Can't open valid SketchUp files

I’m trying to open a previously created Sketchup file using the online version of SketchUp. Have logged into my account, and find a previous SketchUp model in my account (as expected). Then click “Open from device” and selected an existing file from my computer but get this message:
“You’ve selected a large model which may slow down SketchUp or cause other issues.”
I click the “Open” button to try anyhow. The warning message goes away and then… nothing (this file is 6.03 MB).
A couple minutes later I try a slightly smaller file. Same message and still the file doesn’t actually open. I continue trying this and finally do get the size warning to go away, but still can’t get a file to open.

Then I something else: I download and install the SketchUp Viewer 22.0.354 64-bit from Trimble. Try to open any of my existing SketchUp files from my computer and get this:
> This does not appear to be a SketchUp model!

The browser is Google Chrome Version 108.0.5359.125 (Official Build) (64-bit). This is running on Windows 11 Home 22H2 on a Microsoft Surface Pro 8 with 16GB RAM and i7 processor. Should be more than adequate. This is my new computer that I’d purchased to replace a previous one which did have Sketchup Make installed and working.

Okay, next step: I dig out my old computer (Surface Pro 6) and open SketchUp Make 2017. First I try the largest of the SketchUp models that I’d tried opening earlier, and this open with no problem. Apparently it is a SketchUp model after all – the viewer is lying.

So, to recap: With my good new computer I can’t install a free version of Sketchup (no longer available to download in that configuration), can’t use the free online version with my existing valid SketchUp models, and can’t use the Sketchup viewer to at least look at my many home user hobbyist Sketchup models. No way will I pay $299 per year for some other software to try to open these files; this seems like my files are being held captive and unless I pay a ransom, any of the work I did with them over the years is lost. I’m not a professional, don’t do this for money, don’t use it every day or every week or often don’t use it for many months, so that kind of price is out of sight.

There is obviously something about your system that is causing issues. There is no ‘sketchup’ reason the web version or the viewer would not open an older file.
It may be the browser, the graphic card, the version of windows or a combination of those.
Check that you graphic card driver is up to date, do not trust windows to tell you it is. Try a different browser, Firefox or Edge for example. Check for windows updates. A new computer doesn’t come with the latest software, often been sitting in storage for months so updates are needed.
Don’t jump down my throat if you have done all this as I am only offering known possibilities.

As for the free 2017 Make, Trimble left a downloadable copy of the installation file available for several years on their official download site and have only fairly recently removed it. There have been many recommendations to download a copy and keep it safe for future use. You may even still have the install file on your old PC.
Even if you did want to spend the money for a licensed version I would suggest you shouldn’t until such time as you have resolved the issues with your PC.


I figured out the problem. Here is what I wrote to SketchUp support:

I think I now know what the issue is, and let me share that with you now. Sorry, I’m going to be detailed, and that will make this a bit of a long story.

First here is the executive summary:
The files I’m trying to open on my computer aren’t really there.

I’m actually using a new computer, and definitely up to the task. However, the files I’m trying to open were created on my older (but still capable) computer. That other computer is backed-up to my Google One cloud account using Google’s sync utility. Ideally, the new computer would run the sync utility and then it would have access to all the same files. As such, I have the same directory structure on the new computer and all the files appear to be on it…

But not really.

The files are actually placeholders, kind of like shortcuts. There is an icon and a file name and metadata but none of the rest of the file contents. They are ghosts of the real data. Why? One reason is to save space on the new computer (or any other computer that shares the same cloud data set, including a smart phone or other space-limited devices). Also, this stops a flood of data over some network connection that would saturate it for any other usage for an extended period. Best just to leave the data on the cloud storage until needed. This is the standard operating procedure by default for many (most?) cloud storage, certainly for Microsoft’s One Drive product (which I use at work) and apparently also for Google.

Well, when I was starting to send you a reply (this message) with the requested log file, I thought, “Hey, maybe she could also benefit from having one of the actual SKP files that I’m not able to open.” So, I tried to attach a second file, choosing a reasonably-sized 140 KB file from my SketchUp folder… and then got an error from Gmail that it couldn’t attach file that file. Hmmm, the log file attached fine, so what was the problem with the SketchUp file? This pointed to a deeper problem.

Then I thought, "Hey, let’s try copying my SketchUp file folder to a different location, just in case there is some file or folder permissions problem. I selected the entire data folder (created SKP files, not program files), selected the copy tool, and then tried to paste this within the “C:\temp” folder.

Nope. This is the error I get: (see attached)

Well, that’s interesting. At this point it dawned on me what must be going on. I checked, and sure enough, the Google sync utility isn’t running on my new computer. As a result, I’m not getting the entire dataset available to me, and the placeholder files can’t automatically retrieve the file essence from Google.

I suspect I turned this off on-purpose when I took the new computer with me on vacation to Australia last month, so I didn’t accidentally rack up some huge data transfer bill, but forgot it was off and hadn’t bothered to turn it back on.

This would also explain why the online version of SketchUp isn’t working with these files… there’s nothing there with which to work. I had wondered how in the world both the SketchUp on my computer AND the online version could both be temperamental about these files, but the same files on an older, less-capable computer could work fine for both modes of use. But this now makes perfect sense.

Would have been helpful if Windows or Chrome or the SketchUp website could have alerted me to the empty nature of what I was attempting to upload to Sketchkup’s site, and then I would have been able to figure this out sooner, but this is probably a rare confluence of circumstances (Sketch user + cloud data user + cloud sync turned off + trying to open the placeholder files).

It is not recommended to use files stored on networks locations directly in sketchup. There is a lot of anecdotal evidence that working with a file not saved locally can lead to corrupt files. Many users say it has never happened to them, many others suffer the consequences and lose work this way. Any tiny hiccup in the network connection during a save process can very quickly render a file useless.

1 Like

This topic was automatically closed after 186 days. New replies are no longer allowed.