This does not appear to be a SketchUp model! - please help

Hi there, I am hoping someone out there can help me with this issue.

I have several SketchUp files on Trimble Connect that will not open.

I can see all the files but I get this error when I try to open them “This does not appear to be a SketchUp model!”

I am a SketchUp web user and use Google Chrome.

Not every file is affected as I can open files in the 100-200KB range.

The files I am not able to open are all in the 5-8MB range.

I was able to open some of these files last month but some I have not accessed for several months.

I have:

  • cleared my Cache
  • downloaded the file to my desktop & tried to open it from there.
  • duplicated the file & saved it with a different file name
  • opened sketchup in Chrome incognito
  • tried using another web browser (Edge)

I’m not sure what to do next so would welcome any suggestions.

Thanks

If you download a copy of one a those files and try opening that, does it work? Or otherwise upload the downloaded files here, perhaps someone could look at them and see if there’s a problem.

We have been investigating this. Still not sure yet what is strange about your file, but it does open in the current versions of desktop SketchUp 2021 and 2022. Saving it as another file does not fix it for web use, but select all, copy, new, paste in place, does give you a file that works on web. Try this version:

TestAfterCopyNewPasteInPlace.skp (1.9 MB)

Found out after my post that the file crashes SketchUp on Windows, but on Mac it opens ok. I did the steps I mentioned on my Mac.

The developer looking at the problem managed to make a file that works, that also kept the geo location data intact:

Test-fixed.skp (5.9 MB)