Cant open sketchup file on my pc but the file can be opened on my laptop

hi i use geforce rtx 4080 proart and intel core i9 14900K, i have an old files from my external harddisk that can be opened on my laptop which is asus rog 10750 intel core i7 10th gen, theres some file that can be opened on my laptop but when i try to open it on my pc its shows the bugsplat screen, any ideas what is the problem and how to fix it?

this is one of some files that shows bugsplat right when i try to open it

Are you running 2023.1.xx? I was able to open your model in SketchUp 2024. It shows it was saved as a V8 file and it’s clear there’s a lot of geometry which could drag down a graphics card.

Screenshot - 4_25_2024 , 11_52_23 AM

BTW, please correct your forum profile. The operating system is not ‘2023’

im using 2023 version on my pc as well as my laptop, but my laptop still can open this exact file

Yeah but is it 23.1.xx?

its not

Well, if you aren’t going to upgrade to SketchUp 2024 at least update 2023 to the last release.

my laptop has the same version ( but still can open the file

OK, don’t upgrade. I was just trying to offer something that might help. It certainly wouldn’t hurt. Go to the Nvidia site and make sure you have their latest drivers installed.

i tried to copy the files to other folder and it can opened already, and when i tried to open the file from the previous folder it shows the bugsplat screen, however when i compare the file that finally can be opened on my pc with my laptop, the file on the pc is pretty laggy when i orbit but it moves smoothly on my laptop, any ideas whats going on with my pc?

Typically that’s due to graphics issues. Like I told you, update the graphics drivers. You could also install SketchUp 2024 and try the new graphics engine.

You could also cleanup the geometry in the model.

And soften/smooth the remaining geometry.

That will reduce the load on the graphics card considerably.