Can't open models: keeps saying model created in newer version of Sketchup, even though it wasn't

Have all the old models been updated so that they can’t be opened on old versions? I am try to download models that specifically say that they were last updated in 2014 and 2017.

When I try to import them into 2017 however, I get the message that “This operation could not be completed since the model was created in a newer version of Sketchup” This is blatantly false as per the update date of the models I am trying to import.

Where are you trying to download them from? The 3D Warehouse doesn’t supply files in SketchUp 2017 format anymore. The only supported SketchUp file type is for SU2021 and later.

You can use an extension from the Extension Warehouse called Open Newer Version or you can download the Collada version of the object and import the included .dae file.

Screenshot - 5_24_2024 , 1_00_48 PM

Or, you could just create the object yourself. Presumably you are a hobbyist since you are using 2017 Make. Just make the things yourself.

Historically, 3D Warehouse has given you options to download in a few different versions, and also would offer the model in its original version. I tried a few models, and the original format does still seem to be in the list. If the model was made in 2017 or earlier, you should be able to pick that format from the list. The option to download in the last few versions is removed, because all files that are 2021 or later can be opened in 2021, no need to provide a specific 2021 file.

If the original version of the file is not 027 or earlier, download as Collada, and when you import that into a new model, make sure to go into options and choose to merge coplanar faces. It then will look as good as it would have done if you had downloaded the SKP version.

One of the models I was trying to download was a scissor truss from enmnomad. It shows a modified date of 2014, and when I click download it gives me the option of Sketchup file, but when I try to import it, it says it was created in a newer version which is not possible if it was updated in 2014.

The only SketchUp file version available for that is for 2021 and higher. As I told you, download the Collada version and import the included .dae file into SketchUp.
Screenshot - 5_24_2024 , 5_39_42 PM

I was try to download them from 3D Warehouse, and the model specifically said is was last updated in 2014. To me that means that I should be able to open the Sketchup file in 2017. One of the files was a scissor truss from enmnomad which has a modified date of 2014. To me this means that that model was created on an older version and should therefore open with no issues on 2017.

I will try your and Colin’s suggestion of opening it as a collada file. Thanks to you both.

Well, that’s not the case. The 3D Warehouse is only providing the one version of the file.

no.

it means the author last updated it in 2014.
it means the model hasn’t changed since 2014.
not that it is a v14 file

on the server however, the warehouse is not going to keep a version 14, 15, 16, 17, 18, 19, 20 and 21 (versionless)
As the versions officially supported (22 - 23 - 24) all work with the 21 versionless file format, that’s the format you can download.


you could also check the extension warehouse, both su4u and Eneroth have free extensions that allow you to convert newer files to older versions.

For interest, here is an example of a model that was uploaded as 2014:

Its download menu looks like this:

The SketchUp 2014 File option does download the original 2014 format SKP.

In the Filters section is a year slider, where you can set a range of years for when the model was created. Here are all of the scissors made before SketchUp 2018 was released:

They all have the option to download the original format SKP.

Ok, I see. So even though the model says it was last updated in 2014, it does not mean that the person who created it didn;t upload a new version later on?

I wonder Colin if you can download that because you’re a SU employee, so you can get the original file.

because I’ve tried the scissors.
and none of them allows me to get anything but the versionless file.

I’ve checked the oldest files out there, same. just the SU21+ file even for a 2014 upload.

1 Like

That could be, I don’t get the option when signed in with Microsoft. I will complain to the authorities!

I suspect planned obsolescence. Prove me wrong Colin of sketchup team.
I was 3d printing back in '14, with sketch up 5.0.260.
While I have upgraded by HD since then, My set up is almost exactly the same:
same computer (some minor repairs done by parting out identical laptops)
Same exact installation of sketch up. unmodified.
Same OS (win 7 with high level security feature: only spend cash and use gift cards)

I’m trying to load my personal models that I made. The files are all dated 2014. Yet strangely, I’m told that they were created by an unknown newer version of sketchup and I need to upgrade.

Don’t believe this BS “file repositories must have updated their models” Why would they bother to convert old files to make them less compatible??

My problem is that I didn’t pay the subscription fee. At POS we are told we are buying things but according to the EULA we are no longer allowed to own anything. The whole world is a company town and you gotta pay your rent.

the warehouse moves in 2014. so they transferred all the files then. did they import the original files or did they convert back then already ? who knows.

in 2021, they introduced what they call a “versionless” format. there is no more SU21 or SU23 file, since 2021 there is only SU file.

these versionless files have a better compression, so much better that the same projects are about 50% of disk space.
Now, I wonder, what could prompt a company to convert all 5 Millions models from the warehouse into a format half as heavy ?

but then again, It’s only my suspicion here.


or you could just use su4u free extension that converts newer versions to older ones.

My apologies if I offended - IMO, consumer electronics have not suffered from technological bottle necks since ~2003. I live in San Jose and know many experienced programmers who say new technology no longer improves use, it only enables poor coding. So when I open up “obsolete” software that I run on my computer and it needs an infusion of cash, I get worked up.

Can you help with a free way to start designing?
If there is a versionless format that I can open in sketchip 5.0.260 I’d really appreciate your help on how to d/l models and convert them. I’ve built a raspberry for work and I’m dusting off my printer to make a raspberry case. After d/ling models of the raspberry and peripherals, I’m finding it near impossible to open them in sketch up. I think I had a work around with freeCAD or blender to open stuff in sketchup, but I don’t remember and when I try to convert with online resources, I get .skp files for newer versions.