Can't open models - can't make anything work

Just spent an hour trying to install and use VR Sketch.
I have the extension loaded, but unable to use it on my Quest. The instructions on that site are insane.
Written by a non-native English speaker, in tech speak.
There’s a broken link on the install page too.

I just tried VR Sketch. There are a couple of simple mistakes in the installation instructions. One says to click on “Window” rather than “Extensions” in SketchUp (apparently correct for SketchUp Make 2017). The extension manager actually says, “Install Extension” not “Install”.

Once the VR Sketch for PC extension is installed into SketchUp, you need to install the VR Sketch app from the Meta app store ( I attempted to “send to VR on this PC” before installing the Oculus Quest 2 app and this did not work (SteamVR error finding headset).

I also started the Oculus app on my PC before sending “Send to VR on Oculus Quest” via the Sketch VR extension menu in SketchUp as that is what fixes the errors with SketchUp Viewer (So not sure that is necessary with VR Sketch). That worked like a charm. Installation took less than 5 minutes and I have my model open in VR Sketch.

There is a menu I would like to close and will have to get that figured out.

I put off trying VR Sketch because it is so close to what I would like to make myself… That Unity logo almost brings a tear to my eye!

Dzienkuje VR Sketch!

1 Like

OK, I didn’t have that experience on my Mac or PC.
Install the extension into Sketchup, Download and install the Quest App from Meta App Lab.
Send to VR on this PC (or upload to cloud), enter the pairing number when you are in headset and app and that’s it from memory.

You do need an account with vrsketch to access your models if you are using the cloud facility.

You don’t need to have the PC Oculus app open, just the Quest VRSketch app open.

Hi @DapperDanMan,

Firstly I want to say I am sorry to hear you are having a negative experience with the app so far but I ll do my best to help you navigate some of the issues you have listed here.

Please download the latest version of SketchUp Viewer for VR where we have fixed the issue and the app now supports skp files of version 2021 and later.

This message indeed appears when the app does not detect a connected VR device. I see from your message that you own a Meta Quest 2. Can you confirm that the following is true before you launch the SketchUp Viewer VR app?

  • The Oculus Desktop app is running on your Windows machine

  • Your Quest 2 device is connected on your Windows machine via the Quest Link cable

  • You have launched Quest Link from inside the headset and the Rift menu has appeared

Once the Rift menu is up and running you can then launch the SketchUp VR app from your connected Windows machine and it will show up in your Q2 device.

Please try the above and let me know if the problem(s) persist.


Okay, I downloaded it, and ran the installation.
Am I supposed to delete the old version in Sketchup now? Is it automatically uploaded in the program, and Oculus etc?


“it” is the, “SketchUpViewerVR-2-5-31.exe”, a.k.a, “SketchUp Viewer VR” and it is not:

because “it” is “the program”. An icon “SketchUp Viewer VR” will be created on your desktop. Don’t launch it.

It will be available from within the Oculus app, in the Apps Library, which looks like this:

If the Oculus Home (shown above) does not open in your headset when you run the Oculus app from your PC, you’ll start the Oculus app/Home from the Quest Home (shown below):

Select “Quick Settings” (left side of lower panel, shown in image), and then select, “Quest Link” from the large panel. It looks like this:

That will allow you to launch “Quest Link”. Ignore the word “Rift”. If you only have a Quest 2 connected, then whatever it says is ‘correct’. It looks like this:

If that does not open the Oculus Home (shown above), then your headset may not be communicating with your PC properly. You’ll have to make sure you have it installed and set up before using the Oculus Home and SketchUp Viewer VR. It is available here: Setup | Oculus

If you are not using the Quest Link cable and want to save money, I saw a review of this cable verifying that it works with Quest 2: Anker USB C Cable, Powerline USB 3.0 to USB C Charger Cable (6ft) with 56k Ohm Pull-up Resistor for Samsung Galaxy Note 8, S8, S8+, S9, Oculus Quest, Sony XZ, LG V20 G5 G6, HTC 10 and More : Electronics

When you launch the SketchUp Viewer for VR from the Oculus Home (shown above) you may have to sign into your Trimble account from a web browser. The SketchUp Viewer for VR looks like this:

If you are not logged in, there with be notifications (in red color) that will prompt you.

You do not need to have SketchUp Pro (desktop) or any other version of Sketchup running (including SketchUp Viewer VR) to use SketchUp Viewer VR from the Oculus Home. If you get a brown screen or a SteamVR message saying that the headset can’t be found, stop those processes or restart your computer.


Thanks, I really appreciate the work you did in creating and illustrating this answer.
It’s basically a tutorial.
Well done.
I’ll give it shot in the morning.

1 Like

Let me know if I can help when you give it a go. Also, I’d be happy to hear that you’ve got this sorted out and can use it -reliably, 100%- with customers.

Here’s a recap with a few notes:

  1. Install SketchUp Viewer VR. Don’t run it or click on the icon after it is installed. From my experience that leads to the brown screen and inability to detect the headset. You could even restart your computer to make sure you’re starting from square one.
  1. Open the Oculus app. That can be done by clicking on the icon from the desktop (or running from the PC start menu). Put on your headset to confirm that the Oculus Home (‘white room’) is running. It may make a difference whether your headset is ‘awake’ when you launch the Oculus app. Just note if it is, or is not, so you know what to expect and can reproduce it (I usually don’t wake up my headset because it is easier to see the PC screen to launch Oculus without the headset on). If you’re in the Oculus Home, skip to 4.

  2. If the Oculus Home (white room) is not running, then you should be in the Quest Home (whichever you have set up, but the menu is the more colorful one). If you’re in the Quest Home, you’ll launch the Oculus App by selecting “Quick Settings” (left, lower, small menu) “Quest Link” (large panel, right) and “Launch” from pop up menu. If that does not open the Oculus Home, then there is a setup issue that needs to be resolved before moving forward (e.g., cables, ports, software). Also, there are a couple of file sharing permission windows that may pop up. You want to share files and allow.

  3. From Oculus Home, find SketchUp Viewer VR in the App Library. Launch it.

  4. Log in to Trimble from a web browser. I use multiple monitors so this isn’t a problem for me. But if Oculus or SketchUp Viewer VR has taken over your PC monitor, take off the headset. If that does not ‘release’ the monitor, use ctrl + alt + delete, open task manager, to release the monitor (don’t stop anything - opening task manager just happens to be a way to get your monitor back so you can log in to Trimble).

@3DxJFD thank you for providing these amazing instructions.

I have one more update for you. We just released the 2.5.31 version of the SketchUp Viewer in the Rift store as well:

That means that once you have connected to the Oculus Home (Rift mode) you can go in the Store and look for SketchUp. The version that you will find there is the latest one that is also available through our download page.

Hope that helps,

Hi Aris, thanks for the nice feedback.

I noticed that it says the supported platforms are Rift and Rift S. The description says, “SketchUp Viewer for Oculus…”. I switched to Quest Pro and searched, “SketchUp Viewer” and it did not show up in the search results. Since I installed it (from the link you previously provided), I know it does work (as you said) on QP.

I’m not all that familiar with Meta ‘stuff’ and I think they created a bit of a naming mess lately (e.g., Open the “Oculus app”, from “Quest Link” and launch where it says, “Rift”. Try a new Meta feature, just say, “Hey Facebook”). I use the terms “Oculus Home” and “Quest Home” even if this isn’t quite correct.

It seems like SketchUp has a similar problem with naming (I’ve probably misused names here).

For example:

SketchUp Desktop Viewer
SketchUp Viewer for WMR/HoloLens
SketchUp Viewer for Oculus/Vive
SketchUp Mobile Viewer Android (AR/VR)

I realize that these are all “Viewers”, so the names make sense. But maybe “XR” would be clearer? For example, SketchUp Viewer for WMR/HoloLens means basically the same thing as SketchUp Viewer (AR/VR), like the Android version. Also, the SketchUp Viewer for Oculus/Vive (and now Quest) is “Mobile” along with the HoloLens version (though “mobile” means “phone” to many people)… but a larger mobile tablet is better than a phone onsite (larger screen).

SketchUp Viewers:

SketchUp Viewer Desktop

SketchUp XR Viewer WMR/HoloLens II
SketchUp XR Viewer Oculus/Quest/Vive
SketchUp XR Viewer Android (Phone/Tablet)

I don’t know but I presume SketchUp for iPad will be “XR” at some point.

It looks like much of the criticism aimed at “SketchUp Viewer VR” (another name) is aimed at the limitations (and cost). At some point I presume there will be more than just ‘viewers’: SU Pro XR, SU Quest XR, SU WMR/HoloLens II XR, SU Live Components XR, etc. Is “XR” a term that would help clarify products to users? If names are like variables, reducing their numbers is the path to simplification. Of course, SketchUp/Trimble can’t do anything about what Meta does but it looks like more clarity is needed for Viewer/XR users.

This is a little bit off topic (another specialty of mine), but thinking about the SU Viewer for HoloLens, if I recall correctly, an open SU project can be modified, saved and uploaded in (near) real time from the SU desktop extension which is closer to an actual XR experience in HoloLens than a viewer-only experience. So, a laptop/pc companion (like HoloLens Companion) might be a nice addition as it overcomes some of the limitations of the viewer-only experience. A person could present from their pc/laptop to their headset-wearing guest. Collaboration modes depend on everyone having a headset but I think the more common use case is going to be the small-fry user who presents to fewer people (clients who don’t have headsets), at least for the time being.

1 Like

Works, but the program is the same as before. I don’t see any visual improvement.

I went to the store and searched for sketchup and sketchup vr.
Neither one exists in the oculus store.

I opened your link on my laptop, and apparently I have already purchased it.
Which is ironic since it doesn’t work. And isn’t in the store in the Oculus VR.

So, it sounds like you’re in the “Oculus Home” (white room), but you can’t see the SketchUp Viewer VR app icon to launch (that is already installed)?

I followed Aris’ link to the store (from within my headset) and I don’t own it. But I have it in my downloads folder.

I’m going to make a video of myself installing SketchUp Viewer VR from within my headset and then launching SketchUp Viewer VR. That will take me a few minutes…

Got it working, but there’s no obvious difference between this version and the previous one.
I downloaded VR Sketch and SimLab VR, and both have much better visuals.
The sun casts shadows, and the surfaces which are in the sunlight glow realistically.
Sketchup VR looks like a lego model with light that comes from everywhere.


Again, I appreciate your efforts!
Is there any way to turn on shadows and light in Sketchup VR?

1 Like

Okay, good because I goofed the video. I’ll post those anyway and then reply to your latest post.

Here’s a short vid showing opening my PC desktop from within Oculus Home (some people might not use that terminology… to me it seems clear because you can see the Oculus “O” on the tool panel. I launch the SketchUp Viewer VR executable from my downloads folder using “Run as administrator”.

I just did “Repair” and did not launch when closing the installer, just to show where the SketchUp Viewer VR icon is in the Oculus Home. SU VR loads and then I have to sign in so you can see the prompts in red that I mentioned before. I load their example model. Not super exciting, but here it is:

I’ve seen SimLab’s stuff but haven’t checked lately… is their VR free, or free to try?

In the SketchUp Viewer VR, you’re opening a model from within the VR ‘ecosystem’ and staying there. VRSketch works more like the older HoloLens extension. You have the headset on, but you also have the model open on your PC/Laptop. This makes it way easier and faster to make changes with SketchUp Pro desktop (especially compared to the HoloLens 1 because most of the menus are ‘pinch to click’).

I’m not sure but will check now… my first answer is, “no”. Not from within the Sketchup Viewer VR. One first thought is that the example models are optimized for the HoloLens 1 (not a ‘powerhouse’).

Are you using the SU examples or are you brining-in your own models? If you’re using your own models, I’m guessing you could do some optimizing from SU Pro, save, and then open them in your headset. I’m not familiar with sun/shadows as I don’t use them… try making adjustments to your model, then load it in SU VR. Or, if you have a model with shadows/sun settings, send it to me as I’d be curious to try it out.

I can see in one of the VRSketch videos that they have a SU model opened that has shadows on. Also, it looks like they have a ‘Home Room’ and 'Sky" option for viewing models. One reason those look good is that they are using something like baked lighting inside of their app (the Home Room has lights coming thorugh the windows and the Skybox option is lit)… I just searched the VRSketch forums and am now almost certain they use baked lighting in Unity for their app. If you want something similar with SU VR, you’ll have to test sun/shadows.

VR Sketch respects the shadows set in the Sketchup palette but is also entirely dynamic within VR, you can set date and time of day whilst in VR using the same slider system as SU. You can also set custom skyboxes.

1 Like

Thanks @bifterx - very fancy.

Do you happen to know if they built with Unity Reflect?

No idea I’m afraid. :man_shrugging: