Can't open file due to unexpected file format message

Is this another bug? I can’t open this file either from my desktop or the copy held on my USB drive. Very worrying as I have done nothing ‘untoward’ here; all my other files still open. Please help!!!


I confirm that it’s foobar.
It’s corrupted and almost certainly beyond rescue…

These kinds of reports come about almost always because the user has been working on a SKP located on a network or a USB drive.
The recommended way is to use your USB version of the SKP as ‘storage’, and to copy that SKP onto your PC, work on that SKP using SketchUp installed on your PC, save it onto your PC as you continue.
When you are finished copy the PC’s SKP onto the USB - either overwriting its SKP’s current version, or probably better, saving as an incremented version - at least then you have a backup.

When you want to remove the USB-drive ‘eject’ it to ensure the copied file has completed.

Working directly on a SKP on a network or USB might usually work, but any glitch as the data goes down the wires is like Russian-roulette - unfortunately it looks like this time there was a bullet in the revolver’s chamber…


Many thanks.
Ok. So (in layman’s terms): I work on the file on my PC, not from the USB. Got that; I almost always do this anyway as the programme seems to run faster working ‘directly’ into the PC.

When I’m done I normally just drag the file from the desktop straight into the minimised USB widow, whereupon the computer asks me if I want to ‘overwrite’ the copy that’s already there from earlier on. I don’t change the name as I assume the computer identifies it as the ‘USB version’ and that is sufficient of a difference?

I’ve had many problems with Sketchup historically, but this is the first time this has happened in over 8 years!

Final point: did you advise to change the name of the ‘back-up’ because the problem is rooted in what the file is called?

The copying of the SKP to the USB will overwrite the preexisting SKP by default, unless you deliberately react to the overwrite warning and choose ‘compare’, and then tick both files’ boxes, then the added copy gets an incremented numerical suffix added to its file-name to NOT overwrite the existing one[s]…

I haven’t yet found a way to recover these files, but we have some internal tools to at least get the components in the model. For what it’s worth, here are your components.


1 Like

Thanks, but it’s just a completely empty screen! As far as I can recall I didn’t create or import any components here, guess that would explain it?

Thanks. As I say: this is the first time I’ve ever come across this, and it has scared me sh*tless being so close to the completion of the project. I’m pretty lousy with anything Sketchup-wise, but have learnt over the years to side-step the bulk of its more tedious ‘characteristics’ to produce models that still LOOK pretty good in animation & video. Look forward to this, hopefully, not happening again… ( :o S ))

Every time I have tried to recover files the scene is empty. You need to look at the Components panel, and click the house icon to see the components in model. There aren’t many components in your file. Here’s what I see.

Thanks. To be honest, I don’t know what or where the components panel is! Not to worry, as I have managed to re-generate the model from disparate bits & bobs I have scattered about in other files.

As before: this has scared the cr*p out of me and I am still baffled as to why it has happened now and not before. All I can think of is either the recently imported mannequin I pulled in from Sketchup 3D Warehouse brought some junk with it, or that my USB pen is faulty? The latter has cause some issues in the recent past. Could this be it?

Take a tour through The Sketchup Fundamentals This is wealth of info and it is innteractive.

Thanks. Touchwood, I have not encountered this problem again since the weekend. I am meticulous (as ever) in saving these files regularly throughout the period during which they are open and being changed or added to. To this end I only retrieve, work on and then save each respective file to the desktop on my main PC. I followed the advice of a forum member in backing up copies of these documents on USB using the ‘compare’ option as opposed to my original practice of simply dragging the file in and letting the overwrite function do its thing.

The thing is, I am now almost diffident when it comes to ‘touching’ anything I still have stored on USB! What is the risk here? Put another way: when a USB file is open and being ‘worked on’ is this taking place actually ‘on/in’ the computer or do elements of the file remain on the USB? I ask, because somebody advised that problems can develop as a result of the link between the two. I have noticed that it takes considerably longer to save a file to USB, but is it only at this stage that the ‘re-connection’, with all its potential hazards, takes place?

When the file is opened from a USB device it is not transferred to the PC, The time when the file is being saved is when the issues can happen. It has been pointed out that some people can go for years working like this and not have an issue.

It is ok to store a file on a USB device. Prior to opening the file move it to the dektop. When you are finished with the file save it in SU then move the file back to the USB device.

1 Like

This is why Sketchup is so confusing. I can find no reference to ‘moving’ a file from USB, only ‘copy’. If you simply drag the icon the PC assumes ‘copy’ by default, then replaces/over-writes. A file on the desktop can be ‘moved to USB’, then the icon obstinately remains where it is after you click that option!

I note your comment re: folk working in a certain way for years and ;getting away with it’, that pretty much describes me! While we’re on the subject of Sketchup’s penchant to confuse, why is it that the icon representing the file does not update in appearance until & unless you copy it back and forth from USB to desktop?

It may have something to do with the quality of the USB device itself or a glitch on the PC side of the process.

The answer to that one is above my pay grade.

This is not a SketchUp feature. It is basic file I/O of the operating system.

Since you have not filled out your forum profile (to tell us what Operating System you are using) I cannot be sure this information will help you.

MS Windows uses modifier keys during the file drag to let the user decide (ie, an override) whether to Copy or Move.

For example dragging a file within the same folder hierarchy, on the same drive, will default to Move (but the user can override by holding down the CTRL key if they’d rather Copy the file.)

But dragging a file from a location on one drive, to another drive, will default to Copy (but the user can override by holding down the SHIFT key if they’d rather Move the file.)

The file icon changes when the user holds a modifier key, in order to keep the user informed of what kind of file operation will be performed (ie, Copy or Move.)

This again, is basic computer usage which used to be presented in a Getting Started tutorial that used to be distributed with MS Windows up through XP (I think.) It was dropped when Win6 came out (ie, Vista and higher.) I’m not sure now where computer newbs go to now learn the basics (ie, manipulating windows, creating shortcuts, using files, etc.)

Again, this is a feature of the operating system, not SketchUp. The thumbnail image for a SketchUp model is embedded within the SKP file. This image is updated when you save the model inside SketchUp (if a box is checked in the Model Info dialog.)

If you have an old version of the file on the USB stick, then the OS will display it’s (old) thumbnail image, whilst displaying the new thumbnail image for a newer version that you might still have on the Desktop folder.
This is one of the main uses of the thumbnail image, … seeing that one model file differs from the other.
The OS is just doing what it should do which is blindly displaying the internal thumbnail image from each file. The OS does not know that the file on the USB stick is a some version copy of the one in the Desktop folder.

So, until you overwrite the older version of the SKP file, it’s thumbnail image cannot be updated.


I’m not trying to stray too far off topic, but if you’re using a USB to go back and forth between two machines, instead of manually dragging files around, I would turn to file a syncing utility to make it easier to do and harder to screw up. On a Mac, I’ve used Synchronize! Pro X for such tasks for more than a decade, but I see on their website there is no plan for a 64 bit version which means it dies with Catalina. Carbon Copy Cloner seems to be thriving and is probably the best known. I’m sure there are others, and someone else would have to suggest what’s out there on Windows.

With such software you sychronize folders with a one button click. The software takes care of tracking what has or hasn’t changed since the last sync, and if both changed, alert you to decide which to keep or both.

1 Like

MS Windows used to have a built-in Briefcase feature for syncing files between a notebook and a desktop computer.

It seems they removed it when MS started promoting cloud syncing via OneDrive. (ca. Win 8?)

Thanks guys; more discussion going on here than we’re currently having to endure with brexit!

All I can say is that the accursed thing, for the moment at least, is behaving itself - just hope it stays that way until I get the project finished. As most of you well know, I haven’t a clue what you’re all talking about most of the time, but your input is well appreciated.

‘Moving forward’ (arf) I will confine all activities to the main PC unless there really is no conceivable alternative. Otherwise, I think I’l invest in a new USB pen before I attempt to cart stuff about from here to the laptop in clinic.

As always, an edifying if perplexing ‘window’ (sic) into the world of CAD. Hope someone buys me a pallet load of wax crayons and a flagon of Scotch for Christmas! That’ll be my ‘default programme’ for owt that still needs designing in 2020!

it’s edifying to tIt is re-assuring to see that there are (as always) folk out there who d*mnned ea

Yeah, ignore this bit…[quote=“spogadog, post:18, topic:109078”]
it’s edifying to tIt is re-assuring to see that there are (as always) folk out there who d*mnned ea
Can’t even use a word processor…

Get one from a known vendor that has good quality, might seem expensive but… This is My Go To Drive , hasn’t let me down yet.