UNEXPECTED FILE FORMAT, help!

Hi there,

I’m getting the unexpected file format error…I have tried changing skb to skp and it didn’t work. I use 2018 Pro at the office and have 2019 at home. I might have changed the “save as” when using the office 2018 version to save as 2019 to open at home or maybe the other way around. I can see my drawing in the window pane so I know its there it’s just not opening and I cannot figure it out. Is there anything someone can suggest or even take a look at my files?

Are you trying to open the file in SketchUp Pro? Have you tried importing it vs opening it? Is the file something you can share? Posting it here will allow us to take a look at the file and see if there is an issue, or attempt to open the file ourselves.

Here is the file!

Uploading: Stage 7.04.20 (2).skp…

Your file looks as if it didn’t finish uploading. Try again.

If it is too big to upload, share it via a filesharing service like Dropbox, OneDrive or WeTransfer and post a link here.

Sorry, the file uploaded, but won’t open for me in SU 2020.1.

It says “File not found or invalid”.

Someone from the Sketchup Team might be able to look inside the file and see if it’s fixable. But I can’t.

@colin, perhaps?

I tried, but couldn’t get anything out of the files.

I have multiple files…do you guys have any suggestions?

Unfortunately, experience is that it is only very rarely possible to salvage a file that fails this way. It depends on just how the file was damaged. Sometimes a portion, such as component definitions, can be recovered. But all too often the file is filled with zeros, making it useless.

Are you using a file sync system to share the files between office and home? If so, that is likely to be the source of the failure. Saving to anything except a local drive is known to risk this failure. Evidently it has something to do with how the sync service and SketchUp both try to lock the file, but the developers have yet to come up with a reliable fix.

I uploaded more files…not sure if any of these will possibly work. I put so much time into these and really hate the idea of having to re do it if at all possible.

With one file I got back a couple of components, two files I got lots of components, and one file I even recovered the scene.

1 Like

While this doesn’t help with the currently corrupted files, it’s worth knowing your process so this doesn’t happen to you again. A few questions…

  • Where are you saving the files?
  • You mentioned changing SKB to SKP, are you actively using SKB files in your workflow (hint: don’t, it’s a backup file)
  • How are you transferring these files from work to home, and back?

This isn’t a terribly common issue to come up under normal circumstances, so it seems likely that somewhere in the saving, moving and opening processes is the issue.

Pretty sure he meant that he tried renaming the skb file to see if that would open. I tried that too, and the only skb that I could recover I was also able to recover the later skp.

Well I’ll let him confirm, you know what happens when you assume. And it’s an honest mistake that I’ve seen many times.

1 Like

Yes, I did convert the SKB to SKP and tried importing the SKB just right into sketchup - I tried whatever possible but zero luck.

Did you say you had success opening a file?

Lets go back to my original questions then, please don’t interrupt @colin. :crazy_face:

@njg11, I would love to get this fixed so future files aren’t damaged.

  • Where are you saving the files?
  • How often are you working with SKB or Autosave files?
    • Are you ignoring them unless something goes wrong?
  • How are you transferring these files from work to home, and back?

I have an internal utility that amongst other things does try to recover files. I used that on all of your files, both the skp and skb versions. In my last reply I said what I had managed to recover, and gave this link to those recovered files: