Can't move or rotate my sketchup objects

Hi there,

I am needing help with my model.

It was working fine and then all of a sudden none of my components or items in my model will MOVE or ROTATE.

I have restarted my computer, downloaded a new version, checked components and am needing help ASAP.
Working a a Macbook Pro.

Thank you!!

Share the .skp file with us so we can see what you’ve got going on. Most likely there’s a simple explanation but identifying it would be easier if we see your file.

You didn’t lock everything did you?

No - nothing seems to be locked (unfortunately).

Ok great will download and send

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

Download from where?

If the file is too big to upload here, upload it to DropBox and share the link. If the file is something you can’t share with the world, send it to my by DM by clicking Message after clicking on my name.

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

Do you know that the file you uploaded is a backup of a backup file and not your original?

So I tried moving and rotating objects in the model. It works here. What were you trying to move or rotate?

I wonder if this is a case of your graphics card not being able to keep up. Try changing the face style to Monochrome so the graphics card doesn’t have to render the materials while you rotate or move objects.

I see a few other issues with your model.

Incorrect Layer/Tag usage for one.
Screenshot - 8_18_2020 , 7_45_36 AM

And a load of unused stuff bloating the file. Removing that stuff reduced the file size by about 58%.
Screenshot - 8_18_2020 , 7_46_45 AM

Lots of incorrectly oriented faces.

Ok no problem,

I just tried to monochrome and still the same issue,

This is the original version

The double tilde in the file name indicates that it’s a backup of a backup.

I have CleanUp3 running right now trying to further clean your file. It appears to be taking a long time but I can upload the file when it is finished. Maybe it will behave better.

What link were your trying to post?

What are you trying to show with that screen shot?

Oh thank you so much,

Trying to post the original version but would’t allow me.

When I try to delete components it also won’t let me.

You need to Purge Unused. Go to Window>Model Info>Statistics and click the Purge button.

Is it possible this could be an I/O problem?
See if all your keys and buttons are working correctly in another application.
Maybe worth a shot.


Should I wait for your version to be cleaned or fine doing so?

Thanks Shep,

I have had an issue with my V button not working properly, not sure if this would effect

You could correct the face orientation on your end. Currently CleanUp3 is reporting more than 5 hours left to go.

Goodness ok… I have no clue how to do that or what the face orientation really mean sorry

If one key has been problematic, other keys could also be problems.