Can't Load Files


#1

Hi-

Recently in 2016, when I try to open files, SketchUp goes non responsive. There is a note at the bottom of the screen that says “This is a very long string. How long do we want?” I’ve also noticed that this problem may be bigger than Sketchup, since I can’t delete, move, or open properties of these specific files either. This only happens with some files, and I haven’t been able to see a pattern. Help is appreciated, Thanks.

PS- I have tried rebooting.


#2

how ‘long’ are the filenames?

or maybe material with a long name?

just thinking out loud…

john


#3

Not long at all, one of them is called “tower.skp”. I don’t believe I’m using any excessively long named materials either. Thanks for the reply.


#4

the ‘filename’ includes the disc/directory/sud-directory/ect…/ect…/ect…/my_file_title.skp

there use to be a limit, although I think even MS have moved on from there…

john


#5

I copied one of them to the desktop, and the issue persists.


#6

Do you see this behavior for some files or all the files?
What is the behavior with a newly created SketchUp file with just a cube in it ?
What is the behavior with a model from 3DWarehouse?

Yogesh


#7

Some files I have existing open just fine. Others which were also existing (Including some older ones I haven’t touched in years) do not.
A basic model of a cube will not open, whether I try opening it with 2016 or 2015.
Same thing with a new model I downloaded from the warehouse.


#8

The post seems to indicate you were able to open the files earlier but this problem started recently. If yes, any idea what changed on the machine? Have you tried restarting the computer?


#9

The first time it happened was on February 20, Saturday. I don’t think anything has changed. The only thing would be I was having trouble running an older game that requires compatibility mode and a much lower screen resolution. I have tried restarting.

Also, I just moved one of the files to a different computer and it opens fine. The problem definitely seems to be localized to this computer, but affects both installations of SketchUp (2015 & 2016).


#10

I just started receiving this message as well. Files are still loading, but sometimes even simple files take a great deal of time.


#11

How long have they taken? I gave up when I saw sketchup was unresponsive.


#12

15-30 seconds, typically. I don’t know if that helps much … I’m just looking for the same answer you are.


#13

I thought the issue was resolved today- I can open one of the files I
couldn’t yesterday, but others still freeze up.

I’m beginning to think it has to do with the file system. The files I can’t
open, I also can’t move, delete, or view properties.

Anyone have any ideas???


#14

I tried uninstalling SketchUp today. When the program is gone, I can open properties, move, etc, but as soon as I reinstalled SketchUp, the problem came right back. I just uninstalled again, and removed all the program files, and did a CClean. We’ll see if that helps.


#15

Do you use a lot of extensions? Have you tried disabling them to see if that helps?


#16

I do use a lot of extensions. However, I just reinstalled SketchUp 2015, no extensions loaded, I haven’t even opened it yet, and all .skp and .skb files are locked again. Layout files seem to be OK though.


#17

What exactly you mean by locked? Are you seeing an error message?


#18

No error from Windows. If I right-click on the file and select properties, it just doesn’t do anything. Same if I try to move it to a different folder or delete it; it just doesn’t do anything.

In SketchUp, if I try to open it, the program immediately becomes unresponsive and a note appears in the status bar at the bottom of the screen saying “This is a very long string. How long do we want?” and then never opens.


#19

Thank you for bringing this up, I have had similar problems. Recently while (trying) to learn SU, I did a fairly detailed drawing of the bsmt in my house in 2016. For a “nube” it involved lots of work. Later, for reasons that escapes me at the moment, I decided to open the file in 2015, at that time I was informed that I can’t open a '16 file in an earlier version. Well I solved that problem, did the drawing again in '15 and stopped using '16. :grimacing:


#20

That’s an entirely different question. SketchUp’s files are always version-specific and can only be opened by versions >= the one that saved the file. But every version of SketchUp includes a Save As option to save the model in any prior version’s format. To open a file from 2016 using 2015, just Save As 2015 first.