Can't get Unhide Last to Work


#1

If I do a succession of hides on various objects or groups and then hit Unhide Last it unhides everything not just the last hide. I don’t remember having this problem previously. Is this broken in 2016 or is their some definition or qualification of “last” that I am not understanding and fulfilling?

And talking of hiding is there any way I get the irritating splash screen not to pop up every time I start Sketchup? There used to be a ‘don’t show’ checkbox but It seems to have disappeared.


#2

I haven’t see the issue you report with Unhide Last. What are the entities you’re hiding/unhiding?

As for the splash screen, there is a “don’t show” check box IF you are using SketchUp Pro. For users of SketchUp Make, you can’t turn off the splash screen. It’s been that way for years. A very small inconvenience for having SketchUp for free.


#3

I haven’t seen this issue either until recently. Not quite sure at what point I started to notice it. It works (or doesn’t actually) for any entities. Can be shapes, lines, groups, any kind, hidden in any order - no matter what when I hit Unhide Last everything previously hidden becomes visible.

As for the splash screen … point taken. :o)

I used to use Sketchup at work where it was the pro edition where the splash screen could be turned off, now I use it alone at home I use the free edition and find I can’t. I hadn’t appreciated the difference simply lay in the different editions.


#4

Have you installed any extensions recently? I wonder if there could be one that is impacting the Hide/Unhide operation.

After using Pro for so long, I would have a very difficult time going to Make.


#5

Only extension I have apart from those which come with Sketchup is 3DConnexion 3DMouse/Joystick. It is hard to see how this could impact. Apart from a few personal keyboard shortcuts I am using a standard Sketchup. I can easily delete these and re-instate them just in case that is the cause. In fact yes - I wonder - one of my personal shortcuts is Unhide Last. Seems hard to believe that that would cause the problem but I’ll try fiddling a bit.

What does seem clear is that I appear to have a problem. It’s not my misunderstanding how the tool works.

Maybe I’ll bite the bullet on a clean re-install and see if the problem is gone. Then add the 3D mouse extension and shortcuts and see what happens.


#6

A reinstall will not fix bugs like this (if it is a bug.) And you’ll need to reinstall the 3D Mouse drivers after re-installing SketchUp (most likely.)


#7

I am beginning to think I do have a bug.

I have just done a completely clean reinstall after removing all Sketchup configs, support, prefs, etc. (including the third party mouse driver) from the libraries. A fresh virgin vanilla install still shows exactly the same behaviour. I can draw any kinds of lines and shapes, grouped, ungrouped, singly or multiply selected, hide in any order one by one and ‘Unhide Last’ will unfailingly unhide everything.

If this is happening on a completely virgin install it really does look bug like. I cannot conceive of a hardware issue that would spark just this one problem …

Ho … Hum … Doesn’t look like a lot I can do about this one. :o(


#8

I just tested in v2013, v2014, v2015, and v2016. Works the same in all versions.

All successive hides are grouped together into one hide operation.

But, if you interrupt the hide actions with some other tool, ie, draw an edge, etc. Then that will “close” the hide actions before the edge was drawn, and any hides after will be in a new hide operation.

ADD: BTW, you can hide one item whenever the Edit > Undo says “Undo Hide


#9

Thanks for the clarification. I don’t think I’ve ever just hidden entities in succession like that. If it was more than one thing I wanted to hide, I would select all of them and hide them together.


#10

Aha! Then that goes back to my first post. It revolves around what qualifies as “last”.

Ok that’s really clear DAN. I’ve got everything back and running (including mouse drivers and shortcuts) very quickly after the clean install and it indeed works as you say.

Strange I was never bothered by this before. I must have changed something in my working pattern without realising for it to have emerged just recently.

Another day older another day wiser.

Thank you all for your help.


#11

Sorry I did not get time to read the answers. the work around is to view hidden geometry then unhide intended.


#12

Yes I can see all the items if I view hidden - but cannot unhide them


#13

In other 3D programs I can get all hidden items to unhide with a simple keystroke - why can’t sketchup do it


#14

Are the hidden items inside a component or group? If so, you’ll need to open the component or group to get at them and unhide them.

It can if you’re doing it right.


#15

This indicates the hidden geometry is inside a group or component it
possibly inside a hidden component on a layer that’s switched off. Go to
layers turn on all layers. You may need to triple click the component then
right click unhide. If the group or component is inside several you may
need to continue drilling down to unhide.


#16

That worked - once I was able to select the hidden geometry mesh and right click to unhide.

thanks