Can't find where to login into my SketchUp Shop!


#1

Greetings.
Yesterday I subscribed to SU Shop. But when I tried to login it wouldn’t open. So I restarted my computer, and now I just cannot find the login page. SketchUp homepage has no login–When I cannot see any.
HELP!
Thanks a lot.
MarieH.


#2

Click the hamburger (web) menu label (1) in the image below …

image

… then go to the account page. It has the image icon.

But if you are already logged in here, you should be already logged in to Shop.


See this post …


#3

Thanks Dan,

Actually, I eventually followed your direction to your previous post, and that worked, BUT, now that I am logged in SU Shop, I cannot open it. All I get is a white page with the pulsating logo. After an hour or so it still wasn’t open. Any thoughts?

Many thanks.

marieH.


#4

I am not a Mac guy. You are running El Capitan ?

What browser ? If it doesn’t work in one, try another browser.
Works for me in Chrome. Others use Firefox.


#5

Thanks Dan. Didn’t work either with Firefox. I keep going back to SU Free.

But I think that there is a much bigger issue that might be at the root of all this. I just realized that there are two names for my account. And that’s because I gave them a different name for my account and for my credit card. When I subscribed, I remember having issues because the system didn’t seem to register that I have a name for the account: Marie Trope Zanzal (my new married name), a name for the credit card: Marie H. Trope-Podell (my previous married name, still working on changing this) and a name for my organization, which is me as MHTZ. MHTZ was never saved. And, as I also just discovered, I was billed twice for the subscription, which I assume is a confusion I encountered while subscribing.

Do you deal with this too? Or should I wait for Monday to bring this up to the “Team” via phone?

MarieH


#6

Sorry, I do not work for Trimble. You’ll have wait until Monday and contact Customer Service.


#7

Thought so. Thanks anyway.

Best,
MarieH.