Can't export DWG files from SketchUp 8. SketchUp says export went fine

dwg
export
2d-export
#1

I use (very old version, I know) Sketchup 8 Pro on a Mac iOS. I export dwg 2000 files all the time, I have even done it with this file before. I press export and SketchUp thinks for maybe 1-2 minutes (normal speed for my computer) and then it says “Export OK” like it always does, but no file appears in the folder I have specified, and tried looking the name up on my computer, but the file doesn’t exist.

I have tried turning off all the layers I don’t specifically need.
i have tried exporting .pdf .png and .jpg - they all work
I have tried turning programme and computer off and on again
tried deleting a car from SketchUp warehouse (presumably with a lot of lines in it), didn’t do anything different
tried exporting a frame only with a few lines in it to see if it was because my drawing was too heavy, but the file still doesn’t appear in the folder.

I only need the file to get perspectives right in a photoshop drawing I am doing, so it is extremely messy though - but it has worked perfectly before, so I don’t get it.

No really used to posting here, sorry if anything is missing.

0 Likes

#2

you can test the functionality using ‘Window’ >> ‘Ruby Console’ and copy/pasting this…


model = Sketchup.active_model

model.export(File.expand_path('~/Desktop/test_export.dwg'), true)

then press ‘Enter/Return’ key…

if it’s successful, you have a ‘save path’ issue, if not we need more info as v8 is a dim memory for most of us…

john

0 Likes

#3

Hi John, thank you for your answer!

I typed in the text and is said first in a pop up window: “SketchUp: This model contains one or more Groups or Component Instances that contain non-orthogonal transformations. Such transformations cannot be precisely mapped into AutoCAD and have been approximated”

then another pop up appears: “Skp2Acad: AutoCAD export audit : OK”

The “true” appears in the ruby console under the text i pasted ind.

–> it seems like i have a save path issue, right? how do i go about solving it? Let me know if you need more info, and what kind.

Thank you for your help (:

Simone

0 Likes

#4

did ‘test_export.dwg’ appear on your ‘Desktop’?

that’s where the code should have made it…

if it did make the file, then the path you use is suspect…

what is the path that fails?

john

0 Likes

#5

Yes, it made the “test_export.dwg” on the desktop! and i just did a real export to the desktop :wink:

omg, I didn’t expect the path to be the issue since it exported .pdf’s and .jpg’s just fine. Thank you!

(i am not including the path since it contains lots of info on me and the project. But it was a new folder I created for this final stage of the project. It only dawned on me right before that I haven’t exported a .dwg to that folder before.)

THANK YOU! :smiley:

0 Likes

#6

my wild guess is your path contained a ‘:’ and the standard exporters for images didn’t mind, but the code used by ‘Skp2Acad’ has issues with illegal characters…

john

0 Likes

#7

No, there were none of those :b The final folder contains a space and a “/” that might be what it was?

0 Likes

#8

for ‘safe’ filenames [ i.e. the full path ] only use…

  • a-z
  • A-Z
  • 0-9
  • underscore (_)
  • dash (-)
  • period (.)

avoiding spaces is even better, but even OSX uses them for some folders…

john

0 Likes

#9

The slash is a character that shouldn’t be used in file or folder names.

0 Likes