Can't even draw a simple line without a several-second delay


#1

I used to use Sketchup all the time, and it ran perfectly with no lagging. On this computer. A few months ago, it became extremely slow, on the same files I used to be able to work on with no problem. These are not particularly complex models. No other programs are having issues. I’ve disabled rubies, no help. I’ve reinstalled twice. I’ve updated bios and all my drivers.

I can open a new file, and try to draw a line, and it takes three seconds for the line to appear.

Please help. I really need this thing to work again.

Intel core i5-3330s CPU @ 2.70 GHz, 6GB


#2

Might be a Graphic Card issue?
Check that your GC is up to date.

If after a restart SketchUp hasn’t improved check the following [with SketchUp restarts as appropriate]
The GC control-panel is set to allow the 3d-program to sets its own options.
The SketchUp > Preferences > OpenGL various options are set/reset ON/OFF in various permutations to see if that helps…


#3

OMG, I Love you. The graphics card was updated, I guess automatically. When I rolled it back to a previous version, it fixed the problem. Thank you!

EDIT: Spoke too soon.


#4

OK, I spoke too soon. After I rolled the graphics card back, it worked fine for about a minute. Now, same problem. I tried reinstalling the driver update, and it didn’t help, so I rolled it back again and that didn’t fix it.

I’m not sure how to get to the graphics card control panel.


#5

What is your GC ?
Did you try adjusting the permutations of the Preferences > OpenGL settings ??


#6

Intel HD, 1792 mb.

I couldn’t find preferences, but I just looked again and found it (under windows, for future peoples.)

Unchecking all the boxes worked.

You’re a genuis, TIG. Thanks!


#7

Do you mean Intel integrated graphics chip?

When you disabled ‘Use hardware acceleration,’ in SketchUp > Window > Preferences > OpenGL, that means the CPU is doing all the work. The graphics driver is not contributing anything. The graphics driver for the integrated graphics has OpenGL function call deficiencies.

As your models become larger, there may be a greater lag problem. Depending on the driver, you may be able to use hardware acceleration but disable fast feedback without too much ill effect.


#8

I really don’t know what’s in this computer. I’m not very tech-y. All I know is it says “Intel HD.” It’s a Dell all-in-one desktop, about 3 years old.

When I turn on Hardware Acceleration, I get huge lags. I can leave on the fast feedback as long as I turn off hardware acceleration. It’s still not as fast as it used to be, but it’s back to being usable.


#9

Fast Feedback does absolutely nothing when Hardware Acceleration is off. With some graphics card driver versions, turning Fast feedback off will stop some screen artifacts like mouse trails while allowing you to keep Hardware Acceleration on and with practically no degradation in performance.

Anssi