Can't edit component name/definition in entity info all of a sudden?

Hi. I’m working on a house model and specifying names for windows after having put them in the model. It’s not letting me edit the names or definitions of them in entity info, seemingly out of nowhere. When I try to add a letter to the name nothing happens, and when I try to backspace it simply deletes the components. I can manually edit in the component window but this is cumbersome. Any ideas what’s going on here?

Kindly update your profile information.
Indicating which version of Mac OS X you’re using will help others help you.

done :slight_smile:

1 Like

what exact steps are you taking as there some ‘gotchas’ with mac input boxes…

click in box >> type new name >> click outside of box [do not click enter/return]…

does that work?


Apologies if there’s a more recent discussion on this topic but I am having the same issue in 2017 v. Cannot click into the Definition box in Entity Info. Any thoughts as to what may be causing this?

Share your .skp file so we can see what you are working with.

Alcove wardrobes - Bowes.skp (2.7 MB)

I tried your file on my Mac under 2017 Make, and I can’t reproduce your issue. There has been no change to 2017 in four years, so what else may have changed in your Mac?

1 Like

It seems a restart has solved the issue folks but thanks for the feedback.