Renaming components

componentname
name
entityinfo
components

#1

Sketchup.
Now I started to use outliner, name components and groups. It is great if you know how to use it. I hope I know basics but it also seems to me that there is a bug or my intuition fails.

if I make a component in a hurry, the program assign default name. Then I want to edit and group and problem arises.
eg. I had 4 pilons number 1, and 4 pilons number 2 etc. I wanted to rename them sequencially but program refuses. Temporarily it accepts but later renames to previous or to other one. So I end up with names like: Pilon 01 <04>. The first part is ok but the second part is confusing. I want to get rid of <04> part entirely and am unable. I’ve tried to gave same number ie. Pilon 01 <01>, it accepts temporarily and switch back to original. At times I was able to delete or rename the component name in the component info window. I think it sometimes allow and usually does not and also window appears that it must be a unique name. It confuses me a lot.
I’ve watched some videos on Utube on this subject but they say, you can edit. But I cannot.
Perhaps I did not explained well. In the info window, the component name, no problem, can change, but not in component definition lane. It seems to stuck to the end of the world and produces name in <> brackets. How to get rid of brackets entirely or at least to align names to whatever suits me?
Have Mac latest osx.


#2

I think you are confusing Component Definition with it’s various Component Instances. In the Component inspector window the definitions are listed by definition name.

In the EntityInfo inspector window you can enter and change both the instance name labeled “Name”, and the definition name labeled “Definition”.

Changing the definition name, changes it for all of it’s instances in the model. But each instance can have it’s own unique instance name.


But if you insert the same component again from the archive collection (or the 3D Warehouse,) instead of the InModel collection, then SketchUp must make the definition name unique by appending a number. (ie, each definition in the “InModel” collection must have a unique name.)


#3

That I am confused is highly possible.
Some more situation.
I have 24 pilons, arranged in 6 rows, 4 collumns array. When creating I did not care much about naming. So I ended up with 4 instances of “pilon 1” etc. Now when I select a pilon, it lists in the info window that there are 6 not 24 such components. And there are 2 Pilon 2 etc. Even when I renamed then sequentially 01-24.
I’ve learned that I can rename in both windows, in Entity Info, and in Outliner.
I want to learn the right way and to use it to my advantage.
How can I organize it properly even if I had to redo all pilons?
Perhaps I have a group within a group (It seems like) but the Outliner shows only one group Pilons as I want and I expect to have them listed in Entity info as one (number) of 24.
Let me list a few names from a start.
Pilon 01 <05#1>
Pilon 02 <02>
Pilon 03 <03>
Pilon 04 <Component#1>
Pilon 05 <05>
Pilon 10 <02>
Pilon 11 <03>
Pilon 12 <Component#1>

As you see it is total mess. I only need Pilon 01 - 24

Now a few Entity Info.
Name; Pilon 01 ; Definition: 05#1 ; Solid component (1 in model)
Name; Pilon 02 ; Definition 02 ; Component (6 in model)
Name; Pilon 03; Definition 03 ; Component (6 in model)
Name Pilon 04 ; Definition Component#1 ; Component (6 in model)

It looks like they are wrongly named, categorised, defined. And there is no way to rename them. When I change definition, it allow but window appears: A component must have unique name. And brings back an old wrong definition.
When I want to delete all text in definition, this same warning and brings back old definition name.
Maybe should I define as a,b,c, etc and later delete them?

Please help me to define, and name them properly. Oh, they are already grouped in a Pilons.

Thanks


#4

You seem to be fundamentally confused about the nature and use of components in SketchUp. A component is like a template for creating multiple identical instances of some set of geometry. The actual geometry is owned by a single entity called the component definition. Each example placed in the model is a component instance.

When you draw a bunch of geometry, select it, and invoke “Make Component”, you do two things simultaneously: you create a new component definition, and you place a component instance at the location of the geometry you selected. The name you enter in the make component dialog becomes the name of the component definition. If you later select the component instance you can give a name to that one instance in the entity info window or outliner, and in entity info you can also rename the definition.

Here’s the problem with what you are trying to do: when you type a new component definition name in entity info, you are not creating a new component definition and you are not rewiring the existing component instance to a different definition, you are attempting to give a new name to the instance’s existing component definition. SketchUp will not allow two different component definitions to have the same name.

If all 24 of your pilons are identical geometrically, they should all be component instances drawn from the same single component definition. You can give each pilon component instance a distinct name to identify where it is. To make your model use instances of a single definition, you need to delete all of the component instances of other definitions and replace them with component instances of the component definition you choose to keep (for example, you can reduce the work if you keep Definition 02 which already has 6 instances).


#5

Thanks for trying to help me.
In did the way the Sketchup description works is misleading.
When creating component, the name actually does mean definition. And here is a conflict. The terminology should be consistent. It should be “component definition”. Same as in Entity Info.

How I did it. I did not delete anything. I exploded and than created component using consistent terms and all components I “named” but actually defined, as pilons. Then if Entity Info, I named (yes named) individual components with sequential numbers.

I am sure that after some break from Sketchup I will go back to same trap and will use name as name not as they set that name actually does mean definition. Surname is a surname, birthday is not a name, but day of birth. Name is not a definition, and definition is not a name.

So now I have: 01 pilon; 02 pilon; 03 pilon; 04 pilon etc. and now as I redo (redefine) individual components I get correct message 9 in model and it changes as I keep to redefine up to 24.
I’m sure you feel and term it correct, but to me it feels like individual components.
I would wish that terminology was changed to avoid confusion as I already explained.

Thanks for help


#6

Maybe a way to clarify the concepts here is to think about automobiles. “Camry” is the name of a car model. This is like a component definition name in the sense that “Camry” designates a pattern. All Camry’s are examples (instances) of the same pattern (let’s ignore options for this discussion). Your Camry is a separate vehicle (instance) from mine. You can name yours “Old Rattletrap” and that has no effect on the model name “Camry” nor on the name I give my Camry. To reiterate, Old Rattletrap is still a Camry, and there can be other Camry’s with other vehicle names. Having both type and specific names for the same car isn’t a problem.

However, there is, alas, a history of being sloppy about these distinctions in the SketchUp GUI. For example, it is conventional to use the broad term “Component” without drawing a distinction between definition and instance. When you create a new component, the dialog field just says “Name”, not “Definition Name”. When you select an instance of a component in a model, the entity info window just says “Component”, not “Component Instance”. The editable name fields just say “Name” and “Definition” instead of “instance name” and “definition name”. The components browser tries to be helpful by displaying items in the format “instance name <definition name>”, but until/unless you give the instance a name, all you see is the definition name.

The GUI could be tidied up to improve these areas, and that would be a valid feature change request. But they really shouldn’t be confusing if you have a grasp of the ideas involved.


#7

I have another question about this topic. I am running free SU 17.3.116 on a Mac. When I click on a component and open the Entity Info window, I have two field of interest for this question: the Definition field and the Instance field. In the excellent explanation using the Camry above, I would like to delete the “Old Rattletrap” name from the Instance field and leave it blank. No matter how many ways I try to delete the field contents, it never seems to go away. I could just delete that instance of the component and put in a new one, but that seems error prone and inelegant. Any ideas?

BTW, this situation occurs in SU when you are creating or renaming Groups. If you leave the Group “open” with the Group’s Instance field highlighted, then clicking on a component always inserts the Group Instance field contents into the Component Instance field. As long as I remember to “close” the Group before going on to something else or hit the Undo button, it will work out, but I am not always that attentive. This seems like a bug or at least a useless feature.


#8

This is due to the Mac-specific workings, I presume you always have layers named “m” or “p” etc?
Select the instance name, type spacebar and click outside the entity window…

I think @slbaumgartner could explain better then me?


#9

Yes, inability to blank the Instance name is a limitation of the Entity Info GUI on Mac. You can change the Instance name to something real, but you can’t easily blank it out. Here’s a trick that works for me: try changing the Instance name to a single space then pressing enter and clicking somewhere else (clicking somewhere else is necessary in general in SketchUp on Mac because enter leaves the input focus still in the entry field. That often causes errors such as @MikeWayzovski mentioned - though that isn’t specifically what you were asking about ). On my Mac the space gets changed to an empty string!

Groups can cause some confusion because the Definition name is not actually accessible via the SketchUp GUI, only the Instance name. Groups always get Definition names like “Group#12”, and these are not visible anywhere in the standard SketchUp GUI. When a Group is converted to a Component, the Component’s Definition name “inherits” the former Group’s Instance name (if any) and the Instance name is left blank.

Edit: if the group’s instance name is blank, the component definition gets a name such as “Component#2”.


#10

I do not need to press Enter, though…just an outside click is enough


#11

Belt and suspenders!


#12

Henri Fonda? I always liked that quote…:slight_smile:


#13

Thanks Mike and Steve for the good explanations. It is both good news and bad news that I can’t access the Definition name. Good because I didn’t miss something and bad because I can’t do it. The blank space trick works, but doesn’t remove the string entirely on my Mac. I will just muddle along and work around it as needed. Can’t really complain since the tool is free!


#14

How did you determine that the instance name wasn’t actually blanked? I probed via the Ruby console and saw a true empty string instead of the space.


#15

also in the entity info panel :


watch the cursor’s position, the second time I enter the Instance’s name field


#16

The thing that drives me crazy is that after typing a name, Enter selects the name instead of closing the field and ending the process of entering text. It’s such a habit from every other program I’ve ever used for over 30 years, I just can’t seem to get used clicking somewhere in the drawing to end the process instead of typing Enter. I can’t tell you how many components I’ve found with the instance name of “m” because that’s the shortcut for Move, which was no doubt the next thing I was trying to do, and in a hurry.


#17

Yep. That’s been a thorn in the side of Mac SketchUp users through many versions. It happens in most text entry fields. That it doesn’t happen in every field and doesn’t happen in other apps is proof that this is how the SketchUp GUI was programmed, as opposed to something inherently Mac. But no amount of complaining has yet gotten it changed…


#18

I remember the space work around not working on a previous version of Mac OS and SU, but now it works. I think we are all in agreement that the fundamental issue is the way that the Enter key is programmed. If I was King of the World…


#19

Hi Dan,

On a related issue (and not wanting to start another thread)… In SK2018 pro, have noticed that when one renames a “Component’s name” directly in the attributes editor … and then tries to rename the instance … these two fields are no longer “linked” … or it will not update.

This is important particularly when you want to generate a report. It will report two “same components” with different instance names, as you will see in Aaron’s skillbilder example (enclosed).

SB - 2018 Model.skp (1.3 MB)

Why is this also important? … When I use my old dynamic components … which for some reason in previous versions of SK I thought it best to alter the name … now without being able to reset this field, I would have to remake these ?!

Is there a way to reset this field, to the default setting?

Appreciate your input on this.
Sergio

p.s.
Would also be helpful if SK report generator had a specific “instance attribute” in addition to “Entity name”.
Being able to filter our specific components instead of only selection (or manual selection in outliner) and nesting levels.


#20

Sorry it been too long, and I do not have time to familiarize with the topic.