Can't draw a dice, with rounded corners

I have tryed to doo this tutorial: https://www.youtube.com/watch?v=OnUjjjN-uHk&t=143s
But when I draw the same dice in Sketchup 2017 I get open corners.


Why is it not alowed to upload an .skb file to this fora?

You need to work at a larger scale.

1 Like

OK! I understand. I have to draw the dice in a bigger scale, and afterwards scale it down. Is This right?

No, in the Dave Method you make a copy a component, scale it up, and make changes to the scaled up one. Those changes are automatically are applied to your smaller model.

I have changed the template to arcitectural meter scale, drawn a dice, with sides of 3 meters, ofsett to the round corners, 0,5 meter, and I still get thise very small holes,

Yes. The FollowMe tool has a limitation so when you have a corner radius that is the same or smaller than the radius of the fillet you are trying to achieve you get these small anomalies. You can either use Fredo6’s RoundCorner or FredoCorner extension, or , with native tools, first create a full sphere, cut out the parts you don’t need and move that into the corner.

1 Like

Try the method described in this tutorial model.

I Have tryed the Dave Method, and I still get’s this small holes. I think I have to try With Fredo6’s RoundCorner or FredoCorner extension.

dice - Dave Method  Zoomed in

Fredo6’s RoundCorner or FredoCorner extension.
Which would you recommend to use?

Those are backup files. Upload the .skp file instead.

Those aren’t holes. They are excess edges that only need to be removed.

This can be done with simple native tools and the Dave Method as Box recommended.

Profile of cube and square with rounded corners as a component, copy scaled up by 1000x. All arcs have the same radius.

After Follow Me:

Erase the crossing lines on the top and bottom faces along with the vertical line running up the middle. Then select all of the geometry, right click and choose Intersect Faces>With Selection.

Erase the unneeded edges and faces. Exit edit mode and erase the large copy. Zoom extents to return to the original. Solid Inspector 2 only used to show that the component is clean. It wasn’t used at all in the cleanup.

1 Like

I’ll Try this as the next thing, but for now I want a pause and a beer. I have stroggled with this problem for 4 hours now. :persevere: :flushed: :pleading_face:

Hi I now have installed Fredos Round Corners, and it has solved the problem, with round Corners. I also installed Solid Inspector, to check the cube for holes. And Solid Inspector returns “No errors found”.
I have exported the drawing in the format .dae, to make it possible to import the cube in Cura (Slicing program for 3d printing), but after slicing it looks totally wrong.
It looks like the cube is not solid.
Where in the process does things go wrong? In the export to format .dae, or in the import / slicing in Cura.

I would be very happy if there is someone who has a solution to this problem.

I use Sketchup Mkae 2017, So .dae is the only format supported by both Cura and Sketchup.



[Klodsmajor Terning 01 -F - Skarpe Kanter.skp|attachment]
(upload://zgVq2Am6CxHUEusT3kgnaDFmjv3.skp) (1.3 MB)

The extension warehouse has an .stl exporter that works in 2017 Make.

hi I have installed the stl plugin from extension Warehouse, and Cura now has no problem with slicing the cube.
There is apparently a problem with the .dae format either in Sketchup or in Cura.