Can't create "header" above door in "pulled" floor plan

(I tried to attach screen shots but it only allows 1 attachment for new users)

I created a “2d” floor plan in Sketchup pro.

I extruded the walls of the floor plan and then attempted to pull “headers” above the doorways.

Sketchup closes the shape correctly on all side but one. On the problem side it acts as though the surface is non-planer using triangles to fill the surface. And I cannot remove the edge line on the right.
I have tried countless ways to rebuild this surface with no luck.

I then removed all the doors from the “2d” layout and pull without them. I then tried to draw a door on the wall and push

through the wall with no luck. It won’t cut all the way and despite everything I try I cannot re-build it.

I’ve tried everything, removing faces on both side before pulling, re-tracing edges to heal faces, deleting and re-building the wall. Nothing gets this face to close correctly.

I’ve attached the problematic file:
main-house-floor-plan-bug.skp (146.2 KB)

It’s easier to take it from 0 and draw correctly at 90 degrees

Basics of SketchUp at

1 Like

It would help if you turn off Length Snapping in Model Info>Units.

I assume this this is the doorway you are referring to. As you can see from the coordinate labels, there are lots of inconsistencies in the green axis values of the vertices, which cause the surface to be non-planar. You can’t erase an edge that separates two non-coplanar faces without taking the faces with them.

Wow, I drew all these lines snapping to the axis guides. Any idea why I have so many out of square? Also, what extension are you using to measure those angles, or are you in layout?

This kind of thing isn’t unusual with Length Snapping enabled.

What are you using to show the point coordinates? This would be a great way to identify issues in the future.

I used the text tool (the label text, not the 3D text). Change the model units setting to show more decimal places first.

I assume length snapping snaps to the nearest 1/16 inch (based on settings). Without that on how do I ensure things line up correctly without snapping? I assume that is what it is supposed to help with.

As you draw an edge, length snapping causes the end vertex to be an exact multiple of the snap setting from the start vertex. It does not snap to a grid location, a common incorrect assumption. It does not ensure placement in any particular plane and can pull the end vertex off from another inference snap. If there is any error in the placement of the start vertex, length snapping will cause that error to also be in the end vertex. As you continue editing, more and more vertices become inexact.


Working cleanly with ‘Enable length snapping’ enabled - the result is an accurate drawing

1 Like

Surely you meant “With Enable length snapping DISABLED” (i.e., unchecked)?

As I wrote, with that option enabled/checked, as can be seen in the clip, I enable it and then draw the plan.

OK. Showing that one CAN have it enabled, and still get accurate answers. Thanks.

1 Like

yeah, if you know what you do, length snapping is no big deal.

first, if you snap at the length that you display, no risk of having lines longer than they seem. Your display is in cm, therefore the smallest increment it’ll snap too should be cm too.

then, if you pay attention to parallels, perpendiculars, axis, guides, inferences, all that stuff, then with or without the snapping on, you won’t see a difference. It’s even more true if you type all your measures, instead of clicking points.

I only turned it off last year, because of messages on this forum, I used it in mm with display in mm too. In 14 years using it, never has an issue like the ones we see.

the main problem with the snapping is when you have a different level of precision. say I display 0,00 but snap at 0,000. Doing a 2,34m line freehand (no typing) might actually be a 2,3404m line.
hence the results.

1 Like

I have seen that when creating models for games, some/a lot work by eye (creative things), but in the case of architectural plans, it is logical to type in the exact dimensions.


It can be the only option if/when you don’t have access to accurate and reliable dimensions for something. You’re reduced to the OCD hell of pixel counting and infinite second guessing guesstimates.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.