Can't control camera view


#1

Okay, I am desperate here. I was drawing a simple 2d model(on my macbook pro running Yosemite), and was working on printing a 1:1 scale, when everything went wacko. I lost view of my object and at first I thought I just got myself lost in space somehow, but when I tried to find my object, it almost seems as if I’m stuck in an invisible box. My view controls are acting weird (i.e camera shakes when I try to orbit, can’t seem to zoom hardly at all), I also can’t seem to select anything. I tried using zoom extents, it didn’t work the first few times I tried, but it finally got me to a point where I could see my model. Thinking I had fixed it, I then switched my camera view back to “perspective”(I had changed it to print), and my model completely disappears again.

I suspect this may be something simple, like I accidentally enabled some view option or camera control setting on accident, possibly by way of hotkey. I have looked through all the camera settings and such, but cannot find the solution. If anybody knows what on earth is going on, I would appreciate it if you would fill me in.

Thanks!

=============UPDATE==============

I have discovered how to recreate this error, it has to do with the printing process. I still have not found a way around it. The steps to recreate are as follows:

1: Create a plane(or any shape probably, just something to focus on).
2: select “parallel projection”, and “top” view.
3: position view on plane.
4: open “document setup”, deselect “fit view to scale” and input 1" into the “print scale” fields(setting it to print a 1:1 scale) Press okay(NOTE: make sure you select another field for your input to save. simply pressing okay after typing will not save your changes).
5: Open “Print” then close it with “cancel”.
6: After closing the “Print” dialog, simply click once on your model. This should immediately result in a distorted view, and the above mentioned symptoms.

Note: In the few times I have recreated this bug, the number of pages required to print have been anywhere from 4 pages to 275 pages. This is known bug with printing to scale, to which I have found no solution, other than zooming in as close to the object you want printed, cutting out as much “dead space” as possible. Sometimes I can get it, sometimes I can’t. Whether this new bug is related to that one or not, I do not know.

If anyone can attempt recreate this for trouble shooting, it would be much appreciated.


#2

That certainly sounds weird! Have you tried saving the model, quitting SketchUp, then restarting SU and reloading the model? That would eliminate the possibility that you have somehow gotten the running SU process confused, possibly by stumbling on some obscure bug or by activating a setting you aren’t aware of.

If that doesn’t help, could you upload the model here so we can see if it is somehow defective?

By the way, SketchUp is really meant for 3D modeling not 2D, and perspective is a potentially very confusing way of looking at a 2D model! To work in 2D you should point the camera straight at the drawing plane, use parallel projection, and do not orbit, only pan or zoom.


#3

I have not saved and restarted the program yet. I guess I am a little hesitant to do that because if something got wrecked, I’d rather not save those changes and lose my project. I have tried saving as a different name and opening up autosaved files, but to no avail. The last thing I tried was using the menu to select everything and save the selection as a .skb. I opened it and the same thing happens. I can see my drawing fine, but I have trouble selecting anything, and when I select “perspective” everything disappears again.

I’ll upload a picture of the model as it is. I threw in a box and it’s behaving weird too. Note that I do NOT have xray on, and for face style I have selected “shaded with textures”, so that box should be completely solid. As with the plane below it, I can only select the box by clicking on the edges and certain spots on the face(not the whole face like normal).

I’ll note that I have used sketchup for hobby projects for several years, and while I don’t call myself a pro by any means, I can say I’m quite familiar with it. The 2D project I was trying to print was simply a few names. The reason I was doing it in sketchup is because I needed to control the size and style of the font, modify the font as needed, then print to scale for a template(if anybody knows of another program that would be better for this, I’m all ears.) I know it’s a good idea to keep it in “top” view for 2D, but I’ve never had a problem like this one before.


#4

If the screenshot doesn’t help, then I will upload the model for somebody to look at.


#5

add the skp, the image doesn’t help much…


#6

temp.skp (105.1 KB)


#7

Is it possible the very difficult entities hiding over on the right of your rectangle with the names is causing you problems?


I hit Zoom Extents and got this view. Dragging a selection box covering the area to the right of your rectangle finds 5 entities although they are so tiny I can’t see them.

After deleting them and hitting Zoom Extents again, I get this:


#8

Well that is interesting. I had not noticed that before, but have you tried turning on “perspective” after deleting those?


#9

I just did that. Your rectangle seems to disappear. It’s just that the camera was a long way away from the object. In Parallel Projection and a straight on view, zoom level is kind of deceptive and it is entirely possible to get a different view.

You should create a scene for the view when you get it right and then you’ll be able to return to it easily. Of course if you want to be able to control the scale of the print out, you need to be in Parallel Projection mode.

If you go back to that previous view–might require reopening the SU file–and switch to Perspective so the thing disappears, drag a selection box around the origin and you see that Entity Info reports you’ve selected the group. And if you then hit Zoom Extents, you’ll see it is selected.


#10

Aha! I see what you’re talking about. Those tiny, unknown entities must have been what was throwing me off. I have never known sketchup to change your location when changing camera views(parallel vs. perspective). So following your steps, I am able to regain control of my drawing, and I will definitely be setting a beginning scene in future drawings.

However, the one thing I am still unsure about is the wacky camera control. I followed your steps, then repeated the process(setting camera view to parallel, setting print scale to 1:1, opening and closing print, then selecting any object), and now when I hit Zoom Extents, it takes me to my object, however my view is askew(everything including the Origin). I am unable to straighten my camera view at this point. So is this a bug, or some viewing option?


#11

Could you post a screen shot showing that?


#12

Nice catch DaveR.
Select them as you did > in menu Edit > (lowest row =) 5 entities > Zoom Selection.
It’s a little rectangle with face (5 entities), the size of roughly 0.5mm x 0.5mm at 1.5m to the right.

@AceWing7, I don’t consider ‘Parallel’ model suited to orbit a model to view from all possible angles. It can seem buggy, due to positioning your (orbit-) cursor near the vanishing point blue. Your object may rotate 180 degrees with hardly moving the cursor or even with the first orbit attempt (as you described). The object may even look distorted due to being 2D in ‘Parallel’ mode. (it is not) It puzzles your brain.
And orbiting (off from being Top View) can even make the groups face unselectable. I can only guess that this has to do with the exceptional camera position that you managed to put it in by following the steps in your description.
I got selection controle back by > Perspective (disappears) > Zoom Extents (visible again) > Parallel Projection > Zoom selection > orbit now makes the face selectable.
My guess is the “bug” is due to the position of the camera to begin with.