Bug - model view stretches when I resize window after printing pdf 1:1


#1

I have a strange issue that happens when I am printing a pdf with 1:1 scale. Afterwards the scale in the window is way off – it changes horizontal and vertical scale as I change the window size. This make the model appear to be stretched out. Also the zoom center is way way off so that zooming in or out results in panning.

In this “stretched view” I experience, anything I draw appears stretched, so that a circle looks like an ellipse. I can stretch this to extremes.

The model itself is ok - if I print again the model looks normal in the print preview, and everything else functions normally. It’s just that the view and camera functions are worthless. I’ve tried switching camera views and poking around with all the camera settings and nothing fixes it short of closing the file and reopening. It then functions normally again until next time I print as pdf.

Anyone know of this and how it might be fixed? Thanks.

I’m using Sketchup 17.3.116 on a Macbook Pro.


#2

Have you tried to reset the workspace?
SketchUp->Preferences->Workspace


#3

No, I hadn’t tried that. Unfortunately that doesn’t fix it either. Thanks for the idea, though. Seems like it should work. Hrm.


#4

When you print to 1:1 PDF the camera switches to a Parallel Projection correct ?

And when you wish to return to normal editing does it help to set the camera back to Perspective ?

I normally suggest setting up dedicated (and separate) scene pages for print and edit use. Each can have it’s own saved camera settings and it’s own style applied.


#5

Thanks for taking a look!

I have camera already set to parallel.
I’ve experimented and have can reproduce the bug consistently as follows:

Open a new document.

Change camera to parallel.

In document set up set to 1cm to 1cm.

Go to print (ignore warning that it says it will take thousands of pages and proceed to print dialog).

Cancel printing.

Try to zoom and/or resize window.

Does it do this for you?

(Sketchup Make 17.3.116, Mac Powerbook running Sierra 10.12.4)


#6

Someone else will need to test. SU2017 does not run on this machine and I have no Mac products.

(I would not be surprised if there is a bug, as other bugs have been reported recently with the PDF exporter.)