Can't change material color

I have been trying and trying and I even checked tutorials to make sure nothing has changed in the process. I can’t change the color of a material texture. I have a metal siding texture and a wood siding texture and neither can be altered. One was a newly imported texture and the other is a standard SketchUp texture. I am using SketchUp Pro 2024. I have always been able to alter the color of textures until now. Bug?

Probably not.

Are these in model materials that you are trying to edit?

Yes and No. I applied one material but not the other yet. I am only looking at the material palette. I am trying to use the typical process of editing the material color. I have tried duplicating the texture and then editing the copy without success. I have tried editing the original material without success.

You can only edit in model materials. If you are looking at the collection where you saved them, editing them won’t be available.

I am not sure this is true. But regardless, if I place a material on my building and then try to edit the material in the palette (by locating it in Colors in Model) I still cannot change the color of the texture. I can’t do anything to it at all. I have always been able to alter materials before.

Now it is suddenly working. I don’t understand. But I will just be grateful that I can again change material colors.


Yes. It is true that you can only edit materials in SketchUp if they are included in the In Model materials.

Ok I believe you of course. I still don’t know why it was not working before. Thanks for the help though. As always, your expertise is much appreciated.

Before SketchUp 2024 it was possible to colorize materials in collections on Mac, they didn’t have to be in model colors. You could then paint faces with that modified material, and then it would be an in model color, looking like the tinted material in the collection.

If you closed SketchUp and reopened it, the material you had tinted in a collection would no longer be tinted. I think that at some point that was being looked into as being bug to be fixed, but as you couldn’t do the same thing on Windows, and it was understandable that the collection material would return to its original look (because you had not saved over that material in the support folders), it never was ‘fixed’.

I don’t know why the way it worked was changed in 2024. At the moment you can go through the same steps, and the material doesn’t change color, making it seem like something isn’t working. In the next update there will be a message shown if you try to edit a material before it is in the in model colors set.

OK, so I was not crazy. Clearly this is what I was doing before for change material colors within a collection. But I will now work with in model materials to make changes.