Cannot Signin to Validate License using Firefox or Chrome

Have been using SketchUp Pro 2019 under Linux using Wine. All has worked for a couple years, but now, I don’t even get a field to enter username or password. This is preventing me from getting to any of my drawings. Viewing and creating are beyond my present use-case. If this cannot be resolved, I will expect a refund, but I would much more hope for restored access to confirm my license to the installed version of SketchUp Pro 2019.

Normally files are saved locally, and you wouldn’t need to sign in at all. If you have been using Trimble Connect, then you would need to sign in. If that’s what you’re doing, and in the sign in screen it looks blank on the right side of the page, check to see if your browser is using an ad blocker. Those can prevent the sign in fields from appearing.

Thank you for your suggestion.
I appreciate the help as it was one more thing to attempt.
I did solve the problem, and will explain as it may affect others.

I run a lot of security software.
pfSense, GeoIP, PiHole, etc.
And I have several browsers to try.
Firefox, Chrome and Gnome Epiphany.
I tried several configurations without success, until I diabled the PiHole.
Turning it back on, I found one provider that was being black-listed.
When I whitelisted that provider, all was operating as wished.

So there is a source for lots of default black-list entries referred to as StevenBlack.
PiHole Adlist selection of
The entry that I whitelisted is

I assume that it has earned a bad reputation, but it seems to be part of the SketchUp validation process.

The choice is up to Trimble on how to react to this information, but presently, I will enable this cdn provider when validating SketchUp, and will then close it down.

I think that this can close this issue for me, but may help others if addressed properly.

Thank you for your suggestion.
It didn’t become the solution needed, but it drove me to dig deep.
I did solve the problem, and other clients of Trimble may find benefit from this disclosure.

I am a security fanatic, to the limits of my knowledge.
It is why I use Linux.

I use defenses such as pfSense, GeoIP and PiHole.
When browsers are suspected, I use Firefox, Chrome and Gnome Epiphany to investigate.

I couldn’t find the solution by tricking out any of the browsers.
I found no evidense in the pfSense logs, the GeoIP logs, or the Linux logs.
But in the PiHole records there was 1 black-listed entry that was worthy of deeper investigation.
It was black-listed by

I don’t know if SteveBlack recently added it or if Trimble began using the services of CookieLaw.
Once white-listed, I was able to complete my month-by-month license validation.

I will return this entry to the black-list each month following white-listing for Trimble validation.

PiHole is fairly popular for reducing the annoyances of unsolicited advertising, with complete disregard to the operating system.
So other SketchUp users may have a similar experience.

I hope this helps, it did help me.

Thanks again.