Sketchup Web SignUp Process is broken

There are errors on your website. The Contact Form URL “https://www.sketchup.com/contact” (linked on your homepage) is 404.

The URL “https://www.sketchup.com/privacy-notice”, which is supposed to contain a “Privacy Policy supplement” that all new users are required to agree to, is ALSO 404. This is presumably resulting in all new users agreeing to some terms they cannot even read.
I hope you are aware of the fact that in european law this means that all terms and obligations in that missing file are void.

When was this? What browser are you using?
All the links you mentioned are responsive/work for me.

1 Like

Both work for me too, so I would check your end.

1 Like

Both of those links work for me. Could you try clearing your browser’s cache/cookies and see if that fixes the issue on your end?

1 Like

Hi, I am using Firefox 66.0.4 here and this is what I get:

(I would have posted a second screenshot for the contacts page but the forum only allows one image for new users.)

I cleared cache and cookies but the problem persists. I DO have some privacy addons enabled, particularly Ghostery and Ublock Origin. I did, however enable all scripting and cookies required. I also can use Sketchup Web and these forums here with no problem.

Even if there is no problem with other browsers this could be taken as a hint that there might be just a tad too much redirection magic behind those fairly essential URLs. :slight_smile:

There were numerous 404s, probably because at some point of time URLs were swapped and not all changes were tracked:
https://forums.sketchup.com/t/bug-localized-websites-links-strand-in-404/90609

The important information is where did you click to get to this page? The URL that exists is https://www.sketchup.com/legal/privacy-notice (but not without legal).

You said your OS is Linux, so I ran Firefox on Ubuntu (66.0.3 is current for me), and it looked fine. Not sure what’s going on for you.

Have you tried https://www.sketchup.com/privacy-notice ?
It does not work even for me, also not on Linux, but even not on another (work) computer with some Windows (7), in both cases AdBlock Plus and uMatrix deactivated. Is it a geo-blocking issue?

Works here:

https://goo.gl/maps/17QKuK5xdJSWdRGh6

This URL (without “legal”) appears in a dialogue that pops up during sign up for new users, requiring them to tick a mark that they agree to it to continue.

So the URL without “legal” in the path is still supposed to be valid (not deprecated), just as with /legal/ (?)

It looks not like a client issue, but a server/network thing.

I am in in the southern half of Germany (probably served via Frankfurt). Interesting is that I can see https://www.sketchup.com/privacy-notice displayed in browsershots.org (but it didn’t show geo-location of the rendering machines). SketchUp also doesn’t allow me to do an HTTP TRACE request.

@sketchup-io-drsf32, are you also in this or a totally different region (or which is the closest AWS or Google data center)?

Yes, I am located in central Germany