Cannot Remove Keyboard Shortcuts - SU 2017


#1

Greetings,

I have added some CTRL+SHIFT+… keyboard shortcuts (SU 2017) via Preferences-Shortcuts box. They seem to cause a conflict with other piece of software.
I CANNOT get rid of them. Cannot remove them neither by using ‘-’ box nor Rest All button. They keep reappearing once Su opens.

Please assist. Thank you in advance for your prompt response and the solution.


#2

Have you installed SketchUp as an administrator ? If in doubt, right click on the downloaded installer , and choose run as administrator . When prompted you can choose repair.


#3

You should be able to click on it to highlight in the assigned dialog box. Then click the minus sign to remove…


#4

Thank you.
Alas neither way works.
While removing them using ‘-’ button or Reset All they disappear from the box but once RESTARTING SU they are still THERE.
I have tried the same operation several times - always the same results - they keep appear in Shortcuts box.

I was wondering whether there is a clever and secure way to delete them from registry?

Windows 7 Ent 64bit
SU 2017


#5

have you tried re-allocating a different key?

john


#6

Yes, I have I can add and remove different keys but the same CTRL+SHIFT+E (zoom ext) and CRTL+SHIFT+W (zoom windows) are stubbornly persistent in keeping their position there.

I have searched registry, cannot find any preference location/values there.


#7

Ctrl+Shift+W and Ctrl+Shift+E are ‘native’ Camera menu shortcuts for Zoom Window and Zoom Extents

Preferences > Shortcuts > Reset All won’t make them go away … it puts them back.


#8

you try reinstalling SU?


#9

I have used Repair option. In vain.

Thank you


#10

Oh, thank you. Very precious remark.
It explains a lot. Than is why they reappear once SU restarted.
Silly of me.

The very beginning of the problem has been once I have noticed that after some shortcut manipulation (see below) the functionality of SPACEBAR + SHIFT + W (and UpArrow) has stopped working with Lumion.

Prior to that issue I had assigned CTRL+SHIFT+W and E, CTRL+SHIFT+P to a Logitech MX mouse buttons.

As far as I recall this has been my only change I have made.

Should it be any Windows hotkey conflict?

Same keyboard disfunction I have got with Alienware Macro keys working with Lumion.
In this case the macro keys SPACEBAR+SHIFT and SHIFT do not work.

Once more thank you very much for your valuable explanation.

My regards


#11

sorry to keep throwing out low tech solutions, but I like to cover bases as best I can.

Are you positive that the keyboard key actually works at all? Maybe that shift key is broken? Also, if you have a special non-standard windows keyboard, are there drivers for it?

If you believe that there is something running that is intercepting the key strokes, you could try rebooting in to safe mode to see if it’s still an issue.


#12

If the problem exists at all, even in one situation, without SketchUp being involved… it most likely isn’t SketchUp. Another solution could be to try using another keyboard. Again, just to rule out anything simple.

If it is only happening inside of SketchUp, then try disabling all extensions and try to reproduce the issue. If it still happens, try an older version of SketchUp that you know works.


#13

Thank you very much arachnode,

I will start the verification tommorow morning. This is a case of my office desktop.
You are right, first of all the hardware.

Bizarrement within Lumion the left SHIFT works well, SOACEBAR as well, same with right SHIFT.

Now what is astounding, left SHIFT+SPACEBAR has got no effect at all while the right SHIFT+SPACEBAR combination works perfectly.

I will also reinstall the Logitech driver and… be back here with news. Hope good ones.

My best regards with my huge thanks.


#14

Yes, it has been installed that way.

All worked well till the moment I have assigned some keyboard keys within Logitech in Sketchup application section (Logitech Setpoint).

Thank you for your suggestion.


#15

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.