Cannot open 2015 in "Make" mode


#1

I’ve been using SketchUp 2014, learning the software.

At home on macbook pro #1, last night I downloaded 2015 and continued with my model. Today, on my other macbook #2, I tried to open my recenlty saved model and it said I needed to upgrade from 2014 to 2015.

I downloaded 2015 this morning from Sketchup Make 2015 page. When I install and open it, I get the pro license dialogue window - showing that I have an expired 2015 license. I have no way to open it in the Make (non-pro) capacity - the only options are inputing pro license information.

What happened to being able to open this as Make and not pro?
Thanks for any help,
-A


Downloaded Make, Pro opens. I have no license
Sketch Up Make Installation Problem
#2

+1 for this.

I removed a couple of older, unlicensed versions of SketchUp from my macbook, and installed “Make 2015” instead.

The program, however, attempts to start in Pro mode, with the following warning: “SketchUp Pro 2015 User, Expired”, and with a prompt to input license info.

Just like Brian, all I want to do is use Make.

(please note that I have tried to reinstall the package a couple of times, after removing any seemingly SketchUp-related files I could find in ~/Library/Application support and ~/Library/Preferences)

Thanks in advance for your feedback,
Giuseppe


#3

Message to SketchUp Team - This question gets asked many times. Perhaps you should consider pinning an answer so that everyone downloading 2015 understands that the Pro version is available for 30 days and then it reverts to SU Make. Just a thought. This question has been asked so many times even going back to the 2013 release.


#4

@pault728, right now I cannot use SketchUp AT ALL. The program starts as Pro, with an expired license, and apparently there is no option to revert to Make. You can do only two things: add a license or exit.
Here’s the screenshot:


#5

Exact same problem here.


#6

The only thing that comes to my mind is that you might have downloaded the SketchUp Pro installation package instead of Make by mistake (or that there is a mistake on the web page that gets you the Pro package even if you click on a Make link).

Anssi


#7

I thought of this and uninstalled, downloaded Make again while paying attention, and it still runs as Pro with the dialog shown above.


#8

Since SketchUp 2013, SketchUp Make and SketchUp Pro both require a license file (previously the free version didn’t). In SketchUp Pro, the license file tells (obviously) the serial number and authorization code to unlock Pro features. In SketchUp Make, the license file tells 1. that it is the Make version (and you accepted non-commercial terms) and 2. whether it is in Pro trial.
That has the bad side effect that whatever goes wrong, you can’t start SketchUp Make at all!

  • An example is when the license file is missing: SketchUp Make does not start but shows a popup that the license file was not found (this is here not the case).
  • Another situation is when you installed Pro and Make at the same time (or traces of Pro not uninstalled properly): SketchUp Make thinks it is Pro, and you get the expired welcome dialog.
  • If you had never a Pro version of SketchUp 2015 installed, it could be yet another problem.

I would suggest to verify the location of the license file and whether it is readable/writeable (However, I didn’t find out where it is supposed to be, Does someone know?). Also, the file system not case-sensitive (there are know problems with case sensitivity)?

Otherwise one could completely uninstall SketchUp, and make sure that no traces are left that could turn the next install into Pro mode. Check that the uninstallation removed all plist preference files and the old license file. Then reinstall.


#9

32-bit Win 8.1


#10

What @Aerilius writes makes perfect sense to me.

Alas, after uninstalling SU once again and following all the instructions listed here I am still getting the same unwelcoming screen demanding a license–or else.

There must be at least another reference in my macbook’s hard disk to a zombie installation…

Ideas anyone?

Thanks,
Giuseppe


#11

FYI, I’m on Windows 7. Did a complete uninstall / reinstall. Same problem.


#12

Did you restart your computer after uninstalling? I am not sure but I remember seeing somewhere that changes that the uninstall has done to the Registry come to effect only after a restart.

I think there are some issues in the uninstall process. After I uninstalled SU 2015 from a computer, the Explorer right-click menu for SKP files still displayed the “Open with SketchUp 2015” item, even after a restart.

Anssi


#13

Just throwing my hand up. I’m also having this issue now after 2 days of functionality. It was for sure the 2015 Make installer, I restarted, uninstalled, reinstalled, repeat and the program is still trying to launch as pro. I wonder if Trimble accidentally mislabelled the installer and haven’t actually made available a Make installer yet. Whatever the case, I cannot develop my coursework and need to pass the files on to others who will not be able to open it either.


#14

+1 to all these recent comments. I’ve tried uninstalling and installing, several times. Weirdly - on one of my macbook pros, i can operate 2015 in Make mode. But not on the other one - no matter how many times I clean out and reinstall.


#15

Each SketchUp Make installation does start with a 30-day Pro trial. The side effect of this is that it has to install a trial license. I think the licensing system might be catching a state which it considers an error. One example of this is a clock-windback state, that is changing the system clock more than a day backwards. We have noticed that Macs are especially prone to this error. Can someone with this issue send the following file from your system to me via Private Message?

\Users\your_user_name\Library\Application Support\SketchUp 2015\liclog.txt

Thanks!


#16

When uninstalling SketchUp 2015 (Pro or Make) on Mac OS X, you’ll want to trash the following folders:

~/Library/Application Support/SketchUp 2015    
/Applications/SketchUp 2015

You shouldn’t have a SketchUp 2015 folder in the root-level /Library/Application Support folder (unless you made one), but if you do, you’ll want to delete that, too.

But if you delete those folders, empty the trash, then download and install SketchUp Make 2015, you should see the appropriate Expired Trial screen in the Welcome window where you can agree to the non-commercial license agreement. I just tested on my computer and I was able to successfully uninstall SketchUp Pro 2015 and install SketchUp Make 2015 just by trashing those folders.


#17

Good to hear it’s being cleared up. Is there an equivalent workaround for PC users?


#18

You can use the default Uninstaller that’s in Control Panel. After uninstalling, you will want to make sure that the C:\ProgramData\SketchUp\SketchUp 2015 folder is also deleted. Note that it’s ProgramData not Program Files, and that ProgramData is a hidden folder by default. You will need to show hidden files/folders to see the folder.


#19

@Tommy, I have:

  • trashed SU 2015
  • trashed the “~/Library/Application Support/Sketchup 2015” folder
  • trashed “~/Library/Preferences/com.sketchup.SketchUp.2015.plist” file (the only apparently related preference)
  • emptied the trash
  • rebooted (what the heck)
  • installed SU 2015 from scratch

Still getting the Pro User Expired screen and forced to exit.
There MUST be some other file somewhere that tricks SU…

Giuseppe


#20

Many thanks for the update, good sir. Sorry for the seemingly trivial and obvious question, but did you download the SketchUp Make 2015 installer as opposed to the Pro installer? You can get it from this page.

It’s good to cover all the bases :smirk:

If so, are you installing SketchUp Make 2015 by dragging the application bundle to the Applications folder?