Cannot make hollow square form


#1

I’ve been using Sketchup (free) for maybe ten years. This used to work.

I have a large rectangle that I’m using as a floor in my drawing. It is a component.
I drew a smaller square on it, 3" on a side. I drew a still smaller square 2.5" on a side centered in the first one. I want to push/pull the 1/4" rim. I cannot select the rim area and push/pull does not do its job.

When I select the 1/4" region, the entire 3" square surface is selected. I can push/pull that just fine. That makes a square end solid, I want a hollow square tube. When I do push/pull the entire surface, the drawn 2.5" square stays on the top.

This is really basic, it has always worked fine for me. How do I make it work again?

Thanks


#2

More info:
If I draw a square and then draw a smaller square, roughly placed, push/pull works fine.
What I did before was this:
Draw 3" square
Draw 1/4" square at inside corner of 3" square.
Draw 2.5" square, starting from innermost corner of 1/4" square.
Erase two 1/4" square edges showing.
Now the two squares (3" and 2.5") push/pull together, I just want to push/pull the perimeter. So it is something about drawing/erasing the little square.


#3

Workaround: Draw the 2.5" square first. Then add the 1/4" square and 3" square. Erase visible edges of 1/4" square and…push/pull does the right thing.

I’d still like to know why. This sounds like a bug.


#4

You are making it more difficult than needed. Of course you can’t pull up the 1/4" portion because what you have created is two surfaces on top of each other. Try this. Draw the 3" square on your surface. Then use the offset tool to create another square inside the first with leaving 1/4" around the edge. Now you can pull up the outside 1/4" thickness around the second square and it creates a hollow square tube. I would not have made the first square - your working surface - a component, but I would make it a group.


#5

That works, thank you.


#6

Just to fill you in, drawing it the way you original did brings you to the strange anomaly in SU where an internal face connected at only one point will fail to intersect and form a second co planner face.
You can see it here, with profiles turned on you can see the thicker lines appear, then I can reverse the face to produce z-fighting.
Even connecting to the edge and the apparent intersection because the profile lines disappear, the second face is still there.
It’s a “bug” that has been around a long time, who knows, one day they may find a solution.


#7

Thanks for the additional info. It is making a lot more sense now.


#8

Suppose I have a square rectangular solid. I draw a circle on top intending to push it through the solid. It doesn’t work–same problem. Offset won’t get me there since they are different shapes. How do I do this?

I’m using free Sketchup 15.1.106 64 bit.

Steve


#9

Not sure what you are trying…just draw the circle and push-pull:

Oh, if you made the rectangular solid a Group or Component, you must open it for edit before you can draw a circle that will interact with it!


#10

That’s what I did, but it wasn’t working. After your comment, I deleted the circle and tried it again. This time it worked fine.

I don’t know what happened, maybe my circle got broken.


#11

A clearer (to me) way of fixing the square within a square problem.

Select the drawn object that is on the surface, but not part of the surface. Now select the surface as well. Right click to “Intersect Faces”, then “With Selection”. The object will now behave correctly.

Steve