Cannot Install SUPro 2020 on Mac - "Cannot write to Applications directory"

Just downloaded SUPro 2020 installer, and I am unable to install the application. I keep getting a message saying “Cannot write to the Applications / SketchUp 2020 folder. You must be logged in as administrator.”

Not only am I logged in as admin, but I’m the ONLY admin on the laptop. There’s literally no other non-admin account even on the machine.

Any ideas?

How are you installing? Do not drag the downloaded file.
Just double click on it.

That’s what I’m doing. No dice.

Create a non-admin user account and try with this account.

I created a new Standard user account and tried installing from there; still no dice.

Make sure that any version of SketchUp and LayOut is closed, then open Terminal and paste in this text:

~/Downloads/Install\ SketchUp\ Pro\\ to\ Install\ SketchUp

Go through the installer steps, and show us whatever messages appear after the installing has started.

I get the “SketchUp Pro 2020, English, OK” dialog. [Click OK]
I get the “Selected Languages: SketchUp (English, Required), Install To: /Applications/Sketchup 2020, Cancel, Install” dialog. [Click Install]
I get the following error message: “*Cannot write to the /Applications/SketchUp 2020 directory. You must be logged in as Administrator to run the installer.” [Click OK]
The installer quits.

(For what it’s worth, this is exactly the same sequence of events that happens if I double-click the installer icon instead of going through the terminal mumbo-jumbo.)

The mumbo-jumbo does sometimes show up something useful! The other way to get the same information is to run the installer and then look in Console afterwards, to see what errors there were. In Terminal you get to see what’s happening right away.

So, I haven’t heard of this issue with the SketchUp installer, and will check with the appropriate team on Monday. While we wait, what happens if in Finder you drag an application from say Downloads to Applications? Does Mac OS make you enter your password?

If it does, try this longer mumbo-jumbo line in Terminal. You will need to type your password after pressing Return:

sudo ~/Downloads/Install\ SketchUp\ Pro\\ to\ Install\ SketchUp

Colin - Looks like that did it. Thanks!

As you might know, the sudo command temporarily elevates you to super-user (“root”) privileges, which overrides all ordinary permission checks (there are some things even root can’t do without a special kind of boot sequence). The fact that this worked strongly suggests that somehow one or more of the required folders has gotten the write permission turned off for the admin group. You can investigate using FInder’s right-click->Get Info. Look at the bottom of the info window for indication of what you are allowed to do with that folder. If you are fluent with UNIX commands in the Terminal, you can do the same there.

If you find access problems from your account, I’d be concerned they will cause other issues later too.

Is this your personal Mac, or was it set up for you by someone else such as an IT department? IT people often set non-default permissions in an effort to improve security.


It’s a company laptop, but it’s been in my sole possession for two years, and I’ve installed several previous versions of SketchUp (along with just about every other kind of app, from the App Store and downloaded directly) during the time I’ve had it, all without any issues whatsoever. I did the Get Info thing after the first failed attempt, and I have read+write access to the file and the folders.

The installer system was changed from 2019 to 2020. It’s possible the new one is running afoul of some permission setting that the previous ones did not.

I think that the installer itself didn’t change, but because of some notarization changes with DMGs, providing it as ZIP instead of DMG was done for 2020. Having said that, macOS may see installing from the same file on a successfully mounted DMG as being more secure than from an extracted ZIP in your Downloads folder.

I thought the 2020 installer changed to an install shield java implementation vs the previous way it just copied the files?

1 Like

Oh, right, good call. I was thinking of the change from 2020.0 to 2020.1.

I did the same steps as you mentioned (open Sketchup Pro from application > log in the Mac OS) but cannot seem to get to the Terminal log in before the error message “*Cannot write to the /Applications/SketchUp 2020 directory. You must be logged in as Administrator to run the installer.” pops up again.

I wonder if it has to do with me installing the 30-day free trial version of Sketchup Pro 2020