BugSplat After Upgrade To SU 2021.1

I got tired of the continuous crashes on MacOS with SU 2020/21, so I decided to try a Windows PC (WIN10, Dell, Nvidia 2060). After upgrading which processed normally. On the restart, I did a file>open on a previous model. File did not open, tried several other previous files, no response. On exit, I got this all-to-familiar response:


When I click on technical support, I am taken to a page with a bewildering number of self help liinks, none of which resemble my situation. I did file the BugSplat report. These un-explained crashes on both Mac and now PC, produce anxiety and a sense of helplessness. :worried:

For me, trying to troubleshoot problems like this, is not productive. Makes me wonder if the BugSplat report contains the necessary information to effectively identify the problem. Or, are there sufficient technical resources to follow-up? Or, are the support resources just overwhelmed? Or, is it a matter of priority, when I am just a single voice that can easily be ignored. Frustrated and just venting.

Are you able to share the file(s) that are crashing SketchUp?

I tried file>open on 10 different file names, all failed to open. I had the default file (untitled) open. I could add geometry, but when I executed “File/Exit”, the crash (BlugSplat) occurred. I restarted SU, added an edge and promptly got “program not responding”. I then right-clicked>close window, with no BugSplat.

I am not sure this behavior is related to the model files. I will uninstall/reinstall, using the “Run As Administrator” method.

Feel as if I am stumbling around in the dark looking for the light switch. :confounded:

Often the advice for this kind of crashing is to check your graphic card driver - to make sure it’s up to date…

I did check, and the drivers are the latest.

To the technology novice, it seems strange that before the update, this PC with SU2021 (same drivers) was not experiencing crashes. Using the same data files.

@EosDawn If you’d be willing to share some of the files that are failing to open, we’d be happy to take a look. No need to post them publicly. I’ll send you a private message.

Hi Mark,
Thanks for the reply. Further testing reveals the issue is not caused by any particular data file. I was able to repeat the behavior with an untitled empty file. Due to project deadlines, I have downgraded to 2019, which is stable on this Windows PC.

Do you have access to the BugSplat report I sent from the Windows PC? Hopefully, there will be useful data for your diagnosis.

On the Mac, I continually get BugSpat crashes. I have submitted >20 reports to Apple and SU. This link provides more information. @colin looked at some of the reports.

Since you have your profile hidden we can’t see what graphic card you have, but the important thing is to make sure you have updated the driver from the manufacturers site and not let windows tell you it is up to date.
The fact you crash on both Mac and Windows could be coincidental, both systems may have limited graphic abilities.

AMD Radeon R9 M395X on the iMac

Maybe you are right. These graphics cards are certainly not the latest, greatest hardware. One of first things I check is the video card driver. Still a mystery why going back to an earlier SU release in most cases resolves the problem. I have an SU file (small in size and clean) that I use for testing. I am beginning to believe it may be the Space Navigator or my working environment. I generally have two files open simultaneously. If I revert to 2017 Make, I get a completely stable working environment, which is the goal. The downside is I give up important SU features. Thanks for the suggestions.