Bugs in Sketchup Pro 23.1.340

Everytime I open the software it gives me this message. I change it everytime and stills giving me the same. What to do in this case? another bug is when changing the camera angle I cant type the number I want anymore…and I need to do it manually zooming in and out. That makes it much more difficult…

Look at Preferences>Files and fix the bad path.

What number do you want? What exactly are you doing in order to change the angle of view? I haven’t seen any issue entering any angle of view.

when I press alt+K ( the shortcut I create and use for years) and then I set the number, it shows this K letter that never happened to appear in the previous versions. Do you think it has something with the shortcut?

Another bug is the disconfiguration of the toolbar. Everytime I open it needs to be configured again…

What is good path and bad path? I changed the path but it continues not saving the options

Some users have reported issues with certain keyboard shortcuts that include Alt although I haven’t seen any reports of Alt+K being a problem.

This implies you didn’t install SketchUp 2023.1 correctly. It may also be the reason your keyboard shortcut doesn’t work for you.

Quit SketchUp and LayOut. find the installer for 2023.1.340. Right click on it, choose Run as administrator and then choose the Repair option. After it completes do a cold reboot of your computer. Then open SketchUp and configure your toolbars. Open and save a file That should get SketchUp to write the required file to save the positions of the toolbars.

FWIW, you shouldn’t need a separate keyboard shortcut for setting the angle of view. Just get the Zoom tool and type the number you want. In English the default keyboard shortcut for Zoom is Z. Type Z and you can then type the angle of view/focal length.

1 Like

What does it show in Preferences>Files? Which path is bad?

Do you click in the Measurement Window to enter a value. Please don’t click.

Select the zoom tool then let go of the mouse and type. Press the Enter key or the Return key to validate the value.

You probably know that you can add mm to the value to use camera lens focal length equivalent for the Zoom. Once you do that you don’t have to enter the mm suffix anymore. SU remembers the setting. Add d to revert back to degrees.

1 Like


Are you keeping all models, components, materials, etc. in the same folder called +PASTA SKETCHUP 2020?

It comes with this. And when I change, if I close skp and open again it wont save my modifications

It comes with what?


I didnt choose those folders…

what path its best for those files?

They are not the default locations for those files. This implies incorrect installation of SketchUp. Does that folder (+PASTA SKETCHUP 2020) even exist on your computer? Is your username on that computer actually “User”?

By default Models should be in C:\ … \Documents. The default location for Components, Materials, and Styles should be C:\ … \Your Username\AppData\Roaming\SketchUp\SketchUp 2023\SketchUp\Components or Materials or Styles as appropriate. These are mine.
Screenshot - 12_4_2023 , 8_43_33 AM

Classifications and Templates will be similar.

thank you DaveR

changing the subject; the new version dont say that this option could make skp slower…

Whether or not it says it, turning that on could make SketchUp slower. Anything that makes the GPU work harder can cause a slowdown. TBH, from the SketchUp files you’ve shared, your modeling workfllow and the sloppiness of the files has more impact on SketchUp’s speed than the Use maximum texture size setting is likely to have.

I know in the past you’ve told us you get models from colleagues. If you are concerned with speed in SketchUp you should invest time in training yourself and your staff to use SketchUp correctly. If your models were built well SketchUp would be faster and you would spend less, or maybe no time fixing problems which would also make it faster. There’s no reason you have to have the kinds of models you’ve shared here. They just don’t have to be constructed the way you have them.

I know Dave, but its they are not my staff. Just collegues. I always try to say it to them but they seem to forget. Its hard