Blender file import error

When trying to import a blender file in DEA format, the 3d comes out with this error.

What could be happening and how to fix it?

What’s the error? I just see all the trianngulation that is normal in the file you are importing. Softening edges will help to reduce their visiblity in SketchUp. I expect merging coplanar faces will also help.

It does not give an error as such, but the 3d comes out without the original color. I have smoothed the edges and the coplanar faces are active

By ‘original color’ do you mean the materials with only basic colors or some that also had texture and this is missing?

This is a 3d plane made with photographs taken by a drone. The images were processed in dronedeploy. Then passed through blender to place an admissible format for sketchup.

With original color I refer to the texture.

And in which version of SketchUp are you trying to import the .DAE file?

1 Like

SketchUp 2023

Please fix your forum profile. It says you are using “Free Plan” which is misleading.

Is SketchUp rendering set to “Colored with Textures” ?

if you start a new blender file and import the DAE, does it have the textures there?
if so, It may be that you haven’t exported them correctly

By SketchUp 2023, you mean the desktop version (Pro), not the web version, right?

From Dronedeploy, I guess you exported 3D model with ‘Single Image’ setting.


In Blender, when you export the DAE file, check UV as well. If you import the .DAE file into Blender (with or without checking that box), following Adam’s good advice, you won’t notice any difference, but in SketchUp (desktop) it would be visible (probably). And it could solve your problem with the texture.

Or maybe it’s just a simple style setting, and DanRathbun’s advice is enough.

2 Likes

Here is a long discussion we had three years ago. Some of what we figured out may help:

Well, that can be good sometimes when you are importing kinda “boxy” geometry from CAD-like apps (so that you can easily sketch details on it to pushpull and do similar edits), but in general, for this kind of hipoly models, merging coplanar faces is a bad practice for a number of reasons.

First off, is unlikely that a scanned model will have coplanar edeges. It may occasionally have some of them in really flat areas, but there will be few of them, so you cannot reduce the polycount to a significant extent.

What you will get after removing the triangulations will be n-gons.
N-gons are bad for organic modeling, shading and such, you really want to avoid them on organic models to avoid shading and texturing artifacts.
Moreover you will not gain significant performances by simply erasing the triangulation, because what causes the real performance hit (geometry wise, we are not taking textures, transparency and shadows into account) is not the edge-count, but the vertex-count.
The gpu only knows triangles, Ngons are sort of UI “illusion” but they are always triangulated at a machine/rendering level.

The only performance hit caused from the edge-count is related to edge style rendering.
In 99% of cases, with these heavy geometry models, you better smooth the edges and turn off hidden geometry visibility (for edge rendering performances).
Erasing edges and creating n-gons will not produce performance gain, but most likely will produce problems, the most obvious will be screwing unwrapped UV’s if present (and this is the case of most scanned models like this).

To import a model like this in Sketchup, what I generally do is simply use “Universal importer” free plugin, it takes care of UV and materials pretty well (I usally export this kind of stuff from 3dsMax using fbx, did’t try dae, but should be fine and should work pretty much the same from Blender). After importing, you just want to reset component scale and use the soften edges dialog to smooth the triangles.

You may try to import with different polygon reduction settings and see how it goes.
Beware of the fact that the more you decimate the mesh, the more you will get texturing and shading artifacts.
If you have a good cpu/gpu and it runs smooth with the original polycount, just stick with that.

No, unfortunately that will not help, is a totally different scenario goin’on here

We did go over a lot of things in that discussion, including how to get Blender to merge coplanar faces.

Could you show your SKP and DAE files?

I found the solution. You must extract the 3d object and then turn off the edges.

In my case, this solved it.

1 Like

[quote=“colin, post:15, topic:231506, full:true”]
We did go over a lot of things in that discussion, including how to get Blender to merge coplanar faces. [/quote]

I messed up the quotes… but… it is what it is :sweat_smile:

Did you read my previous post above? I explained quite in detail why merging coplanar faces (quite rare in this kind of scanned models) is usually not a good idea.

Based on my previous experience with this kind of beast, I would say that “the safe route” to manage this kind of model is to export them as fbx from Max/Blender/MayaC4d/wathever and then import in Sketchup using “Universal Importer” plugin (based on the pretty robust Meshlab)

Not sure if you are asking me or the original poster.
BTW here’s a video showing pretty similar process (alongside a few other optimization steps in Max).
Unfortunately it’s in italian because I recorded it to hel some friends dealing with similar problems.
But if you fast forward it at the beginning and at the end, you can see Universal Importer at work on this kind of hipoly/unwrapped scans.

1 Like

You better smooth them instead of hiding… it will give smoother shading to the mesh.
Use the slider in the soften edges window.

If I undersand well, you also have problem with textures which have nothing to do with edge properties.
You should probably double check your export/import process.

Hi @colin,

can you do this little test and maybe find out what exactly SketchUp changes when importing .DAE files to alter the UV map?
In the video is what I described in the previous post. I exported .dae files from Blender in the two modes (default and with UV checked).
Then I imported those .dae files into three software: SketchUp, Blender and pCon.planner. In the last two, the texture remains unchanged, as it should.

Also, Colin, do you know if the SketchUp developers intend to create an extension that will allow the import/export of .skp/.blend files between SketchUp and Blender? Or can you please forward this request to them?

Thank you!