Black areas showing up in 2017 Layout viewport

layout

#1

Just upgraded this morning to SU 2017 Pro and am having black areas show up at the fringes of my model in all Layout perspective viewports. Tried updating scenes in the model, turning off shadows, resizing viewports, restarting app etc. and no luck. They also show up on pdf export. On a Mac with Sierra 10.12.1.

Anyone else having this?

update: only in scenes/styles that have textures turned on.

update 2: was able to get them to go away by going into document set up - paper and changing the rendering and output resolution to high, which unfortunately makes moving around in my layout document slower and exported files much larger. hope this helps anyone having same issue.


Problem! Black points show in Layout using Raster
Sketchup 17, Mac OS sierra transparency bug
Layout question 2017 version
Artifacts in Layout
#2

I think this is related to anti-aliasing, which is a known issue on the Mac edition of SketchUp 2017 with the new OpenGL 3.0 graphics pipeline overhaul.

Hopefully, it will be addressed in MR1.


#3

This is basically making Layout 2017 unusable for me. Even with the high output resolution there are black edges showing up around the model in viewports and exports. Forced to use high output resolution, I end up with a single page pdf at around 4mb which is impractical. Really frustrating. Guess I will have to go back to 2016 until they figure this out.


#4

Did you try rendering your model in Hybrid or Vector mode before exporting?


#5

This is only happening in hybrid mode, but not raster or vector, so i believe it has something to do with textures/materials being displayed in layout. Another reason I think this is that it also doesn’t happen in hybrid mode with any style that doesn’t display textures/materials.


Jagged outline of my inserted SketchUp model in LayOut 2017
#6

Did you apply a standard style or is this one of your own?


#7

Ah, and little internal birdies have told me about a transparent background issue on some Macs that can cause this.


Layout 2017 Hybrid / Raster Rendering Problem - Jagged Outline
Sketchup 17, Mac OS sierra transparency bug
#8

What happens if you put some other background than pure white in your SketchUp view? What happens if you switch to a standard style?
To me this looks like you are using a Sketchy Edges -type style, and that the display is wreaking havoc where the transparent background of your viewport is meeting the transparent backgrounds of the images comprising your strokes. Are the images your style is using very small? Currently SU 2017 seems to have issues with very small images (2x2 pixels were discussed in another thread).

I am just guessing, probably wide off the mark.

Anssi


#9

In the original two pics I posted layout viewports are using the standard “shaded with textures” style in hybrid mode.

In the following attachment the:
top left is “default” style/hybrid (only one with no black boxes)
top right is “hidden line”/hybrid
bottom left is"x-ray"/raster (still has tiny little black boxes)
bottom right “shaded w/ textures”/raster

So, I was wrong before when I said it wasn’t happening in raster mode too. Maybe it is something to do with a white background in the style. Not using sketchy edges anywhere. Images (do you mean viewports?) are on a 24x36 inch layout. Also, checking/unchecking the background box in layout - sketchup model - style does nothing. Boxes still there.


#10

Another thing: in your original post you said that setting rendering and ourput resolution to High fixed this problem but made navigating the LO document slow. What if you leave the edit resolution to low and only rev up the Output resolution? I always set my LayOut files like that.

Anssi


#11

Anssi,

I thought setting output res to high fixed the problem, but it only minimized it. The attached image is zoomed in on a pdf export that was set on high resolution output. Boxes are still there just smaller and a single page is now a 4mb file at the higher resolution. So I have huge pdf that has obvious flaws in it. Not acceptable.

I think you’re correct about the white background being the issue.


#12

You could try setting the scene background to 254,254,254. That would probably be white for all practical purposes except viewport transparency.

Anssi


Vector fills are rasterised when printing
#13

No luck there either. Changed background style color to all 254’s and updated style in layout. Nope. Captured with an off white background:


#14

Hi folks,

I have the exact same problem. I use a 5k iMac which has a AMD Radeon R9 M395X built in and since SU 2017 I also have these black squares and boxes around my models. Whatever I do, they don’t disappear. It is extremely annoying because I need to export 72 scenes as an animation with transparent background and I can’t find out a setting whichs just works. Despite the PNG export is also not working anymore concerning transparent backgrounds. The are ALWAYS white plus the LOVELY BLACK BOXES around the model.

I really hope for quick solution for this. By the way, it is clearly a mac problem. My PC (working with a GTX 1070 AMP Extreme!) can export everything like I need it, but as we all know, PCs can’t export animations with transparent backgrounds. So I’m stucked again.

Cheers,
operatorOne


#15

We have the same computer and graphics card. I went back to SU 2016, which was pretty annoying since I didn’t notice this issue until after I had saved several models in 2017 format. Having to switch them all back is a headache. Someone from the sketchup team asked for system info about this issue in another thread, which I sent to them in a PM, but they never replied concerning it.


#16

have you set it in png export options, I just double checked and it’s working on my iMac with v17…

for export you can set the Antialiasing to 4 using Ruby Console found under the Window menu…

you need to paste this line into the ‘bottom’ text field and hit return…

Test.set_AA_method(4)

my tests show this has no effect on the display, but still works on exports…

it may help with the ‘black boxes’ as I don’t get them…

john


#17

Which reminds me. When saving a layout file from 2017 format back to 2016 all the model viewports I had in hybrid mode reverted to raster in 2016 file. Had to change them all back one by one.


#18

Hi,

thanks for the tips, but I had no success. I suggest it is the graphic card handling of macOS 10.12 Sierra. I tried to use SU 2016 and had exactly the same result. Black boxes and no transparent backgrounds. Sad :confounded:

operatorone


#19

I’m having the same problem on my 5K iMac with AMD Radeon R9 M295X 4096 MB card running Sierra OS. Unacceptable for a new software release.


#20

Same problem here. I was able to clear the back areas by changing the field of view/zoom factor. Went in one instance from 75 to 40 and that did the trick. But in another drawing that didn’t not help at all…