Black areas showing up in 2017 Layout viewport

layout

#21

Hi guys, I just updated my Sketchup 2017 to 17.1.17 on my mac OS 10.12.1. The black boxes around the model disappeared, which I’m very happy about it. : grinning: Nevertheless I can’t get the transparent background to work when I export my model 2D to a PNG, which annoys me still a lot. Even when I choose a colored background – blue or something – I get an image with a white background. : cry: May be still an issue concerning the graphics driver or the render engine of SU17.


#22

I’ve just downloaded and installed SketchUp 2017 17.1.173, but it’s not really helped me - the black squares and jagged edges are still there.


#23

that’s what happens when you open a transparent background image in software that uses white as a background…

e.g. in ‘Preview.app’…

john


#24

That’s odd. :grin: When I try to open my transparent png in Photoshop I just have a white background and only one layer of course.


#25

See:


#26

What I did

Opened up the sketchup drawing then opened up styles and edited the current style, setting background, sky and ground to white, then saved.

Opened up my layout and updated the reference links.

The imported drawing still showed the black blocks, so I right clicked on the drawing within the layout and selected styles.
this showed two style options one with [1] next to it.
I selected this style that DID NOT have a tick next to it and this seemed to resolve the issue.
I had several instances of the same sketchup drawing on the layout and had to do it for each instance.
Some times I had to click back and forth between the two styles before it would work.

Im running sketchup 2017 on a new macbook pro with serria os x.

I think it could be due to transparent backgrounds, I moved a series of jobs over from my old macbook pro running 2015, where everything displayed fine and these had transparent backgrounds as I often overlay the imported drawing.


#27

Hi all-

Just a little update on this issue.

We’ve tracked this down to some sort of an issue with the drivers for particular graphics cards in particular Macs. We’re looking for a fix on our end and we’re working with the vendor to see if they’ll fix this in a driver update.

At the moment I don’t have a dependable workaround for this issue.

The best way to help solve this issue is to post your exact graphic card specs

Thanks,
Marc


Sketchup 17, Mac OS sierra transparency bug
Where did transparent background go?
Layout imports look wrong
Black outlines, black dots in Viewports in LayOut 2017
#28

Has this been resolved yet? I have bought a SU 2017 Licence that i cannot use and i am having to use a trial version of 2016.


#29

AFAIK, no. It seems to be a bug in the Mac driver for AMD graphics cards.

Some people have used as a workaround either Hybrid or Vector rendering or setting the Sketchup model viewport background not to be transparent.

Anssi


#30

Just updated the macOS to 10.12.2 on my new macbook pro but this doesn’t change a thing… Very annoying, I have a lot of running projects which can’t be updated properly now. Anybody found a workaround yet? I have to finish a project before the holidays. Picking a background color instead of transparant doesn’t solve it, only the vector mode the edges will dissapear but this is far too ugly to show my clients…
Kind regards
Jeroen


#31

I’m on El Capitan now, but I’ll update my operating system Sierra. Here is my graphics info:


And here is what my file looks like in Layout:
Animations look like a thunderstorm is happening, with black boxes flashing. Hope to see this fixed soon!

And thank you!

Leah


#32

Here is mine


#33

Has this been resolved?

I just noticed this for the first time this week.
I found it went away in a vector mode, but then there are not textures.
I also found that when I turned of certain layers and resaved my SU file
it went away in Hybrid mode. The layers I turned off were not visible in the
scene I was using but had multiple complex components. For instance I have
modeled each of the open web steel joists.

I am running 17.1.173
MacOS Sierra on a 27" iMac. My graphics is similar to that Leah showed above.


#34

Last I heard they are working on it, but there has not been a fix released yet.


#35

Coming up on 3 months that I’ve paid for a pro version of this program and haven’t been able to use the latest version. Had to revert all my files back to 2016. Pretty frustrating…


#36

Same problem here - Mac OS Sierra 10.12.2 MacBook Pro (Radeon Pro 450 2048 MB
Intel HD Graphics 530 1536 MB) and just upgraded to SU 2017. Layout is now unusable. Just waiting… and hoping for a bug fix or workaround. Very frustrating.


#37

Yes. It is. It would be nice if the the video driver folks and Apple could get it together and fix it.


#38

Not sure if this info is relevant or helps any - but just notices the same issue in scene manager directly in SU too.


#39

Just quoting the updates by the OP, so as to summarize. [quote=“cbdavis4, post:3, topic:33430”]
Forced to use high output resolution, I end up with a single page pdf at around 4mb which is impractical.
[/quote]


#40

Not really a solution for everybody but maybe an egpu (Razer Core / Akitio node), powered with a recent nvidia card, would make this problem go away? Would be interesting to see if someone could test this (who is using a mac and has access to an egpu).