Bizarre: Push/pull changing surfaces to faces?


#1

Hello,

I’m completely new to sketchup, and have mainly been learning it from google searches and playing around. This particular problem seems to be so bizarre that I can’t find any information on it.

Basically, I’m trying to make a small object with several raised surfaces as solids. I have the border and the internal shapes raised 1.5mm, and I want the background plate to be about 0.5mm. However, when I use push/pull on the background and bring it to the level I want (really anything beyond 0.3mm), some of the surfaces on the raised shapes change to faces. They begin showing all their segment lines as well, and are transparent. If I return the background to 0, the problem persists, so I have to undo in order to fix it. But I need to background to be a solid for printing, so it needs to be raised.

When viewed from the other side, those same shape segments are perfectly fine, it is only on the part that will be visible. If I add the other surface to the background to solidify it, the problem also persists. I have no idea what is causing this, or how to fix it. I just want a simple solid object (no hollow places) to print.

Any help you can offer would be greatly appreciated.

I am attaching the project file; after pulling it, and you can see that some curves are now transparent faces.

nod ring WTF.skp (2.2 MB)

Thanks!


#2

There’s something wrong with your link (for me), but you should create the object much bigger (scale 100x or 1000x) to avoid the famous small faces issue…


#3

Cotty, although clicking the link doesn’t work, copying the link does.

Mr AngryScientist, I think most things will be solved at the larger scale (your entire model is current less than an inch tall), but there are other things that seem odd in your model. Have you tried using a template, where you see the ground? I have no idea where in space your model is, and some of the rotations don’t behave like I would expect, and floating in nothingness makes it harder to tell what is wrong.

You could copy the model and paste it into a new document that shows the ground, then scale it up to say a value of 10. When you do the paste you can place the model at the Origin point, which will hopefully act a bit more predictably.


#4

Let me try re-uploading it here. You mean create it larger and then shrink it back down when I’m done?nod ring in progress.skp (2.0 MB)


#5

Yeah, it’s meant to be small, it’s going on a ring. What I did was imported an image and traced the shapes for that image. I have no idea about other templates or anything like that. How do I enable a view to see the ground?
I’ve noticed rotations were weird when i tried to orbit, I guess, but I just made do.


#6

Could you change to having a 1000 foot tall girlfriend?

Go to Preferences/Template to set one that has a ground.

Copy your old model, make a new document with new fancy template with ground, paste the model (click on the origin to place it) select all, select the Scale tool, and make it be bigger. How much bigger might depend on if you need to get it back to the original size. The 10X I said, or the 100X Cotty said, are good starting points.


#7

Same for me.
Copy/Paste URL fails for both the links provided.


#8

Right-click, copy url works for me:

https://discourse-cdn-sjc1.com/sketchup/uploads/default/original/2X/b/b9cbf4a45fc9779a4cf2a9971ce9f566c96cc26a.skp


#9

I also tested the link I just posted, and it works. The original link didn’t work.


#10

Like @Cotty described, the reason behind the missing faces is the model too small.

Model tiny objects BIG from the moment you start and then scale down only when you’re finished.
Perhaps working in meters and then scale down to mm would be easiest.

Scaling the model up x1000 solved most of its issues, but not all.


One of the interior faces still had a propensity to disintegrate into triangles.
Here, the Text tool indicates slightly non-coplanar edges. That’s tough to fix.


Consequently, I made a slice by intersecting a face with the scaled-up model.

Try continuing the model from here:
nod ring in progress 001.skp (99.9 KB)