Blue parts of a model


#1

im new with sketch up and i just dinish drawing my gun but when i use push and pull some parts are white and some are blue and also i noticed that the white part is solid and the blue part is hollow how to fix this


#2

Hi,

Faces have 2 sides: The ‘white’ side is the front, and the ‘grayish blue’ side is the back.
[…and you can change the default color of these sides in the edit styles menu if you wanted to].

Having said that, you could be looking at a Reversed Face, or a Missing Face, or likely both based on your description.

To fix a Reversed Face: use the ‘Reverse Face’ command […available on the context menu which appears after you Right Click while hovering over a face you which to change]. . . In using that SketchUp will flip the face orientation around each time you invoke the command.

And for regenerating a missing face the typical trick is to draw a new line between two end points that already exist on the plane of the missing face. Doing so causes SketchUp to fill in the face again on that plane.

Sometimes missing faces exist because your edges don’t fall upon the same plane. in that case you have a non-coplanar relationship between the edges, and in that situation you need to resort towards triangulation between the various endpoints in an effort to fill them in.

OR, this symptom of non-coplanar edges is really a problem of imprecise modeling – where lines that should exist on a common plane don’t for whatever reason… In this case the solution is to reestablish the coplanar relationship between edges and endpoints. (and this probably involves rotating the model around and taking a closer look at where the fault lies – and finding what got moved out of position].

Sometimes faces get deleted accidentally because when you make a selection the bounding box used also selects geometry from the back side of the model as well. consequently whatever modifications you make to that selection affect the entire selection group, and things disappear. This is easy to miss if you’re not rotating the model around to check for such things.

If the blue you’re referring to is a brighter blue, then that could be associated with the Blue Box which appears around objects that have been grouped, or turned into components.

If that’s the case then you’ll have to go into the groups/components edit mode in order to make any changes… which happens by double clicking on the group/component.

  • It would be nice to see the real SketchUp model, just in case there’s some else going on.

Otherwise, I hope this helps you for what it is.

Take Care,

Jim


#3

this is the model im making of


#4

All of the ‘blue’ faces are orientated ‘backwards’.
While this presents few issues in pure SketchUp modeling [except in pushpull face retention etc], it is bad practice.
Almost all Rendering programs will fail as they render the front and ignore the back.
Also 3d-printers can fail too, because although the object might seem ‘solid’ the exported STL file etc might contain anomalies that will ruin the print.

The ‘reversed faces’ are easily resolved.
Select a problem face [or faces] and use the context-menu 'Reverse…'
You can make a shortcut to it in Preferences if you have a face selected when you open the Preferences dialog and filer ‘reverse’.
That makes it faster.
If the face is inside a group, then edit the group so you can select the face.
If you have an object that is totally reversed, select-all then ‘reverse-faces’.
If just some of its faces are reversed you can try this…
Select a face that is oriented the right way.
Context-menu > Orient…
All connected faces flip to match the selected face’s orientation.
Note that this works if the object is a ‘solid’ or it at least has no edges with more than two faces - otherwise SketchUp won’t be able to properly orient all connected faces, because at least one will be reversed relative to its neighbors…


#5

ive reversed all the faces but still some are hollow like this


#6

That’s a different problem. There are two possibilities: either whatever technique you used to generate the depth did not leave starting Faces, or the Edges of the “open” Faces are not planar. To test the former, try redrawing any little Edge on the boundary of the open side. If a Face suddenly appears, it was the former issue. If not try drawing some diagonals and see if triangular Faces appear. If so, the Edges are not co-planar. This second issue is much harder to fix, as it depends on exactly where and how you made the errors.

As usual, if you post a model instead of pictures, we will be much better able to tell you exactly what is going on in your model.


#7

how to upload a model?


#8


#9

You can PushPull a reversed face in two directions.
One way may leave the original face in place, while the other might erase it [having adjoining faces affects this]

If the extrusion with missing faces is symmetrical you can simply copy the faces from the other side Move+Ctrl and snap into place on the side with the hole.
A little reversing/orienting of the faces to get them all ‘outwards’ fixes it.

Drawing over an edge in a missing part can also auto-generate a missing face, provided the perimeter is coplanar and not too complex.


#10

thank you guys for all your feedback i finnaly mannaged to solved the problem big thanks to the community :smiley: