Beginner Question (9/30)

I am new to sketchup and I have been trying to create a base for an object using 3D text. I have tried all of the tutorial suggestions including using push/pull and a combination of settings and I cannot get the text to be embossed in the object, I get all kinds of weird stuff happening. I would appreciate any help that you can provide. I have tried flipping the faces, ungluing it and some other stuff but it does not work as expected.

Looks like you are really close. Here is a short video of one way. I place the text (which is really just a collection of geometry) on the surface. Then I scale in the one direction to make the letters as deep as I want them to be. Then right click and chose unglue to get the letters not to only stick to the surface (by default 3D text is created “glued” to make it easier to place on surfaces). Then I move the text into the body of the geometry I want to emboss, taking care that the front face of the letters is in the same plane as the top surface. Right click the selected text and choose explode. Sometime SketchUp does not interpret concentric surfaces as closed as with the “e” here, this is quickly healed by drawing a line over any other line in the coplanar edges of the surface, then that surface is closed again. I then select the front surface of each letter and delete it. The depth can be modified with push pull after this if desired.

1 Like

Thank you so much, I will give it a try! I really appreciate your help.

1 Like

Just a question how do you scale up? I don’t see the option, did you explode it first?

Don’t explode until the letters are the correct size and in the correct place, once exploded they cannot be easily moved.

Select the letters with the select tool, click on the scale tool and you will see green handles surrounding the selected object. Click on the top center one to scale in only one direction. Play with the handles a bit on a box to see what they do.

I understand what you saying but when I select the 3D letters and select the scale tool I only see the options to shrink/expand the letters, no green indicators on top. Is it the wrong type of 3D letters I am using? I am on windows not sure if that matters.

Windows does not matter in this case. There must be some confusion with the scale tool. Are you selecting the same tool I did in my video from the large tool pallet?

Looks like this?


Yes, I believe I am using the correct thing

Thanks for the picture, worth a thousand words :grinning:.

In the dialogue that pops up when you are entering the text for your 3D letters, one of the ckeck boxes is for Extruded then there is a place to enter the extruded depth. You have left this box unchecked so your text is being created into the modeling environment in 2D, without depth. So you cannot scale in that direction as the current value is 0, and 0 x whatever is still 0 (it’s all math underneath).

You could- skip the scale step and go straight to explode Then use push pull to push each letter into the surface. After the first letter you can double click each next one with the push pull tool as it remembers the last depth. I find this method very un reliable and recommend the way I first illustrated Faces sometimes fail to intersect correctly this way and cannot be push pulled.

I recommend you check extruded in the 3D text dialogue and use the previous method.

Thank you so much for your time. I followed your first instructions again and I got this:
I just need to figure out how to how to make sure the whole thing appears embossed without the white parts so that it would be under the surface sort of.

1 Like

Looks like you are there, the letters inset into the surface, is that what you were going for?

The white surfaces are the front of a surface, and the dark blue grey are the back, you should right click on the white top surface and choose orient faces to fix the backsides showing.


This is due to a feature of 3d text. When you don’t extrude, the 2d text is placed just above the face you put it on to avoid z-fighting. If you look at the text from the side in parallel projection you see this.

So exploding doesn’t correctly intersect with the face.

The simplest option is to unglue, scale through, then intersect the face with model to create the geometry in the face for pushpull, allowing you to delete the 3d text component.
It helps to intersect a second time to complete any missed bit, and weld the edges for a smooth extrusion.


For some reason this method does not work for me, does the block need to be a certain height?

Attach your model so we can see what the issue might be.

I was able to use part of the instructions from above but for some reason I can’t use the move tool to do anything other then just pull it straight down, not sure why. Also this really isn’t that important for me to figure out, if you guys have more important things to do I’m just trying to learn for fun. I really appreciate it.
3D1.skp (364.9 KB)

Avoid a letter touching an edge

Just as a follow up why do the sides of the rectangle appear to be slanted? Is this due to something I did?

Either they really are slanted (you might have moved some edges) or you are viewing the model at a very wide camera angle.

Okay thank you, I’m going to delete the model and try again new.