Push/pull text only works on letter n


#1

I’ve typed the 3D text, exploded it etc but when I go to pull the surface, it technically works, but only for the letter n.
The first image is as I’m starting to pull and the second shows how all the other letters vanish; help please!


#2

You made your effort more difficult by exploding it. This may have resulted in several of the faces being unable to close so the P-P tool would not work in each case.

Try doing it in this order:

Start out with a plain background of the size desired (no color or texture for now).

Go to Tools and select 3D Text. Choose font style and enter text as you want it to appear.

Scale the text to the size you want. (Do not explode)

R-click on the text and select edit.

P-P the individual letters (including the n’s) to the desired height. Note that once your height is entered for one letter the same height can be duplicated by dbl clicking the push pull tool over the other letters. This behavior will be maintained until another height is called out.

Close component.

Apply material and desired texture to the background plate.

Select everything and make it a group.

You’re done.


#3

Thank you for replying and helping, I appreciate your time.
I was following a tutorial which told me to explode the text, otherwise I would have no clue what to do.
I must be doing something wrong because I can’t p-p the letters individually. I right click and select edit component but that only allows me to click on the lines of the text with the cursor, and the p-p tool can’t do anything.


#4

It would help us help you’ll post a link to the tutorial and explain a bit more about what you’re trying to accomplish.


#5

I’ve looked at too many links, so I’m afraid I can’t post a specific link, sorry.
I’m essentially trying to create a message engraved in wood. I tried using filters and effects, in photoshop, on a image but it didn’t look realistic enough, so thought I would try making it a 3D reality.


#6

There are quite a few ways to do what you want.
If you want to use the explode version you need to make sure the letter actually cut the face.
If you use a filled letter sketchup moves it slightly off the face to avoid z-fighting so it doesn’t always intersect the face when you explode it.
If you use unfilled letter they tend to be placed on the face, but it helps to intersect them again just to be sure.
You could also use extruded letters and bury them in the face, intersect them and remove the front…

anyway, this is the explode method


#7

Try the method described in this help article.
Therein, notice there is no mention of Push/Pull .

Drawing Engraved Text — SketchUp Help


#8

Box: I don’t have to use the explode version; I’ll use any method that produces the outcome that I’m looking for, provided I can understand and execute it!
Loving the screen capture video, very clever (: It appears to work but there were some surfaces that weren’t selectable, as in they were still joined to others; hopefully the picture will make more sense. I managed to push/pull the hole in the o but I couldn’t do the same with the g.
(side thought: is there anyway to get rid of the lines in the ‘engraved’ sections?)

Geo: I think that might have been one of the methods that I started with, but it produced holes in the o, g, a and e.

Thank you both for taking the time to reply, I really appreciate it.


#9

I suspect you are working at too small a scale which is causing breaks in the edges.
Try scaling up by 10 or 100.
To remove the lines inside use the Soften edges dialog.


#10

Notice all those letters share a common feature-- an enclosed face.
When the Extruded 3D Text is exploded those interior faces tend to disappear.
You’ll also find that with Unfilled Non-Extruded 3D Text the interior edges may fail to cut /meld with the underlying face.

In either situation, simply take the Line Tool and retrace an edge, endpoint-to-endpoint.



@anon15
You’ll find modeling much more enjoyable if you follow JVL’s advice.
It’s far easier to see what you’re doing if you view the default material / monochrome face style.
Then turn on Profiles and/or Endpoints as each modeling situation dictates.


#11

Box: I tried scaling up by 10 and then 100 but it still seemed to work/not work sporadically. I shall remember the soften edges tool for the future, very useful, thanks.
Geo: I figured that it was the letter with an enclosed space but I didn’t know how to prevent/get around it. That’s clever! Knowing how to retrace those interior sections made it so much easier and worked like a charm, thank you.
The reason I kept the wood effect was because I wanted the ‘engraved’ bits to look like that wood. And I don’t know how to apply it afterwards really. It would be awesome if I could just carve in to a solid block of wood for a more realistic look but I don’t know if solid materials exist in sketchup.
Also, is there any easy way to get makes the lines of the text invisble?
Sorry for all the trouble and thank you all so so much for your time and help.


#12

@anon15

You are encountering this degree of difficulty because you are attempting to run with SketchUp before you get comfortable by walking with it.

It is well worth it to take the time to better comprehend the program to see what it can do and how to best accomplish your goals.

There are some very informative tutorial videos on the SU website. The amount of visual data can be overwhelming so I recommend digesting the learning experience in manageable bites; perhaps starting with the following playlist:

http://www.sketchup.com/learn/videos/58

Many more videos are available online at no cost at other sites as well, such as Harwood Podcasts and Go2School just to name a few.

Most SketchUp users who become proficient were able to develop their skillset through following the advice offered in the various video tutorials. Just a little time and patience is required.


#13

That is true and I’ve hardly used sketchup so I realise that is making my life harder; the only reason I’m trying run before I can walk is because I’m on a deadline for a personal project and I was just curious if I could make it work in sketchup.
Thank you for the link; maybe I’ll try to learn from the beginning in between other projects.


#14

You’ll save yourself a lot of time and frustration by spending an afternoon here:
SketchUp Toolbar Series Videos — SketchUpVideo Channel YouTube


#15

Set up at least 2 Scenes - one with the textured material and another with the monochrome face style.


#16

Geo: thanks for the link, I’m sure it will be very useful (:
catamountain: may I ask, why?


#17

You can quickly switch between the default, monochrome face look and your textured face by adding Scenes. A Scene adds a button tab above the workspace.

You will not be removing your wood texture - just changing the face style and saving your choice in a Scene. Of course, you also can switch face styles without adding the change to a Scene. It just can be a little quicker to switch between different looks by setting up a Scene.


#18

Why not just turn on the “styles” toolbar?


#19

I usually use Scenes because I end up set up more that one thing - layer visibility, camera, etc.


#20

So I decided to keep the project 2D, so that’s why I hadn’t replied sooner, but I wanted to say that the scenes tool sounds very useful, actually; shall be remembering that for the future, thank you.