Basic "modify" command for single entity or groups

#1

how to: Basic “modify” command. single entity or group.
don’t see a command to change size or modify size.

0 Likes

#2

There are numerous tools for modifying geometry in SketchUp. Scale, Push/Pull, and Move are three of them. The correct tool depends on the job. Show us an example of what you are trying to modify so we can give you some useful information.

0 Likes

#3

Just starting to design an outdoor bench out of various lengths of 2 x 4’s.
I stacked 10 together and want to make each a specific length.

0 Likes

#4

For simple shapes like that, Push/Pull will work fine or you can select the end and use the Move tool, or you can scale the geometry with the Scale tool. If you share your model it’ll be easier to give you exact instruction.

1 Like

#5

After reading a lot of the “manual” modeling became easier. go figure. Trying to put some holes in the model but can’t seem to find a “cut” or hole command. Help. And excuse me if it’s right there in plain sight.

0 Likes

#6

If you have 2x4’s with identical dimensions, then making them components (select geometry -> right click -> make component) will save time. Also, there’s a tape measure tool which helps you mark measurements, but push/pull should be sufficient for making 2x4’s. Push/pull allows you to type in a distance in the bottom right measurements box.

You can draw a shape on a face, then push/pull the surface to make the hole.
0

For other instances, it’s easier to use the “intersect faces with selection” command from the right click menu.

1 Like

#7

Hi,

Trying to put some drill holes through all the components. All I seem to do with the push/pull tool is put another solid object within the model.

I set up a test block to experiment with and I didn’t have a problem with a one piece model. When I built a two piece model I had problems with making a cut vs another solid protrusion. How do I cut, that is remove material, make a hole through all components in a model. Tried making them “groups”, “Components” “editing” all to no avail.

Thanks,

Richard

leg,bench.skp (249 KB)

0 Likes

#8

In the free version you would need to open the component for editing to be able to push the hole through. Since you have created nested components for the legs, you would need to open the leg component for editing and then the component for the block you want to work with.

If you were using SketchUp Pro or SketchUp Shop, you could use the Solid tools to trim the holes with a “dowel” drawn through the blocks.

0 Likes

#9

Thanks. I have the Pro version. Not sure I’m getting it yet. Whenever I try to use the trim or any of the solid tools every object I point to comes up with a message “not a solid”. I created all the objects with the push/pull tool. Not the correct way to do that? Still having issues “drilling” thru anything in my model using push/pull. Just putting more so called solid, but apparently, not solid objects in the model. Also I inadvertently deleted the push/pull tool icon from the std. menu on the left side of the main window. How do I get it back.
Thanks for the help. Having used ProE (solid modeling) for over 30 years I understand basic question on what must be a simple function can be frustrating.

0 Likes

#10

That’s because you’ve got nested components. For the leg component, open it (not the block components inside) and add the cylinder. Make it a group or component and make sure it shows as solid. then you should be able to use Trim to put the hole in the blocks.

You posted this in the SketchUp Free category and your profile indicates you are using SketchUp Free. Since that information is incorrect, answering your questions correctly is harder. Please correct your profile. I moved the thread.

0 Likes

#11

Try this The learning center. good tutorials.

0 Likes

#12

You made it look so easy. I’ve hard copied the making components, push/pull sections and still can’t figure it out. How do you break apart the various components. I tried the edit component?? Tried pulling a round shape but wasn’t able to make it a component (dowel)?? Was able to push a cut through one 2x4 but that didn’t help in the long run. Frustrated enough for one day. Snowing like the middle of winter now. Bummer. looks like 50 deg. starting tomorrow so I’m logging off SU for the day and going to do the weeks bills and watch it snow.

0 Likes

#13

I also wasn’t able to draw the initial circle the way you did by touching the mid points. Just goes into creating it on the edges. Must be some basic impute I don’t know how to use. Read the basics, but?

0 Likes

#14

I’m getting the impression you need some basic understanding of components and groups. In your model you’ve made components of each of the blocks. That’s sort of like putting the geometry in a transparent box. To make any changes to the geometry of the block, you have to open the box it’s in. Now, you have a stack of these components (boxes) that you’ve then put inside another box you’ve named ‘right leg assm’. For the other leg you’ve made a group instead of a component which is strange work flow. To get access to the geometry for one of those blocks, you now have to first open the big container called ‘right leg assm’ and then you have to open the box for the individual component.

With the Solid Tools (and Eneroth Solid Tools which I find a better choice), you don’t actually open the components to the geometry but the cutter (a cylinder component) would have to be inside the right leg assy box with the blocks. If you look at my GIF, you can see the dotted line box which indicates the right leg assy component is opened for editing.

As for your trouble drawing the circle, I expect you are clicking on the edge. I didn’t click. I simply hovered the cursor over the midpoint on the short edge for a couple of seconds, then hovered over the midpoint on the long edge for a couple of seconds. Then I moved the cursor toward the center and when I got the indication I was lined up correctly, I clicked to set the center point.

Our snow is finally melting away and the sun is out.

0 Likes

#15

What about that push/pull icon I deleted off the basic menu?

How do I find the Eneroth Solid Tools?

0 Likes

#16

Why did you delete the Push/Pull tool from the Toolbar? Go to View>Toolbars and highlight the toolbar that should have it. (Getting Start, Larger Toolset, or Edit) Then click Reset.

Eneroth Solid Tools are available from the Extension Warehouse. Go to Window>Extension Warehouse and search for it.

0 Likes

#17

Ok ,back at it for a few hours. Created a new model by only making a few groups. Created a circle. Pulled it out (dowel?).Made it a component. But it’s not a solid. ??

0 Likes

#18

How about uploading the model so I can look at it. And then let’s look at it together.

0 Likes

#19

Exported model? And attached. Not sure if this is how It’s done.

(Attachment bench assm 2.3ds is missing)

0 Likes

#20

Just save the SketchUp file as you have before and upload the SKP file. Drag it and drop it into your reply in the forum.

0 Likes