Drilling holes, an old topic and new example

Previously Dave has helped me with this subject and his post is here:

I am trying to use the Eneroth Solid Tools to create holes in some solid shapes I have created. Before I add cylinders, Solid Inspector reports no problems.

I have grouped the faces of each solid shape before starting.

This is the example that I am working with:

When I use the Trim tool, it cuts a hole through one solid shape and then I start getting messages that something is not a solid on the other solid shape.

This seems to be very similar to the example Dave gave before, so why is this a problem?


The strange thing is that the three cylinders are copies so I don’t know why one would not work properly.


You can try VisuHole, which would dig the holes regardless of whether your shape is solid.

Replicated your model and have no problem “drilling” the holes with Eneroth’s Solid Tools. Might be best to post your model to cut down on the guesswork…

Thank you both for your replies. That plugin may come in handy at some point, I will check it out.

I do want solids in this instances so hopefully by uploading the model you can figure it out. I checked again with solid inspector before uploading.

Many thanks.

Drill Press Table.skp (1.5 MB)

Well the end of the trail for me… can’t open your SU2019 model. It’s good practice if your posting a model for help to save a copy of your model back to an earlier SU version. You can get more assistance that way. Not everyone is running the 2019 version. The path is SketchUp > File > Save As . There is a drop down menu in the save window that allows you to pick the SU version, SU8, SU2015 etc.

I also observe that Trim Tool (from Eneroth Solid Tools) has problems with this.
However, the native Trim Tool (from the native Solid Tools) works perfectly fine in this case.

From previous experiences I have found that the native Solid Tools and Eneroth Solid tools behave different on various cases. None of then are perfect, in certain cases both will fail.
Thus, it is good to have both tool sets installed, often this solves the problem at hand.

This can be done using Intersect faces.



You could try Eneroth3 extension - Open Newer Version.

Would but according to the download it doesn’t work on a Mac…

Thank you all for your replies.

According to your demonstration, when you remove the tube and create the hole, there are lines inside. Does this mean that there is a problem? When I have done this type of thing in the past, that has indicated that something it not right.

Lines indicate an non smoothed surface - experiment with the soften tray settings (after selecting desired lines / surfaces).

This is frustrating because when Eneroths Solid Tools work, you don’t have to worry about smoothing.

Doesn’t this annoy anyone else?

I use 3mm radius hole cutters fairly often as I remember and don’t really have any trouble with them. So in theory your 4mm radius should work.

First I tried drawing a fresh 4mm radius cutter and that cut fine. Then I inspected your cutter to see the difference and you somehow have 4 extra planar edges on the cylinder. I reckon this could possibly be making the geometry too small to produce the solid output I got with mine. I don’t know how you ended up with that edge.

To test, turn on hidden geometry and erase the 4 edges that don’t connect to a vertex. Then try the solid tool again…

There’s also a slight issue with the vertices of the cutters being “off axis”. That’s nothing to do with the issue of solids but its always better to draw circles “on axis” for numerous reasons. To fix that for this one you could just rotate the cutters so the vertices lie “on axis” before using Solid Tools.

In case you aren’t aware theres also a lot of hidden groups and components in your model too, check the greyed out items in the Outliner.

I guess I haven’t had this problem either.

Thanks for thoroughly looking into this for me.

When I was creating the circles I set it to 96 sides and it came up with an error message saying that was too many, perhaps that is what caused it?

Not sure why it is out of whack, can you show how I should be doing it to avoid this please?

I’ve deliberately hidden lots of stuff at the moment, thanks for the heads up.

For a tiny hole like that there’s absolutely no need for 96 sides. SketchUp wouldn’t actually draw a small circle like that with 96 sides. It would give you that message and revert to the default 24-sided circle.

So that can’t explain why the circles are off axis then?

Off axis would be due to the way you’re drawing them. Make sure you drag the radius out on axis.