Deleting from intersection area

advice

#1

Hello there, I am new to SketchUp and learning slowly.

I have grouped some shaped together and want delete the intersecting area of the OSB which crosses the posts. This should be really simple but despite my attempts I cannot figure it out.

What I am aiming for is to make the OSB smaller by the dimensions of the posts.

I hope this makes sense, I have attached an example of the objects I am trying to edit. Using programs like Illustrator for non-3d images this is simple with livepaint and tools to merge and trim etc.

Example.skp (74.7 KB)


#2

You’ve got your model unnecessarily complicated with incorrectly nested groups and incorrect use of layers. There are also multiple overlapping copies of the OSB group which makes it difficult to work on.

To trim the OSB parts you need to open those groups for editing and then you can draw lines along the posts with the Line tool and then Push/Pull should take care of the waste.

Are the OSB pieces otherwise shaped as you want with the sloped top?

I simplified your model and made components of the parts. I also corrected the layer usage. After that, you could use Trim from the Solid Tools to trim the OSB part but it will convert components to groups. You could also use Trim and Keep (plugin from Sketchucation) which would trim the part and leave it a component. I just did it the manual way here with the Line tool followed by Push/Pull.


#3

Hello Dave, thank you so much for your reply (which includes a really useful GIF!).

The end result is perfect, I just wonder what you did to fix the issue with the layers? For example, did you put all the parts into one layer rather than several? Also, you say I need to open the groups for editing, do you mean selecting edit group or is there more to it than that?


#4

I put the geometry (faces and edges) on Layer 0 where they belong. Edges and faces should always be created and left on Layer 0.

I made the front post a component (it was just loose geometry in your model) and copied it to the back position.

Nope. That’s it. I generally just double click with the Select tool to open the group for editing but selecting Edit Group from the Context menu or Edit menu is fine. Think of the group or component as a container with the edges and faces inside. In order to make any changes to the contents of the component or group, you have to open the container so you can access it.


#5

Thank you once again for your reply.

So all of the shapes should be left on layer 0? What is the purpose of layers in SketchUp if that is the case? I like to keep things which are the same (use the same material and dimensions) on different layers for reference.

Also, I highlighted everything in the application and selected layer0. When I select individual items they show that they are on layer 0 but when I go between show/hide particular layers other than layer 0 it shows/hides the OSB. Why is that?

What difference does it make assigning objects to a group vs component?

Although your instructions appear simple at first glance I still haven’t been able to produce the results shown in the clip. I have made each object a component, selected the OSB so everything else is greyed out, drawn a line and then tried to push/pull but it doesn’t come up hatched/cannot clip the ends. Why am I finding this so difficult when it should be so simple?


#6

All of the edges and faces should be created and left on Layer 0. Groups and components can have other layers assigned to them. Or they can be assigned to other layers, whichever way you want to look at it.

Layers are used to control the visibility of groups and components. Layers do not provide any separation between various bits of geometry. That can only be done by groups, component and actual space between.

You may have associated the groups with Layer 0 but unless you associated the geometry within them to Layer 0, you haven’t fixed the model.

Creating either groups or components is like putting the selection inside a container that protects it from being modified and to make changes, such as trimming the ends of your OSB panels, you need to open the container to change it.

Components have some properties that groups haven’t. Editing one instance of a component in the model results in other instances (copies) getting the same treatment. Editing a group means that group gets modified but none of the others do.

It really is pretty simple but you need to start with the right approach. If you want, I could demonstrate after I finish dinner.


#7

Thank you for your reply. If this is wrong, how do I fix it and assign all/particular geometry to layer 0?

That would be very useful and kind, thank you.

There are things I want to do that seem as though they should be really easy but as a beginner using this program it seems like there is a lot to learn. For instance, if I wanted to easily work out the dimensions of a cutout in a sheet of OSB, I would like the program to cut out the piece which is overlapping a piece of timber as shown in this screenshot:


#8

Open each group or component for editing, select all of the contents and return them to Layer 0 in the Entity Info window.

I’ll be ready in a about 15 minutes if you are.


#10

Hello Dave, I have a piece of wood which I want to produce multiple copies of between one side of the build and the other. How do I easily produce equally spaced duplicates of the first between two points?

In the screenshot I want to create evenly spaced copies all the way to the back.


#11

Here’s a video on making arrays.


#12

Thank you for your reply. That is a useful video which helped me get the idea.

I am trying to produce a list of cuts from the materials used in my design but some of my components have useless names and others need to be renamed. Is there an easy and quick way of doing this so I can use cutlist?


#13

Open Outliner so you can see the list of components, select those that need to be renamed and edit the Component Definition Name in Entity Info. Repeat the process until all are correct.


#14

Hello Dave, thanks for your reply. That worked brilliantly.

Is there anything out there like cutlist (which works for sheet goods) but works instead with lumber such as CLS timber to calculate how many pieces are needed and can show the dimensions for special cuts (like 45 degree cut out at the end for example)?


#15

The CutList extension will handle lumber as well as sheet materials but it won’t show the special cuts. I don’t know of any extension that can do that. They report bounding box dimensions and bounding boxes are always rectangular prisms.


#16

Thank you for your reply. I am havin trouble understanding what I am doing wrong, some of the materials appear to be listed correctly in cutlist but some default to boards rather than lumber. Also, I don’t know where it is getting the length dimensions from.

I want to share the file but it wont let me for some reason. It is 4.2mb in size, is that too big? Where else can I upload to share the file so you can see?


#17

Boards and lumber are the same thing and different from sheet materials. The extension sorts them based on words in the component definition names. You can add words to the Sheet materials section on the opening window of the UI. If you want certain components to show in the boards section, that they don’t contain sheet words in the component names.

As for sharing the file, upload it to the 3D Warehouse and share the link.


#18

Hello Dave, thanks for your reply. My last post was made just before I went to bed, looks like you kind of understood that I meant sheets rather than boards.

I edited the settings in the plugin and it is a lot better, but I still don’t understand where it is finding the lumber lengths from to calculate the sizes and how I control that.

Also, it is including ‘groups’ in the cutlist which I don’t want it to do, just to include actual components.
Wood Store.pdf (354.3 KB)
Wood Store Cutlist.pdf (199.8 KB)


#19

Sorry to double post but whilst awaiting an answer I have been trying to add holes to the model so I know exactly where to drill and what size hole each piece requires.

Whilst doing this I ended up creating a hole which was too big. I added a circle into the gap and use the push tool to try and make the part a solid again, filling the hole. However, when I try to do this it just moves the circle from one side of the part to the other.

If I managed to do it and activated outer shell to try and merge the two parts into one, it would report that some of the selection is not a solid, but the part it complains about is a component. What is going on?


#20

Just being a component doesn’t make something a solid, a stray line, a missing face or a tiny hole can make something non solid.

Try removing holes by simply selecting them and deleting them.

Solid


#21

Thank you for your reply. If you look at my screenshots, that is a button which does not appear in my copy of Sketchup 2018 Pro.

I have checked the menus and can’t find any mention of it anywhere, I have the measurements toolbar activated,

What is going on? That would make life way easier.