Solid inspector 2 says solid but sketchup says it isnt


#1

sketchup 2014 / Windows 7 / Newest version of sold inspector 2

I try to subtract the small object from the large and sketchup says the larger object isnt a solid
even thou solid inspector says its perfect.

test.skp (341.8 KB)


#2

Looks like the problem is that line where two curves meet. An edge touches two faces in a SU solid.

Shep


#3

Nested Components need to be corrected in order to use Intersect.

Running SketchUp 2014 on Windows XP and Solid Inspector 2.and Google Chrome

Shaft Working Model.skp (210.3 KB)

I imported this part (a slip-clutch shaft) into SketchUp and tried to cut a 7mm shaft thorugh it by making a circle, push-pull, and flip to the opposite end, and select push-pull and tap on the opposite side. It didn’t work.

Then I decided to use intersect and I created a tube 7 mm in diameter, and push that into the shaft, and create a hole. Interesect didn’t work. And then I used solid inspector and discovered that there were nested components had to be manually corrected.

I don’t have the foggiest idea how to do that. Any idea what I can do? I have imported a lot of SLD Workst models and they all have this problem.

Also, Solid Inspector says it can run only on versions of IE Version 9 or higher. Older versions are unsupported. I am using Windows XP. Am I out of luck?


#4

The imported component was nested within another component and another and another … I lost count.

Right context click on the component > Explode
Repeat exploding until it’s no longer a Component … just raw geometry in the model space.
Make your modifications and then select all of it > Right Context click > Make Group or Component
Entity Info will tell you if it’s a Solid or not.
If not, you need to hunt for defects or use one of the solid inspection tools mentioned earlier.


Here’s a cleaned up copy of the model:
Shaft Working Model Fixed.skp (126.8 KB)

Double click on the Group in the model to open it for editing.
Select all the geometry > Right Context Click on the selection > Intersect Faces > With Selection
Then carefully erase what you don’t want.
Simply click outside the bounding box to close the Group.


#5

I need to do this by myself, and I haven’t the foggiest idea what you did
to fix it.

I tried to select and explode. And I continued to explode until I saw
these zig-zaggedy lines all along the surface of my model. I did not have
a clue as to what it was that I had to fix or erase.

I also got “No intersection can be found with selection set and the rest of
the model.”

Can you run solid inspector and see what I see? Perhaps you can walk me
thorugh what you did, and send me back a partially reworked file (see
below).

Mel Kamisato
buena park, CA
Shaft Scratch Practice.skp (214 KB)


#6

I notice when I create a circle, and use push pull to create a solid, it’s
not recognized as an object in sketchup. I tried attaching circles at the
ends of both the front and back of the resulting tube-shaped object, and
selecting and regrouping as a group, but it still doesn’t seem to work. It
is kinda hard to use the circle menu and try to locate the center of the
circular object you created using push pull.

Any ideas on what I’m doing worng?

Mel


#7

I gather you’re not the author of the imported model (a slip-clutch shaft)
Was the imported file type an STL file?


#8

The following was done;
Exploded redundant components;
Put shaft in same context as clutch and also changed seg count in it down to 12;
Then did intersect and then used TIG’s solid solver to make solid which in process it deleted the cylinder since intersect created a number of coplanar edges.
Shaft Working Model1_mac1.skp (286.2 KB)


#9

Attached is a new version of the shaft, which I resized, that I would like
comment on.

Actually, no. I downloaded the file from GrabCad and I am altering it for
my purposes. I have problems making this file a solid that Sketchup will
recognize. I tried following your recommendations, but I can’t figure out
how you did it.

I can create a 12mm diameter cylinder, and use that as a cutting tool
using Intersect. That way I can create the 12mm bore hole through the
shaft. Unfortunately I run into the same problems.

Both the shaft and the cylinder need to be a solid that SketchUp recognizes.

How did you fix the part?
How come Sketchup won’t recognize my cutting cylinder?
Could you give me some idea of how to fix both problems.
Shaft Working Model Fixed.skp (133 KB)


#10

The ribbed part looks like most of its faces wrongly oriented.
You should see no ‘blue’.
BUT you have painted it ‘steel’ !
View in Monochrome mode to see any issues…


Also consider using View > Hidden Geometry ON, to show oddities…
A temporary section-cut shows a few problems [highlighted].
There is an internal partition face and a non-intersected disk and circle at the other end.
there are still two minor issues with duplicated edges overlaid on the ‘rib-ends’ etc.
These can be fixed.

When these are fixed…

It’s now a solid…


#11

@makamisato

We’ve no clue what condition the original GrabCad model was in.
Thus, we haven’t the foggiest idea what you’ve done to alter it.
It’s impossible to help you learn how to model the part when we don’t know whether the modeling errors are yours or those of the original author.

Share the link to the original file at GrabCad.
Then, we’ll start at the beginning and walk through the process.


Learn more about what you’re trying to create.

Understanding Solid Objects in SketchUp — Aidan Chopra
•• http://www.dummies.com/how-to/content/understanding-solid-objects-in-google-sketchup-8.html
•• http://www.aidanchopra.com/web-content/chapter-6/understanding-solids


A Solid in SketchUp is a single Group or Component whose geometry meets certain conditions.
When those conditions are met, Entity Info indicates the model is a Solid Group or Solid Component.
Also notice Entity Info indicates the Volume of a selected Solid.

• The geometry must form a single* airtight vessel.
Like a perfect soap bubble … •No gaps •No holes •No leaks

• No extraneous Faces** inside or outside the vessel.
All Faces must serve to enclose the singular volume of the vessel.

• No stray Edges.
All Edges must serve to support a Face that in turn serves to enclose the airtight vessel.
Thus, each Edge supports two Faces … no more, no less.

No nested Groups or Components.

*A Solid Group or Solid Component may contain one or more separate airtight vessels.
**Best that all Faces are oriented Front Side (white) facing out.

-Geo


#12

Here is the original GrabCad file for the shaft, attached. Like I said, I
was trying to extrude a hole 12mm in diameter across the length.

Also, I had some cutting I needed to do, and the solids I was using to cut
were not recognized as solids.

Mel
Shaft Import.skp (215 KB)


#13

OK, this is actually easier to fix.
If has nested objects.
I used my SolidSolver and it exploded them.
Then it was a “Solid”.
View > Hidden Geometry > ON
There were Coplanar edges etc that could be deleted too…
I then used Smooth option to re-normalize all such edges.

It’s a relatively easy fix [if you know how]…


#14

Solid Solver? Never heard of it. Tell me about it. Where can I download it?

I have problems performing simple Solid Tools operations (Trim, Intersect) because SketchUp detects nested objects. I think Solid Solver might be the answer. Tell me more.


#15

GrabCad has Sophie in their file?


#16

I don’t understand. Mel


#17

The file type you import into SketchUp and the import options you select, affect the results.
Allow us to work with the original GabCad file; not the result of your efforts to import it into SketchUp.


#18

Ohhh. I sent it by gmail. – Melvin


#19

Here is SolidPart file from Grab CAD – Melvin


#20

Hey Geo & TIG, My Solid is far simpler as it was drawn on layer0 & turned into a component FRONTPORCHFOOTINGWALLS & moved to it’s own layer FRONTPORCHFOOTINGWALLS. Solidinspector2 says everything is SHINEY but Entity-Info has no volume field. Solidinspector1 outlines certain vectors in the model(solid) that has little to do with the problem as there is very few faces to create at that juncture.


It looks like two lines on the front edges in this image?