Bad projection of model


#1

Hello,

today I’ve a little problem. I use SketchUp Make about 3 years, now I have 2015 version. I use it almost every day - I’m working on my detailed model of flat. But today, when I opened it, the projection is really bad. Every lines, edges…, are like … I don’t know, how describe it … Like stairs with some white pixels. Application settings is OK and I don’tt know about any Windows updates.
The best will be look at the PrintScreen:

Does someone know what is it and how can I fix it? It does not matter if I work with this large project, or if I open some small component - there’s the same problem.

Thanks in advance.
Denis


#2

Hello. Can we have a look at your OpenGL settings? Window > Preferences > OpenGL

Have you made any recent changes to your OS, graphic card or SketchUp settings?


#3

Hello, thank you for your reply. I have this:

I never changed it. When I tried to set it to maximum (use maximum texture size + 4x anti-alias), it was better, but still worse than few days ago.
I didn’t make any OS, SketchUp, or GC changes and if I know, PC hasn’t any new OS updates.


#4

The jagged lines problem that you’re facing is tied to the antialiasing system most of the time. I’d suggest to turn off fast feedback and keep your anti-alias at 4x if possible. Keep in mind that this setting automatically steps down to 2x if your card doesn’t support 4x. You’ll want to double check that after choosing.

While testing the SketchUp 2017 Make version, I noticed that while orbiting a heavy model, the anti-aliasing setting turns off altogether. But I think that’s a new feature, not present in 2015 or 2016.

At the moment, I’m struggling to identify the problem. Can you confirm that you NVIDIA card is still controlling SketchUp’s visual properties?


#5

In fact, I don’t know, but I think yes.
I tried to reinstall Nvidia drivers. Without effect. I set better graphic card options (best quality), without effect.
Very strange is that when I set better anti-alias in Sketchup (2x, 4x), textures are absolutely bad:

With “0” in settings, textures are OK…


#6

And is the “Use Maximum Texture Size” checked in both cases?

If you’re not sure whether NVIDIA’s in control, head to the drivers properties. (Right click on the desktop and choose the graphic driver’s properties.) I don’t have a dedicated graphic card, so I can’t directly pinpoint the location and the right way to check, but after getting into the driver’s properties, you can figure out. (Or send a screenshot and we can figure out together.)


#7

Thank you.
When I click on the desktop, I have one of some options “NVIDIA Control Panel” (in Czech). When I click on it, the panel opens and there are options about quality (texture filters, smoothing, etc). But I do not know how to find if my graphic card controlling SketchUp’s visual properties, it’s not there.
I can send PrintScreen to you, but it’s in Czech and there’s no option for change the language (it’s probably the same as system language).
Strange is, that if I render something, textures are OK…


#8

If your computer has a motherboard/CPU Intel display chip in addition to a Nvidia card, this is the most important Nvidia setting:


Anssi


#9

Thanks for providing a screenshot @Anssi. :slight_smile: I turned Google Images upside down to find a SketchUp + NVIDIA control panel settings to help Denis but was unsuccessful in the end.


#10

Thank you @Anssi.
I checked the settings according to your instructions, though I have AMD.
I have options about quality (in Czech, but rows are similar):


I tried to set the best quality. Unfortunately in SketchUp without effect. When I tried to restore it to default settings, It’s the same too.
Anyway I can not switch off controlling SketchUp’s visual properties by my graphic Card.


#11

I am not sure if this is related, but all of your screenshots are very weird. like how you described below.

The texts are not appearing black, it has overlapped colors.
could be global anti-alias setting that is in effect for shifting all the graphics that way?

Have you noticed this before the issue in SketchUp?

We shouldn’t rule out hardware going bad although the chances are slim?


#12

Thank you.
I don’t know, I see all screenshots and I think it looks normal (?) - on my main PC and in my NTB too.
But I don’t know about other changes (bugs), but it true, that when I was set “optimal” setting for the PC game, there was the same problem and moreover with “jumping” of the textures - it was never before. When I set it back (un-optimal), it’s OK again. But for Sketchup I never set another settings.