Back Edges Not Visible in LayOut 2019 Hybrid Viewports

I want to include internal geometry in some of my LO Views. The Views are associated with Scenes in the SU model. The Scenes include a Style with Back Edges displayed. I want my LO Views in Hybrid mode, but in Hybrid mode, no internal geometry is displayed.

I thought I remembered Hybrid LO Views displaying Back Edges in previous versions, but in LO 2019, I can only see Back Edges with Views in Raster mode. I much prefer to work with LO Views in either Vector or Hybrid modes.

Is this a previously mentioned bug with Hybrid mode, or am I missing something else? I’ve included a simple example SU model and associated LO model that I created to illustrate my question.

Thanks in advance for any insights!

layout_practice_00_rev00.skp (204.9 KB)

layout_practice_00_rev00.layout (1.4 MB)

I think you have faulty memory. Back Edges haven’t ever been displayed in Hybrid rendering in LayOut.

If you are set on having back edges shown and have the rest of the edges displayed as vector lines as you get with Hybrid, you can use two scenes in SU and stack viewports. Or better, use two scenes and the dashes feature so the dashed lines can also be vector lines.

I definitely have faulty memory. Thanks for clearing up the expected behavior of Hybrid Viewports in LO for me.

Your example image looks great. Did you use the “two scenes and the dashes feature” approach to create it? I was able to reproduce something like your image, but not sure I did it the most efficient way:

SU - placed grouped geometry on Solid Lines layer
SU - created Cover Page 1 Scene with Solid Lines layer on and Cover Page Style
SU - pasted in place copy of grouped geometry on Dashed Lines layer
SU - created Cover Page 2 Scene with Dashed Lines layer on and Wireframe Style
LO - created View on Model 1 Viewports layer with Cover 1 Scene
LO - pasted copy of View on Model 2 Viewports layer (above) and changed to Cover 2 Scene

Is this anything like your process for stacking views with two scenes and using the dashes feature for vector lines in LO?

Evidently your method worked but it’s too much work for me. I did this:

In SU, assign the group to a layer and set a dashes type in the Layers panel for that layer.
Set up the style with dashes disabled.
Create a scene (I just updated your Cover Page scene since that’s what you used for the viewport in LO.)

Change the style to Wireframe and enable Dashes. I also made the line color a medium gray for this style but you could leave them black or make them some other color.
Create a second scene from the same camera position.

In LayOut, I updated the reference and left the viewport as you had it with Hybrid rendering.
Copy the viewport Ctrl+C, Command-C, etc.
Make the Model 2 Viewports layer active,
Right click and choose Paste to current layer.
While the viewport is selected, change the scene to the Dashed scene and render as Vector.
I wound up reducing the lineweight and setting the dashes scale from Auto to 1 x in the SketchUp Model panel.

Done.

Thanks very much, @DaveR. Your thorough explanation cleared up the details of your “two scenes and the dashes feature” approach. One key I was missing was the Styles setting for displaying / not displaying the new Dashed Lines feature in SU.

Working through your explanation, I updated my example SU and LO models, which now contain custom Styles for the Scenes to be stacked in LO Views. I also found out that I can use Vector mode for the stacked LO Views which still display the new Dashed Lines from SU, and they render more quickly than Hybrid Views.

I appreciate these detailed discussions, @DaveR. I often go back to our previous discussions to refresh my memory on a particular topic. That’s also why I’ve also taken time to use this forum to fully document my results. It becomes a great reference for me, and hopefully others in this forum, as well.

Here are my updated SU and LO example files, in case anyone else would like to inspect them. The Block component in these files is just notional, to practice and illustrate this approach of stacking views to show internal geometry with LO Views in either Hybrid or Vector mode.

layout_practice_00_rev01.skp (356.3 KB)

layout_practice_00_rev01.layout (3.3 MB)

Looks pretty good.

Yes. I could have changed it to Vector for my example. Just didn’t do it there because I was getting ready to head out for the evening.

If this is going to be a common sort of modeling project, you could create a SketchUp template with the two styles already included so you can switch to the wireframe/dashed style just before creating the scene.

One thing I noted in your LO file is that you have modified the scene for the 3/4 view of the part. As we’ve discussed before, that’s not a great workflow. Better to create a second 3/4 scene in SU with the face style set to Monochrome or maybe better, Hidden Line so there’s no shading.

Keep up the god work.

1 Like

Although my question were different to yours, here’s a topic with another description from Dave with the dashed lines method

That’s exactly what I did and incorporated the two styles into my main template. It makes it even simpler not having to fumble around with styles for the sake of it.

1 Like

Grrrrr…

Seems to me these work arounds are too difficult, especially since they cause a proliferation of scenes, styles or other rubbish that just further clutter the file, when it is already daunting enough to create multiple scenes for each part and assembly that need to be rendered in LO. I for one would RATHER THE DEVELOPER FIX THIS ISSUE so BACK EDGES can be displayed in vector or hybrid modes with simple check boxes to enable or disable or at least holding to the SU style, period. Anything else is just SHORT OF ADEQUATE.