Hybrid Mode causes "lost" lines when geometry is viewed behind transparent or water surfaces

I have been struggling with this for some time now, and it seems it may be a bug after all. Either that or I’m not understanding the “best practices” for selecting Raster Mode Vs. Hybrid Mode.

Obviously, the “jagged” lines in Raster Mode are horrible when presenting/printing drawings from Layout in native file format or export to PDF etc…

As we use a lot of “water” surfaces and “transparent” surfaces, the Hybrid Mode is preferred (over Raster) to avoid those jagged lines. BUT…when selecting Hybrid Mode, we lose critical lines anywhere they are meant to be seen behind Glass or under Water surfaces. Is this normal behavior for SKP Layout?

So…am I just left to either have no lines “beyond” or “behind” these transparent surfaces and clean vector lines…or settle for horrible “jagged” lines to be able to see the geometry behind these surfaces?

BTW…here is the Tester file showing the problem…if that helps.

Tester_001.layout (1.4 MB)

This is a known bug. The LO team are working on it.

Thanks DaveR…any idea on a work-around?

Well… Admittedly not the most convenient but it works.


Tester_001.layout (1.5 MB)

Transparent face component on one layer, the rest of the model on another layer. Two scenes in SU. Same camera position. One with transparent face on, second with the rest of the model. Stacked viewports in LO. Each on a separate layer so you can access the viewport on the bottom of the stack. Explode the transparent material viewport, edited resulting png image in external editor to make it transparent, save and update reference in LO.

Set the model viewport for the rest of the model to Hybrid or Vector as needed.

That is definitely a work-around, thanks for the suggestion DaveR. We use Sketchup to quickly explore and conceptualize pools, wet decks, and other transparency heavy models…this “bug” is a real pain in the butt… hopefully it will be addressed soon in a new release??

How does one “Stack a viewport” and have it align and sized correctly when bringing it back in from an external editor? If I understand the what DaveR is suggesting, take the same view, but the isolated scene of the just transparent surface, then drop down the opacity in say PSD, then import that back into Layout, and “stack” it above the underlying SKP scene, with the transparent surfaces, obviously turned off?

Though, when we import raster files, such as a PNG into PSD, we then have to assign both screen size and resolution…and I’ve never been able to figure out what the native resolution of a Layout page is per se?? So… I am left to manually re-size any graphic once imported back into Layout if i’m to stack it above an underlying SKP file/scene.

First: a definition. A viewport is the view of the SketchUp model which should be tied to a scene in SketchUp.
If the viewport is exploded as I referred to above, it is no longer a viewport. It’s just an image.

Stacking viewports is simple. Copy the existing viewport and then paste it. The pasted copy will be pasted in the exact same location on the page as the original. Instead of using the regular Paste option, use Paste to Current Layer and paste the viewport to the layer above the one containing the original viewport.

After changing the newly pasted viewport to the scene showing just the water, explode the viewport. This will convert it to a raster image. Right click on the image and choose Edit in Photoshop (or whatever you’re using as your default image editor). Change the opacity of the image and save it. When you return to LayOut, the image should have the transparency as I showed and still be the same size and in the same location as it was before. No need to screw around with resize the image.

Hey DaveR…

I guess LO team is still working on this “bug” ??

Why wouldn’t they just have a Vector mode that supports materials?

Ugh…

I expect so. Since I’m not on the team (as much as I’d like to be) I’m not privy to exactly what the status is.

They do. It’s called Hybrid.

that’s the one with the “bug” in it… that started this whole thread…and still acts the same way now as it has for years

I just don’t see why anyone using LO would want “jaggy” raster-based line work in their drawings?

1 Like

Look. I told you I’m not on the SketchUp or LayOut teams. I’m not an employee of Trimble, either. Please don’t get upset with me.

Textures in SketchUp are raster images not vector.

As for the jaggies, are you referring to what you see while working in LO?

It’s not uncommon to see the jaggies when you are working in LO because by default the display resolution is set to Medium. PDF and image exports can be set to higher quality output.

Are you still using SketchUp 2018 as indicated in your profile?

easy mate…not getting upset with anyone, just thinking out aloud :slight_smile:
Yes…still using SKP PRO 2018… didn’t see any real improvement, or advantage in 2019 other than dashed lines.

…and I am aware of the different settings when you export to PDF, though the “high” setting produces very large file sizes…so there is that trade off.

I do realize this file is just a test example…but if the model isn’t too overly complex…tracing over the lines while in raster and then switching to hybrid is also an option. (please see attached)

Tester_001_TraceOver.layout (1.5 MB)

Tester_001_TraceOver.pdf (733.0 KB)

Charlie_v tracing over in Layout is not really an option for 99% of my illustrations…however exporting multiple images of raster materials, vector line-only and shadows then getting “stuck into it” in Photoshop layering it together. It just gets painful when the client makes changes…I tend to leave the “water” out… a lot…lol.

I suspected so…but oh my that would be tedious…hopefully this gets sorted out soon!
Edit: Very nice work BTW

C

1 Like

No need to trace. Below, I have created two versions of the same scene: One normal view, set to hybrid rendering. A second identical view, set to wireframe view with dashed lines, and vector rendering. I then overlaid them in LayOut.

That’s getting close to a result Mr. Anssi, thanks for the tip… though I’m hoping to only have the “missing” lines display through the transparent surfaces (green in your model) and not the entire wireframe of the whole model showing through the SKP solid surfaces.

I’m wondering if this “bug” has been fixed in SU / LO 2020, as I still have yet to upgrade due to the amount of time its going to take update and re-install all my extensions.

I guess only one way to find out…