Autosave and Save behavior has changed in June

Since June, the saving feature has changed and in my opinion is now, broken…
First of all, I turned AutoSave OFF. I want to control when I save a file and Do NOT want to save a file and update the time if I made NO changes…

Today, I opened an old file and had was looking at it. I had made NO modification. I happened to notice the SAVE button, next to the Undo/Redo and filename, suddenly said “Saving” Sure enough when I check HISTORY of the file, it says it was modified today. I re-confirmed that AutoSave is OFF in the settings…

The Undo/Redo used to work in that if I make some changes to try things out, I could UNDO back to a point that I started (or last saved my design) and the “SAVE” button would gray out indicating to me that what I am looking at is what the file contains.

I use the revised date to keep versions of my file. It is annoying that the save button becomes active as soon as i open an old file and it it even more annoying that the original design is overwritten and my dates in the history get messed up.

Is it possible that the file format has changed in SketchUp Web and even opening an old design forces a SAVE? That said, I think I have seen it overwrite an unmodified file even though I just opened it a day or two ago… SO I don not believe the file format hypothesis…

Dates are important. Whatever changes have been made to the Save function are messing up my dates!!!

I’m curious. As a hobbyist, why is this so critical to you? Trimble Connect automatically makes incremental saves of your models every time you hit Save so you shouldn’t need to do that manually.

Please update your forum profile. SketchUp 2016 is not a web version.

Would a use case (or a few) help understand my need?

Use case 1:
I use SketchUp for 3D printing. Sometimes, parts fit sometimes they don’t. So to make a part fit, I make a couple of different versions. One with maybe holes 0.2mm larger or 0.1mm larger. Maybe it’s correct for my printer but I want to make something just a little larger or smaller for someone else or for a different printer. I don’t want multiple versions that so I can’t remember which is the nominal fit. I want to control what I save.

Use Case 2:
Sometimes, I need to look at an old design to measure something and then use that measurement in my new part. Since June, when I open my old file and close it, I don’t want to save or change the date of my old design. I an now asked if I want to save even if I don’t touch the old file. Most annoyingly, today it just went ahead and saved my file without asking me.

Use Case 3:
I build RF antennas for MRI. One way to tune them is to make the a few mm longer or shorter to adjust the inductance of the wires. I have a nominal size but I try three or four different lengths. Build the circuit, test it and iterate. I used to be able to undo my change and know that I don’t need to resave it.

Use case 4:
I build boxes for electronic projects to 3D print. Sometime I want to print the lid separately from the main box. SketchUp Web doesn’t allow me to highlight the part I want to export to STL. I have to delete the other parts and export the piece I want to print. I load a file, delete, export and then undo the deletion. I don’t want to save again. Now, I have to keep track and say “exit without saving” because fit whatever reason, it doesn’t remember I undid everything….

I used to use SketchUp 2016 and I could highlight what I wanted to export. But no longer on the Web version. Also, I use Linux and can’t run SketchUp natively.

Also, this behavior changed since the last version of SketchUp Web.

It should not be modifying my files other than Autosave, which i have turned off.

It very much seems like a bug.

How about boiling down the problem to it’s core. Try the following:

Open any old Trimble Connect file in SketchUp Web… Any existing file from Trimble Connect will do.

Immediately, the “SAVE” button is lit up and available.

Try to exit by going “Home”

You will be asked to save your design or exit without saving?

That behavior has changed since the June 3 update.

No changes made to file, there should be no need to “save.”

Traditionally in SketchUp land autosave actually refers to how often it backs up rather than saves.
I’m not sure if that is the same for web.

This may well help -
If you are saving to web you can see the entire history of the file and download a version from any time a save has been performed , manually or otherwise.
The best thing about web saving if you ask me.

You can find it in

Go through the the project, tick the file and the sidebar on the right will have the version history on it

I can’t reproduce. Try resetting the App settings (don’t forget to turn off Autosave) and reload the page.

Sometimes, Cookies get in the way. Deleting those should/might help:

I can reproduce this, and took a peak inside the Sketchup files.

When a file is opened in the free version of the webapp (don’t know about the other versions) there are several time stamps/counters that are being updated; each of the styles is touched, the model gets a new stamp, and the metadata for the file is updated. There is no way to get the file back to a not modified state. In addition, creating a new file via the ‘Create New’ button will open a new blank file with the Save button lluminated.

For reference, here’s what is being changed in a style.xml file.

Also, I don’t know if this is intentional on Trimble’s part or not.

Makes sense… I think this is also why the save button does not disappear when you undo all the way back to the file I loaded… thanks for looking at it that way!

If I open a file in any file in a text editor, and just look at it, I would not expect it to be in a changed state are require saving… Similarly, I don’t think a file opened in SketchUp should be marked as needing saving, just because I opened it to look at it. I would guess this is an unintended consequence of trying to change some other behavior in the SketchUp Web App.

There where some issues with files opening in the desktop 2024. It would simply crash.
That was a style issue, so it might be that some files needs to be updated?

1 Like

I was wondering if it was a file format/ file version problem so I tried with newly created files. Same result. Open a new but existing file and immediately, the “Save” button illuminates.