Autocad export scale problem

Scale problem while attaching exported 3d dwg from Sketchup 14 pro as xref in Autocad Architecture 2016. Exported file opens perfectly with correct units but while attaching block units in Autocad import window are inches regardless of units set up in Window>Preferences>Template and Window>Model info>Units. Using importskp command in autocad results the same scaling problem.

Manual changing of block units in Autocad seems impossible so I suppose it is rather Sketchup than Autocad problem.
Any ideas?

This is a known issue.
I believe it was fixed in newer versions of SketchUp.
In v2014 the DWG/DXF is made with the correct values for the lengths etc - in say ‘mm’ but the ‘units’ flag needed by AutoCAD was always set to ‘inches’…
You can reset it in CAD - see this explanation How to: fix my AutoCAD drawing to correct drawing unit | CADnotes
Not ideal but opening the exported file and using this method [to say ‘unitless’?] BEFORE importing it into your CAD drawing should work…

Well everything straight now.
Thanks a lot.

It was fixed in v.2015.

However, this error is so common in DWG files created by other people (not me and my near colleagues) that I have created an AutoLisp routine that I run for every DWG file someone else sends me before I use it, or our own older files before re-use. Beside the units commands it sets text and dimension styles, angle direction, linetype scale, annotative scale list, updates title blocks etc.

The world seems to be quite full of metric drawings that were started with the “acad.dwt” basic imperial-unit AutoCad template.