Trouble exporting Autocad dwg to Sketchup

Hello,

I have been attempting to bring in a dwg house elevation to sketchup, and it keeps coming in as a long flat straight line. When i zoom in i can see that pretty much everything is there, but then when i try and scale it the lines go everywhere and its not right.

I used the blog below to try some extra steps but it did not help. I have done this before without any issues, but now it is not working. Please check the screenshots and any help would be greatly appreciated.

http://www.thomthom.net/thoughts/2012/12/sketchup-dwg-import-guide/

Could you share the DWG file?

How about setting the units to the same as the DWG was exported as? Feet, maybe? Or Meters? If you import using the same units as the export, you shouldn’t need to do any scaling.

Appreciate the quick reply, whether feet/inches it is not working and i made sure to swich it in the options on sketchup when i did that. I would prefer not to share it in the community do you have a email i can send it to?

Send it via a private message. Click on my name and then Message.

Not sure where that message options is im new to the forum, ill upload it and delete it once you have it.

Got it.

I get the same results you got. Bad DWG! But I think you can fix it. I drew a horizontal face up toward the top and with everything selected, I scaled down vertically. The face could be down on the ground plane, too. I just used it to make the scale box bigger so I could easily get hold of the center handle at the top.

Then I scaled down. You can see how some of the endpoints aren’t at a Z of 0.

Getting closer…

You could flatten it more or just redraw it since it’s not a really detailed drawing. Or You could use an extension called Flatten to Plane (TIG at Sketchucation if I remember correctly).

1 Like

you could try an old ‘trick’…

import dwg into SU, top view, parallel projection, then export 2d dxf…

open a new SU and import the dxf…

john

2 Likes

Thanks so much looks like i got it.

1 Like

Thanks for the tip