Exporting a Layout drawing to Autocad .dwg files

I am drawing simple 2-D house plans in Sketchup, importing them into Layout, dimensioning and finishing all of the notations there and hoping to be able to export to my engineer from there as a .DWG file.
He needs to be able to work with these drawings in AutoCad.
I purged the drawings before saving, and am ready to export to .DWG

Below is a screenshot of my choices when exporting from Layout.

Please advise which items to include in order for the engineer to work with my files and all scaling, dimension, etc will work later on

Your image hasn’t uploaded. Try again, and (perhaps?) wait a bit longer before closing the post, and check that the image appears in the preview window on the forum.

I Uploaded the export .dwg window.
Did it appear here?

Yes, that worked. Can you remove the ‘blank’ in your earlier post, just to tidy up?

Sorry, | don’t know enough to be able to answer your question about options to use. Do you know what version of AutoCad your engineer is using?

Can you quickly send him/her a modest size test file, to see if he can open it and see what he/she needs to?

Tried sending one earlier, didn’t want to keep sending until I figured out the best format and not waste his time.

Fair enough. Wait for someone who uses Layout to export DWGs to respond (I rarely use it at all, and almost never have to export DWG).

PS. I can’t help you with the subject of your question, but having noticed your image didn’t upload, I wanted to help you get a response from someone who can help you from their experience.

Ok Thanks John

Hi sales1, sorry you are having trouble.

Based on the settings you have set, the file should export fine and the results will be as follows:

  1. The LayOut dimensions and notes will be exported on the layers you establish in LayOut to autocad modelspace.
  2. With the “Export for SketchUp” option selected, the SketchUp linework will be exported to modelspace based on the scale in LayOut paperspace - So if this is exported as 1" = 1’-0" it will need to be scaled up by x12 once in autocad.

It might be best not to use the “Export for SketchUp” option though. By not having it selected your file will be exported as follows:

  1. Dimensions and notes created in LayOut will be contained in the paperspace in autocad.
  2. The SketchUp file will be exported as 1:1 and will be contained in the modelspace. The modelspace will be scaled based on the scale you had it set to in LayOut. (You must set a scale in LO for the export to export correctly).

Please note, if your LayOut viewport is Raster rendered, either change it to Vector or Hybrid or select the “Export raster-rendered SketchUp models as Hybrid-rendered” option on the DWG export dialog. It may be that your viewport is raster rendered and if so will only display an image and not the linework when exported.

Also would you able to share your file? I may be missing something. You could PM it to me.

Trent

1 Like

Hi Trent,

The method of exporting for SketchUp is the only export method that correctly stacks layout stacked viewports into DWG model space.

There probably should be a third method that is a mix between both: stacking viewports in model space and sending Layout specific entities to papers pace. Stacking viewports is (still) standard workflow :wink:

Best,

João

2 Likes

Not sure why you have “export hidden layers” turned on… you want the engineer to see things you have specifically turned off?

I do that a lot of times. Two examples:

  • Engineering overlays are usually inside SketchUp and in Layout I have a viewport for them that is usually hidden.

  • I have faces that I use to retrieve areas, which have awkward colors and that I usually have in a viewport per plan which is also hidden.

Both are good for CAD exports and they export though they are hidden in DWG

Hi Trent.
I have now attempted the following when exporting to .Dwg:
Document setup: references: Purge
In the export to .Dwg window: i have selected the following

Please see the attached drawing that I exported to .dwg format based on the above…
Are you able to tell if it can be opened and modified with AutoCad?
I noticed that when I saved the DWG in my files, LO added an image of the Sketchup version of the drawing. Do I need to send that to my engineer as well?
In terms of Scaling, you wrote the following:
The modelspace will be scaled based on the scale you had it set to in LayOut. (You must set a scale in LO for the export to export correctly).

The only thing I can see that resembles units in LO is under File: Document setup: Units, which is set to Fractional 1/4" = 1’
Last items:
Is there a way to lighten the background on a drawing when importing into LO? My drawings are a medium grey toned background which obscures the drawing and makes it harder to see the lines on the page, especially after printing it out as a PDf drawing… Can I make the drawing background lighter or the lines darker?
I also noticed the screenshot that my engineer sent me his drawing background was black with white lines. Is that normal? Do I need to change a setting for that?
Thanks,
Andy

Foundation plan.dwg (126 KB)

Hi sales1,
Yes, I am able to open the file in acad and it appears that the data came over correctly with the exception of some dimensions. They appear to not be connected to the SU file so are displaying the paperspace diimension.

The image that LO added is essentially the raster render of the SketchUp view. This can be included but does not need to be included to your consultants. If you set the SketchUp viewport to Vector and not using the “Export raster-rendered SketchUp models as Hybrid-rendered” checkbox it will export just the linework and not create an image.

The scale is set by selecting the SketchUp model viewport, and setting the scale from the SketchUp model panel. This scale will be passed to AutoCad as a scaled viewport.

Using the setting you used this time, the model is correctly exported to the model space at 1:1 so your consultants will not need to scale it up using these options.

Without seeing your file I am guessing that the style you are using is why the background may be too dark. You can turn off the background via selecting the SU model and unchecking the background from the SketchUp model panel, Style tab.

The screen shot your engineer sent sounds correct. The missing image .png is seen accross the background. This can be unloaded within acad but is not needed.

If possibile could you send me or SketchUp support the .layout file?

Hello.
Here is a screenshot of my drawing in LO
I have changed it to Vector, and the dark background disappeared.
I checked the scale setting as well

Here is a problem i ran into with a different drawing when switching to Vector:
a whole bunch of drawing lines disappeared.

here is the drawing in hybrid format

Hi sales1, it looks like the camera did not follow correctly. Are you on 2021?

Trent

Hi Trent
I am having this same trouble I mentioned in my last message, with at least two of my drawings.
Please advise.
Is there a chance we can chat over the phone?
I need to get these drawings out as soon as possible
Thanks,
from Andy

Looks like i need to download an update.

Downloaded 2021 version. Same problems

How late in the day today will you be monitoring our conversation?
I would like to resolve this

I just sent you a personal message.

Trent