Auth token cannot be used. The user must sign in

Trying to work but getting the following message

Auth token cannot be used. The user must sign in.

I need to sort this urgently, can anyone help?

Is there a windows fix for this please?

Sign out of SketchUp and Layout

Quit them both

Sign in again

1 Like

Tried that, no luck though
Thanks though

Try this instead

Go to a file explorer window

%appdata%\SketchUp\SketchUp 2022\SketchUp
into the address bar

Delete the file called login_session.dat

quit sketchup/layout restart computer

Try again

Apologies, my person didn’t follow instructions before and didn’t sign out then back in
I’ve now done this and it worked brilliantly

1 Like

Hi there, I’m having the same issue with a MAC its very difficult to work with this. I use SketchupPro and have a license. I tried restarting, deleting the app and redownloading it (sketchup 22) and nothing seems to work. I keep getting signed out and impossible to sign back in whilst I am using the program. I getthis message: “You can continue to use SketchUp, but you will not be allowed to start a new file or open an existing file.”

Thank you for helping with this!

1 Like

I was told to sign out of SketchUp then sign back in, it worked for me

1 Like

I’m having the same issue!! So annoying to keep getting this “Auth token cannot be used. The user must sign in” message. Will try logging out again.

I get this same message when trying to open a second file when working in SketchUp. I click the OK button the go to “Manage Licenses.” Then I click the “Sign In” button and the dialog box grays out and nothing else happens. I go to the Trimble web site and sign in there but that has no effect. I can sill work, but I can only have one file open at a time. To access the information in the second file I have to import the whole file into my model. This is annoying in the extreme.

I’ve tried following the steps on the support page by * Locate and delete the “login_session.dat” file But when I start sketchup to login again I get this error message on my brownser:

{“error”: “invalid_request”, “error_description”: “Invalid token error.”}

Try refreshing the page a few times, while holding the Cntr key

1 Like

I’ve been having the same issue today - it worked for me on the second attempt (the sign-in window said it was relaunching the browser page, and then I got the normal sign-in).

Terrifying… Trimble!! Thanks a lot!!

I’ve been having the same problem since I switched from iMac to MacStudio. Several times a day Sketchup crashes + randomly getting the message that ’ Auth token cannot be used…’ Reinstalled Sketchup several times and deleted the log files but that brought me nothing. It’s extremely annoying and almost unworkable. Hope that an update will solve this problem? Cause I don’t know what else I can do. Maybe switch to an older version? Big problem then is that I cannot open the files I made in the 2022 version…

1 Like

The auth token can’t be used message relates to whether you are signed in or not. Most times a sign out and in again fixes things. Sometimes you have to close SketchUp after signing out, to give SketchUp a fresh chance to update some support files.

When that doesn’t work you can delete a login file, which then gets regenerated. For your case, where you have crashing, it’s more likely that you’ll need to delete that file. Follow the steps in the article, and it should clear any auth token messages. You may have an unrelated problem that is causing the crashing.

Is this a recently occurring problem? I have never had this issue before but it has cropped up in the past few days, and happens every time I use SketchUp. It’s annoying to have to close the program and sign in again every time, especially if I have multiple files open. Hopefully this is an issue that can be resolved in an update. So far I think it has been happening more commonly when trying to open a file directly from the Mac files browser.

Edit: I think for me it only happens when already signed in and using Sketchup, and then wanting to open another file. I can be signed in working on a model whilst at the same time not signed in and thus unable to open a new file.

This is actually turning into a complete nightmare. Every time I use SketchUp I seem to get hit with this notification. Since 5th October I have had to go through the whole log out - log in thing (with 2 factor authentication) 7 times.

Before June this year I had never encountered this kind of problem. I have been using SketchUp since 2009 so this feels like a massive regression.

There were some issues recently at our end of things. Those problems are solved now, and I hope we’re finished with unexpected auth token and other sign in issues.

Please let me know if new cases come up.

I keep having this authenticity token issue every time as well. The only thing that works is to quit and come back in. But after that it only lets you have one sketchup file open at once ( you get the authenticity token message if you try to have 2 files open at once) and that doesn’t work for my needs.
This has never happened before until recently. I am on a Mac Big Sur OS. What is a long term fix, Trimble? I have signed repeatedly into Trimble, etc and it says my license is valid and that I’m signed in. I am really having a hard time here.

Sign out before you quit
Then start SketchUp