Auth token cannot be used - the user must sign in

Hello! Just started tonight (March 9) - I get an error message:

Auth token cannot be used. The user must sign in.

When starting up Sketchup it shows I’m signed in and that my subscription status is active. When the file is open, if I go to Sketchup → Manage Licenses it asks me to sign in to access my subscription. When I click Sign In the window goes a little lighter but nothing happens. I’ve gone into Trimble to check on my account, and deactivated all my computers, and tried again but no change.

I can sign into and Trimble but otherwise having problems within the program. Any help is appreciated - this is a main tool for my work.


I am having the exact same problem.


I can confirm there is some sort of issue with licensing in 2022. I can Manage my license from within 2021 but 2022 does as @charlesvarga describes. It just doesn’t let you do anything when you click on sign in.


If you see this message, it is best to Sign out through the Help menu, then sign back in (same Help menu)

The Welcome screen uses the (corrupted) token, probably, and so it get’s stuck.

The error message could be more specific.


Even trying to sign out using Help/Sign out… you get this error
and you aren’t signed out, thankfully.

1 Like

Ditto for me on all of above errors this morning. Was good until at least 8pm East Coast US time yesterday.

1 Like

Best to close SketchUp and delete the login_session.dat file in the user AppData (Roaming/SketchUp/SketchUp 2022/SketchUp/)


Work-around seems to be double-clicking on a file in file manager which allows me to open and work on and save existing files.

Mike, thanks for the fix. Did that and it took me back through the web login upon launch. All good now

Hey @MikeWayzovski. Any idea where that would be on a mac?

I seem to be having the same problem.
I have been using Sketchup for about 10 years and recently updated to 22.0.353 and it was working fine until yesterday. Now I get this error message: “Auth token cannot be used.The user must sign in. You can continue to use Sketchup but you will not be allowed to start a new file or open an existing file.” I can still open and use Sketchup 21.1.331 but cannot open files I have saved in the newer version. What is going on here??

1 Like

Same problem here. Meeting in one hour.

Thank you Mike. I did what you recommended and it seems to be working again.

Wow, looks like everyone had the same problem at the same time. I have a Mac and was not able to find the login file but was able to sign out/in through the help menu. Thanks for the tip!

This happened to me last evening and is still happening. Thanks for the tips y’all. Fingers crossed.

Thanks for the suggestion Mike! Can confirm for me this morning that signing out from the Help pull down menu (get a web page that tells me I’m signed out of all things Sketchup) and then signing in through the Help pull down menu (pops up a web page for me to sign in) worked for me this morning.

I was able to open several new Sketchup windows and saved projects without the error. If something changes I’ll update, but for now everything seems back to normal.


~/Library/Application Support/SketchUp 2022/login_session.dat


That worked for me on a Mac. Thanks.

1 Like

Thank you Mike! Signing out and then signing back in specifically through the Help menu worked for me. I’m on a Mac.

Thanks @MikeWayzovski & @colin. Worked like a charm on the M1.