Auth token cannot be used - the user must sign in

Thanks @MikeWayzovski & @colin. Worked like a charm on the M1.

Tried all of the above. I can open a file, but hobbled by “Auth token cannot be used - user must sign in”
Fix the login mess!

1 Like

What a mess. I work for a SketchUp reseller. Multiple customers received this error message.
When will this be fixed?

Muchas gracias Mike, solucionado el problema, ahora funciona perfectamente

Sure, it’s a mess, but we might be seeing this more and more, especially with all the activity going on in the cyberworld.
Part of the reason why Trimble is having an ISO certification
is that is trying to protect it’s users and data. That means that when user’s automatically sign in with yesterday’s token, it might fail overnight…

I am not suggesting that it has anything to do with cyber attacks, but it might just relate to recent failure of the log in servers:

We have seen this earlier a few months ago.


Just adding my name to this issue. All was running great (2022 version) until I opened 2021 version by accident and now I get this error too. I will try Charles and Mikes recommendation.

The error has gone away so far after I deleted login_session.dat file and signed in again as Mike recommended.

As a reference my previous Sketchup Pro version was 2021 Maintenance (not sure it makes a difference)

If error reoccurs I’ll post it then. Thanks All for your help!

Same problem here. Does anyone have any suggestions for how to correct this on a Mac OS? There is no dropdown menu for help on a Mac (that I can find anyway). Any help would be greatly appreciated.


can you please share what you did that worked on aMac? Thanks.

The dropdown menu of applications are only visible of the current active app, you need to check the icons in the dock and ‘activate’ the app to see its menu.

Their reply was right after Mike had given this file path:

~/Library/Application Support/SketchUp 2022/login_session.dat

If you switch to Finder, then choose Go to Folder… from the Go menu, paste in that path, and delete the file that you are taken to. Then reopen SketchUp.

Thank You! - I had the same issue - your help saved me MUCH frustration.

Same problem here, I have to restart my computer to make SketchUp work again.
Good to know I am not only one having this problem.

I went to go delete the login_session.dat file, and there was no SketchUp 2022 folder present. Something must have gone wrong with my update. I simply did the update again and reinstalled. Problem solved. Thanks @MikeWayzovski

1 Like

Wow! Painful, but this seemed to work. Thanks.

I’ve made Windows batch files for deleting the auth. token file of the latest SU versions by simply running.

Glad to know I wasn’t the only one! Thanks for the help. I have a mac–did the sign out/sign in through the Help menu on sketchup and the issue is fixed.

May I ask where you get this nice server status graph from?

1 Like

This topic was automatically closed after 186 days. New replies are no longer allowed.