As severe as a problem can be. Total file deletions in entire working folder


#1

I have been working on a huge project for over one year. It contains over 3 million edges and over 1 million faces. It is actually a primary model that contains approximately 500 sub models, most of them about equivalent to a single, detailed and complex model. Nearly all of that has been done in SK8, until the last two weeks. I decided to put SU2015 to the test and it has failed as miserably as is possible. I have been having Bug Splats the last two days and have been trouble shooting this. I have already submitted several BS reports including one with a full write up of what I can tell about the issue, which isn’t much.

This project is intended to push SketchUp to its limits and it does. I have been using SU since day one when it first became available and am at the very high end of user knowledge and competence. I have been programming computers since 1964 so I do know what I am doing, specifically and generally. The machine I currently use is this:

Computer:
OS Name Microsoft Windows 7 Professional
Version 6.1.7601 Service Pack 1 Build 7601
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name TOPDOG
System Manufacturer To be filled by O.E.M.
System Model To be filled by O.E.M.
System Type x64-based PC
Processor AMD FX™-8350 Eight-Core Processor, 4013 Mhz, 4 Core(s), 8 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. 1903, 7/11/2013
SMBIOS Version 2.7
Windows Directory C:\Windows
System Directory C:\Windows\system32
Boot Device \Device\HarddiskVolume4
Locale United States
Hardware Abstraction Layer Version = "6.1.7601.17514"
User Name TopDog\Evan
Time Zone Pacific Standard Time
Installed Physical Memory (RAM) 32.0 GB
Total Physical Memory 31.9 GB
Available Physical Memory 28.7 GB
Total Virtual Memory 34.4 GB
Available Virtual Memory 30.8 GB

I have six drives, 3 are SSD and 3 are spinners, 2 spinners are on USB3. Total 7 terrabytes.

It is my latest build. I have many years of professional training in the computer science arena and have a Masters in the field.

As I have been trouble shooting this series of bug splats I have not been able to discover anything specific to point to the cause. Nearly any action can result in a BS, including copy and paste, simply moving an object next to another, creating a group or component, pasting something into another existing group or just drawing or deleting something.

I keep the working files on another drive so I must back up that drive separately from the system drive. I do system backups every day but only back up the various work drives once in a while. I last backed up this work drive on Jan 12th so the damage isn’t too bad but it is still as nasty as it can be from a piece of software.

I had just had another bug splat. Upon restarting SU2015 I was not able to load the work file. The reason turns out to be that somehow, during the bug splat, all the files in that particular directory were erased. Because it is an SSD drive that happens nearly instantly, even for a number of large files. I do not use the recycle bin so deletions are immediately permanent. Because of the file sizes I routinely work with a recycle bin is another management headache. I will be enabling it for the near future. There is zero chance that I did anything that could have resulted in the file deletions other than use SU2015. That is what I was working on and the files were present before this bug splat and after it they have vanished. They have not been moved anywhere nor are there any temp copies on drive C or anywhere else. The actual file sizes are not as large as you might expect. I know many ways to vastly reduce the file sizes without compromising the model quality This model was running about 53 megs.

For me this is just a hobby as I am both retired and severely disabled. For somebody trying to make a living this would be a disaster. I should not have to extend my automatic daily backup system to include my Sketchup work files. To account for this it would need to be as often as the autosave system. But those files were erased along with my intentional saves every 20 minutes or so. I have to go back about 100 hours of work. I can repair the damage faster than that because I do keep separate copies of all the components as I create them.

At this point I do not recommend using SketchUp 2015 for anything that matters.


#2

Evan
Bunner. If you are trying other things;

  1. As of VISTA MS greatly enhanced the task manager to give much better insight what is going on. Start task manager, at bottom select resource manager then will have displays that may give idea what is happening;
  2. Try update of graphics drivers seems to be a general theme in TS recommendation’s. SU 2015 SU converted to 64 bit vs 32 previously
  3. Mark Russinovich system internals http://blogs.technet.com/b/sysinternals/ has a number of TS tools you can run w/o installing to help with system insight also. In fact I have them loaded on a USB stick and you can go to a machine use that to TS w/o installing them.
    Good Luck

#3

I have the very latest graphics drivers installed. I keep the system up to date since I push it hard. It’s what I do all day because of my disabilities.

I have managed to recover nearly all of the files from the drive since it isn’t the system drive and the only activity it sees is SketchUp use. I am still using 2015 because I want to see if I can figure out what is behind this. So far the only clue I have is that it may be involved with having components appear when hidden on a layer and then enabled. SU will take into account such hidden items and even display some of them to some extent even while hidden, depending on the circumstances. If those items also have validation errors then they may be causing the crashes the moment they must be taken into account for display.

That leads to another issue that seems to be related. I had very recently updated the video drive because of SketchUp wide display issue that looks the same as z-fighting but isn’t. For some reason it was calculating display plane priority with very low resolution, perhaps as integers instead of floating point.

The very odd thing about that is it was 100% tied to the actual model file, not system settings. Opening an older version of the same file and it was fine. Open the versions from after it began a few days ago and it was very unfine. I cannot think of any possible change to the model that could account for that but it is very obviously something in the model itself, not the general system settings in SU.

I have already checked everything in the logs in task manager etc and there is nothing there that gives a clue. Nothing I see in the mini dump that BS sends seems very informative either but I don’t know that much about that part of the system.

I have the sysinternals package and have used his goodies since before he was bought by MS. He is one of the top “white hat” hackers around.


#4

One comment you made there about the components and hidden layers leads me to ask are you using layers correctly.
Raw geometry needs to be on Layer0 and layer0 should be almost always the active layer.
Just checking as lots of advanced users still miss this issue.

Many bugsplatts are caused by 3rd party plugins, there are quite a few that are notorious for it.
What plugins are you using and how did you install them.
Did you just copy the plugins folder across from SU8 or did you install fresh copies of all your plugins.
2015 uses a different ruby system from SU8 and many plugins need to be updated for this. Not to mention many that need to be altered to work correctly with 64bit.
The are several rendering systems that will cause splatts if you don’t have their very latest version.


#5

I keep all but the upper component in layer zero. I check now and then to catch any that I may have accidentally included in a new component. It can certainly cause some problems if done otherwise. I run many plugins. I have tested and vetted them carefully and have a favourite set I use. Occasionally I will modify them to alter operation or at the least have them occupy a different menu. There is still the possibility that one or more are sometimes causing problems but I very much doubt that in this case. Only one of many crashes seemed to be related to the use of a plugin but that may have been simply bad timing since that plugin usually works well. There are many that do no coexist well.

I install the plugins automatically if RBZ, otherwise I do it myself. I am very aware of the requirements in the case of manual installation. I write software for various reasons but I have not written any plugins for SU. I have written plugins for a CAD-CAM program called CAM-BAM. It makes it possible to create numerous polygonal shapes including meshes of everything from 2D and 3D spirals to spheres to triangular solids to some very unusual solids. One of these days I just might translate it to Ruby. There isn’t anything like it currently available. If you have anything to do with CNC machining and use CAM-BAM it is available here:

http://ixian.ca/server/SpiralPollyGone_v24.vbs

The version that does meshes is here:

http://ixian.ca/server/pollygonemesh_V5.vbs

Since CAM-BAM will create DXF files it is possible to use it to create model shapes in CAM-BAM and then transfer that to SketchUp as a 3D DXF.


#6

You still skirted around the Plugins question.


Are all of your Plugins the latest available ?
There are significant changes from v8 to v2015.
Most Plugins have been updated to suit the new Ruby2 etc…
Install the very latest ones.
After that, if you still have only some earlier versions available, do not copy from v8 Plugins folder to v2015 Plugins folder, unless you really have to, then do it gradually and test to test for compatibility.
Are all of you Plugins from “trusted sources” ?
e.g. Extensions Warehouse, SketchUcation PluginStore, well-known author’s sites [like Waat] etc.
There is a very very slight chance that you have a malicious RB/RBS loading.
It is quite possible to delete files using Ruby, so the emptied folder when it does the BS sounds worrying…
When you say you have been changing Ruby files have you added or changed any ‘File’ methods ?
Can you post a list of the base level Plugins folder files/subfolder names…

#7

AFAIK

That is how I do it

Yes, I download from SketchUcation. I have user name Evan. It’s rather old and I haven’t posted there for a long time.

I assume you are a “trusted source”? (grin) I have not changed any of the methods in any of the more recent ones. Ones I did change are no longer in use. I check plugins carefully before using them with projects that matter. Checking includes reviewing the code.

The file deletion is starting to look like it may be a BugSplat issue. BugSplat has now attempted three times to do something involving the local file system other than reading something like a log. I am aware that BugSplat is a separate crash tracking service. Bugsplat has once asked to map a network drive, another time asked to insert a disk in a non-existent drive and another time attempted to access a drive not currently enabled. It has also connected to the http://www.bugsplatsoftware.com/appCrashed/?vendor=su15win site which I assume is NOT a normal part of the process since it also gave me the instance count
"Crash Report #42668"


#8

See here for plugin directory list:

http://ixian.ca/server/2015plugins.txt


#9

for starters sandboxtools.rb is a really old SU plugin that is superseded su_sandbox.rb
that could definitely cause clashes…
ocean_extension.rb another old SU one that may also be an issue…

you have a other old stuff and also the updates, they could share code…
john


#10

You have an AMD processor, do you have an AMD graphics card too? As a longtime user of SU, you should know that AMD isn’t geared toward 3D modeling needs. And lately, their graphics drivers have been having more issues with SU due to their return to less OpenGL support than their NVIDIA counterparts. SU has been increasing the reliance on OpenGL for more operations, even saving files.

You haven’t mentioned what troubleshooting has been done. Disable hardware acceleration from Window > Preferences > OpenGL?

Sounds like you need to scrape your plugin directory and download/install anew.


#11

I have an ASUS Nvidia 760 with 2 gigs ram. I didn’t notice it wasn’t in the system specs. I am very familiar with the issues with AMD/ATI. Ever since AMD took over ATI it has been a slow downhill drift. The CPUs do just fine although I would really like an upgrade and am waiting for the clock speed to step up.

CAD software is extremely dependent on the CPU clock speed because the type of work to be done is not compatible with parallel processing. That applies to all CAD software and SketchUp falls in that category. AMD is generally about the same FPU speed as Intel at the same CPU clock rate but AMD beats Intel in clock speed. I am currently running at 4.3 Ghz but am looking to upgrade to over 5. AMD beats Intel on price by a very wide margin. I do not have unlimited funds.

What is really the answer is to move over to using the Video Card with the GPU and PhysX to take over from the CPU FPU. The improvements can be incredible, in the range of factors of ten or more.

I don’t think the plugins are the issue. Almost without exception these crashes have been happening when no plugin was executing and so far I have had maybe 30 or so crashes in a couple of days. The plugin configuration has not changed but the crash rate sure has. I have done beta and alpha testing for a number of software makers over the years and finding what causes bugs is something I have a lot of experience with, never mind the software I used to write. I only dabble a bit these days but I used to play with straight machine language modules 10,000 lines and more with 1000sands of variables. ML is where I learned to program and is still my favourite way to work.

Even if plugins are sharing code or otherwise able to conflict, no conflict will be happening if they are not executing at the same time. It is not common for plugins to be operating simultaneously. There are some that can do that by operating full time in the background but not most. Nearly all plugins require explicit activation to perform whatever function they provide. The rest of the time the plugin may just as well not be installed, it makes no difference if it isn’t being used. This assumes no silly mistakes have been made using global variables etc. That is one of the things I look for when checking out a plugin.

I have found in my testing work in the past that blaming plugins is a programming teams most often used excuse for problems. It makes it possible to shift the blame to some place where they cannot be expected to provide a fix.

What is happening here is a problem that has something to do with layers and how “hidden” contents of a layer are not actually always hidden. Because those contents must always be taken into account there are situations where the existence of an entity will be displayed even though hidden. That may well be producing some sort of conflict but it has nothing to do with plugins.

As for the deletion issue, I think the place to start is BugSplat. It should not be trying to map a network drive or trying to write to a non-existent disk. It almost seems like something was left in place from the system used to build the app.


#12

Some plugins have been known to cause problems simply by loading.
To rule out plugins as your problem disable the plugins folder.
If you are still getting crashes with no plugins loading then you are correct that it isn’t any of them.
Make sure you know all your plugins, you haven’t mentioned any render engines and quite often they are installed via .exe which places them elsewhere. V-ray for example was notorious for causing all sorts of problems.
Your text list of your plugins is a touch confusing also, knowing where they are often helps to spot problems, and F:\Sketchup_2015\plugins isn’t a default location.
You also don’t appear to have the most useful plugin of all, The Scetchucation toolset.


#13

Plugin directory has moved to Application Data with SU14 - on the C drive.

Part of troubleshooting means going back to a clean baseline. No one from the SU team who can retrieve your bug splats has piped in. Those of us answering you are working blind, but with years of experience too. Your non-traditional installation is a variable we need to deal with.

Keep submitting your bug splats. The developers need to keep track of frequency of the problems that appear to prioritize what can be fixed.

Yes, SU should like your GPU.

Some people have be able to handle 400 MB SKP files. Lots of people are at the 100 MB range. Each version of SU has made notable improvements handling the demands of larger files.

Are you using a modeling Style that’s been optimize for faster modeling performance?


#14

F:\Sketchup_2015\plugins is where I copied them to make a list. I do not mess around in C drive any more than I must. The installation is fully standard.

I am not currently running any renderers but will be. I have frequently used POV-Ray in the past from since it was on the Amiga but I am considering buying something in the near future. I have also used Kerky and assisted in the development of a couple of others.

As for a “clean baseline” it is as clean as it can get other than removing the plugins. I just started playing with 2015 a couple of weeks ago.

I have disabled bugsplat. I do not trust it. There is no way it should be trying to do weird things like trying to map a drive on the network. It is still crashing but not as often. I am still figuring out what is happening and I have noticed a few things that always seem to be happening just before a crash. The real problem is trying to figure out a way to make a small file that will replicate the problem. Once (if) I can do that then there is a way to figure it out. I have done this many times before. When beta testing the thing that I am best at is causing crashes.

There are some other issues I am noticing too. It seems to me that 2015 is using a higher level of accuracy, as in more decimal places before round off occurs. This is causing some major problems with large planar areas that SU8 thinks are actually planar but 2015 does not. It may even be possible that this is a part of the problem. Because of what and how I am modelling I am running the model at a huge scaleup of 1 metre = 1 inch. That means even very small inaccuracies will be caught as non-planarity. A large number of large planes that were fine in 8 are being broken up by 2015 as soon as I refresh the scale. I tend to build models that are very large but also contain a lot of very fine detail. Very large means kilometres and fine means fractions of a millimetre. I am very good at using all the tricks that are available to insure accuracy but there are limits. I do machining on a fairly large CNC mill I designed and built that is capable of creating diffraction gratings so working at high precision it what I like to do.


#15

?
you have reiterated your skills but not tried suggestions.
I wish you well.


#16

Get SketchUcation Toolset and disable some Plugins…
Them retest to see who the culprits are,

The ones mentioned are very old - where there are newer “su_” equivalents supplied the older “sandbox” etc should not be in manually added into v2015’s Plugins folder - remove them.
Also Fredo’s LibTraductor.rb is now within the Lib Fredo ? It should not be loose…
The utilities.rb is old too.
The OSCoolean is known to be incompatible with >v2013
What are those Lib6…rb files ?
There are several tools dated pre-2013 which might be suspects regarding their newness and compatibility…

etc…


#17

I tried that on my mac at one point and crashed SU on every minor error, it is deeply integrated into SU…
If SU can’t write the errors to BugSplat, SU crashes…

and I join the throng in advising that you must disable all plugins before for any testing can be credible…
just use Sketchup.plugins_disabled=true and turn back on with Sketchup.plugins_disabled=false
john


#18

Disabling plugins completely will show if it’s a plugin-issue, but not which plugin[s] == disaster…

If you use the SketchUcation Toolset ‘Plugins Manager’ to make some Sets, you can easily disable suspected Plugins and restart to see if they were creating the issues.
You can enable/disable Plugins [Sets] until you zoom in on the culprit[s].

You’ve already been given several pointers to the usual-suspects…


#19

BugSplat is not integrated into SketchUp at all. It is an entirely separate piece of software that lives outside of Sketchup entirely and is provided as a crash monitor by a third party.

See for yourself. SketchUp is not dependent on the existence of BugSplat. BugSplat reads whatever it has been “told” to read during operation.

I will be trying some operation time without the plugins but I am not interested in letting what acts like a virus loose in my machine.

I forgot to mention that I won’t be disabling the plugins because there is one that I must have to work. I will still be running MoveIt (Mover 2).

edit: It also might be helpful to see this:

Edges 2958142
Faces 1225641
Component instances 14711
Groups 745
Components definitions 1242
Layers 67
materials 212
Styles 1

The rest are zero. The style is my own settings that work best for this.


#20

although you seem reluctant to allow for any opinion that is not inline with your own…

for the benefit of others who may be following…

I would consider this integrated…

Add BugSplat to your application as follows:
mac

Add the BugSplat.Framework to your Cocoa project.
Add a Copy Files build step to the Targets to embed the framework onto your application.
Import the BugSplat exception handler class: #import <BugSplat/BugSplat.h>.
Add BugSplat member to the interface for your application class: BugSplat* bugSplat;.
In the init method for your class, send the bugSplat object an initWithVendormessage as shown in the sample code above for MyCocoaCrasher.
Optionally, use these methods to set options:
setDescription - a description of your application
addAdditionalFiles - add a log file, system info, etc.
setQuietMode - suppress all dialogs (for server applications)

windows

Add BugSplat to your application as follows:
Include
"BugSplat.h"
Create an instance of
MiniDmpSender
following the example in myCrasher. The
MiniDmpSender
constructor requires three parameters: BugSplat database, application name and version. The BugSplat database is created and selected on the Databases page. Typically, you will create a new database for each major release of your product. You supply application name and version to match your product release. These must be used when uploading symbol files for your application.
Link your application to
"BugSplat.lib"
Add
"BsSndRpt.exe"
“BugSplat.dll”
“BugSplatRC.dll"
and the
"DBGHELP.dll”

simply disabling the parts will not stop SU from looking for them on mac or windows.

john